Pitool Beta Test Release for Brainwarp 1.0


When you are in a game hit Alt+Tab and go to Pitool and see if FFR is active.


Thanks ebjornen.

LOL in good old Pimax way … it just kicked in for no obvious reason. The only thing I was aware of doing differently on the last occasion was starting SteamVR before Pitool, all’s well that ends well :grinning:

So maybe a bit erratic but I can confirm FFR works on this version. In Elite Dangerous (ED), FFR on ‘conservative’ setting, sat in the hanger, I was surprised to be getting a big jump from 48 FPS to 69 FPS.

I’ve been very lucky and never noticed distortion in ED (normal FOV). However this was the first time. The middle 80%/90% had clarity, but the last 10% at the sides was blurry / shimmering. ED has bright wrap around menus so that might make it more noticeable.

I could definitely live with it, but seems easier just to turn FFR off and Smart Smoothing on. 100% clarity, FPS drop to a solid 45 but Smart Smoothing just boosts it back up to 90?


Are your graphics drivers up to date?

FFR in this version has worked flawlessly for me on my 2060 and I always start SteamVR using the “Start SteamVR” button in Pitool. I also restart steam VR whenever I change the FFR setting.

I get around a 38-40% boost in FPS with “conservative” (the lowest) setting.

I did a performance test with FFR in Elite and Skyrim and posted it in the forum.

Smart Smoothing does seem better in your case. FFR might be preferred to increase performance in games where smart smoothing can thorw off the timing. Or if you are like me and can’t get over 45 FPS in stations in Elite without FFR so SmartSmoothing won’t kick in :sob:

-5 brightness with 1 contrast is amazing in Elite on my 5k in this version.


I was finally able to try Elite Dangerous.
The setting is great!

My base setting.
Brightness : Low
Contrast : 1
Brightness : -4
It is too dark in the dark section.

Who want to enjoy the dark of space.
Choose according to preference.
Brightness : -3 to -1

Thank you for the good information.


Minecraft VR mode Vivecraft stopped working with this update. Used to work with Pitool version 91. Now the game just shows a blank SteamVR room and does not load in the Pimax 5K. The monitor shows the game is loaded though.


That is the exact same case as Google Earth VR!


That crossed my mind too, so I double checked and yes.

It was your post that inspired me to test FFR and like you I did see a significant performance improvement. Your explanation above makes perfect sense to me so thanks I understand now.

What was a nice surprise for me with this beta Pitool, was I could just sit in game and adjust FFR (same too for brightness and contrast) on the fly and the changes happened immediately which made testing/choosing settings very easy :+1:


Yeah man i have the same problem too. The game is running but i am just stuck in the room with all the lines


I setup a support ticket for Google Earth VR not loading in 121 beta (loads on the monitor but not the HMD) After a few exchanges with pimax they are calling this a bug that they will fix in the “future”
I would encourage any one having issues with 121 to setup a support ticket so they know what the issues are.


I am pretty satisfied with this beta for most of what I play. I decided to buy Creed Rise to Glory from Oculus $17CA on their Easter sale. Pitool picked it up right away and it launched perfectly. The game looks and plays great in my Pimax.
A new workout for this old guy. :sweat_smile:


The only thing I’d like from the new PiTool is have it remember the brainwarp settings and not set them random every time.


I am on a 2080TI and having FFR on gives me this sort of layered visual distortion on ED i end up having to turn it off not sure if its an issue on my part from something.


FFR renders different parts of the screen at different resolutions.

You will see layers where suddenly things are more blocky and this will give a shimmering appearance as you move your head.

Anything other than “Conservative” was unusable for me as the layers are visible easily. Conservative is still had noticeable layers on the edges. More so in some games than others.

So it is probably working as expected for you.

Pimax ideally should have more resolution settings. There 1st layer of resolution decrease was barely noticeable for me in Skyrim. I didn’t notice it at first until I saw a line where the detail of the rock textures decreased. The last layer is too agressive in all 3 settings and makes everything blocks. It is usable for the most part in Elite for me but not Skyrim.

If the 1st layer was the only layer and replaced the last layer it would probably be more usable in games like Skyrim (but less perf gain).

Edit: Though I don’t know the specifics of the implementation. I’ve never seen the 1st layer that I saw in Skyrim in Elite so it also could have been a weird Skyrim issue. Something like LOD or Mipmapping that I never noticed before. Or it just isn’t noticable in Elite.


Lucky tale, the height still not correct.
When I place the headset on the floor and set 0 cm. After I start game, the game height is set to the floor and when I place on my head, it is too high.

I have to hold HMD on my face and use 120 cm. and so the height will be correct.
Problem is it still can’t use the dashboard, so we can’t adjust height by openvr advanced setting tool.

Test Robo Recall, it is correct.
But I think that when we want to play each game between seating game (in front of the pc) and standing game, we have to set room a lot of time and this is very inconvenience.


Of course it is. It isbecause the pixels are off. like it has been with the Rift DKL2. You forgot to mention that ED is totally unplayable like this because of the godawful black smear. This cannot be fixed either. Only be activating the pixels (no more perfect black) the reaction time is at a level where black smear does not become an issue anymore.


It works great ! :slight_smile:


I believe there are two kinds of people:

  • I love true blacks and I can live with some black smear.
  • I hate black smear and I can live with dark grey being the new black.

I belong to the first one. The black smear is somewhat ugly, but to sacrifice true black. NEVER! If I have to choose it’s always true black before smear. Well, I guess there are some people right in the middle and some that don’t care. So we need option “Use true black (XR only)” On/Off


Options are allways good and if you can live with the smear why not. I think too much options are a problem for the typical end use wich is why you’ll never see this with an oculus headset (no brightness and conbtrast either).
The good thing is that pimax is an enthusiast product and handled like this. I am totally supporting such a tickbox. Let people decide what they want.


@Sean.Huang any news about new Pitool ver. to test ?:slight_smile:


Just an update on this. I requested a time frame for the fix and Pimax emailed me today saying about a week for the fix.