Pitool 1.0.1.129 Beta Test Release for Brainwarp 1.0


#322

I also tried that, no effect. You go to task manager and restart it yeah?


#323

One thing i find very anoying with pitool is that it dont seem to save Turn on smart smoothing, i turn it off every time and next time i start pitool its on again :confused:

Btw what is Compatible with vive only game?


#324

Yep, you have to stop it (the screen will flash)
Then start it again (the screen will flash again).

If even by doing that the problem persists, try to delete the lighthouse folder (with the service stopped) and then try again.


#325

It presents the Pimax headsets as “Vive MV” (like a Vive does) to SteamVR instead of presenting it as “Pimax 5K Plus” etc.

Some games only work if they “see” a Vive (Doom 3 BFG VR Fully Possessed for example).

In some of the oldest PiTool releases this was default for backwards compatibility.


#326

I’m not sure why some like yourself have this issue with Smart Smoothing (SM) reverting to ON. Mine stays off once set.

Vive compatability makes Pimax headset look like a Vive for games that need it.


#327

Something that has happened to me with v129 that I forgot to mention. After exiting IL-2, I close SteamVR, then I power off the HMD. At this point I have received the blue screen of death about three times. It may have happened with v121 but if so, it was only once.

I have never had this issue prior to use of the Pimax.


#328

With the BSoD do a search on Code.


#329

At our lab we did have that issue on previous versions but it is no longer happening at least in any of our local setups. I’ll mention that it still is an issue in some instances.


#330
Skip the need for Parallel Projection & try it without SteamVR.

Before continuing any further, one must find the way to launch ATS/ETS2 without Steam...

The camera view requires too much hoop jumping so recommend installing Seat Adjustment No Limits update v 2.1/2.3


Create/Edit .bat with below contents:

@echo off

cd /D "C:\Program Files\Pimax\Plugin\OCSupport"

START OVR_Launcher_x64.exe "X:\Program Files\Steam\steamapps\common\American Truck Simulator\bin\win_x64\amtrucks.exe" -oculus

#331

@CMM Thanks for the tip. I tried this but can’t get it to work. After running the batch file it comes back with an error saying that the OVR Launcher program cannot be found. I just copy and pasted what you wrote to create the batch file. I changed the steam folder location to match my system but my Pimax install is in the same directory as what you wrote so I’m not sure what I’m doing wrong…


#332

If the batch file does not take, remove the line cd /D “C:\Program Files\Pimax\Plugin\OCSupport”

Instead, just copy and paste the contents of “C:\Program Files\Pimax\Plugin\OCSupport” or Symbolic link the files into “X:\Program Files\Steam\steamapps\common\American Truck Simulator\bin\win_x64 folder and retry.


#333

Thanks for trying to help, but that didn’t work either. It still gave error saying it couldn’t find the OVR Launcher.

@park have you tried getting American Truck Simulator to work from the Pitool launcher so that parallel projections is not needed?


#334

Do you have oculus home installed?


#335

Yes, I have it installed


#336

Installing the pimax beta releases (this one and the one before it) both times it got stuck at the very end of the firmware update and didn’t officially finish. The headset itself had returned to a solid red light but the software refused to update to say that it had completed the firmware upgrade.

Restarting made it work well enough. However I’m having an issue with one particular program now.

The Grand Canyon Experience is an early 2016 era program that got a few updates but is still probably kinda old. It requires parallel projection mode to be set or you’ll see a cross eyed view, but if I actually DO set the parallel projection mode, the game crashes.

It pops up a way to send crash dumps to the developer but I don’t know if they’re even going to review them or try to fix things from their end. It’s just weird that the game would be happy to run without parallel projection mode but the visuals would be screwed up, and then I set the parallel projection mode to fix the visuals and it stops working.


#338

I just tried the .129 beta. It works fine in Elite Dangerous, even with smart-smoothing enabled. I didn’t notice any particular visual artifacts and performance was good.


#339

This is what I get in almost every games with this 1.129 as soon as I move my head, don’t know how to call it, some kind of frame delay/ghosting.

Any idea what’s causing this?

(This is not related to PP, I see the same thing even with one eye)


#340

Have you tried with much lower resolution / SS / Pitool quality level ?

I could be wrong but i think that from the game’s point of view, one big difference between PP / non-PP is the res it renders before passing it to the next stage (distortion profile or whatever).


#341

Take your PiTool render setting down to 1, bump your Steam SS both Vid and App to 100% and get rid of your AA and see how the image looks then.

Looks bloody brilliant on the 8K and aside from higher res panels - it is being fed the same res from the computer as the 5K.

If you worry about speed, then PiTool Render at 0.75 works a treat too.


#342

To be honest I dont see a point by doing your way. My input resolutions with PP ( IL2 need that) is high enough to get struggle in Kuban map near ground with dips below 70~65 fps. My input res is around 3750x3120 showed by steamVr app.

Are you tell me that SteamVR SS render engine is better than Pitool render ?