Pitool 1.0.1.129 Beta Test Release for Brainwarp 1.0


#345

I have the same exact problem and watching my FPS drop to like 2-3, couldn’t figure out what’s causing it, even tried going back to 121 and some how the pitool 121 does the same now also…I ended up going back to 109 full release to get rid of the double image


#346

For Oculus games, don´t use PP, and set Pitool SS at 1.0 ALWAYS,


#347

I am beginning to see it that way in certain cases. I find myself leaving Pitool at HMD 1 and making my adjustments in SVR, in games where I turn Smooth on. I get better results in Skyrim for example where I can advance SVR to over 4000x??? although the high 3000’s look just amazing.
From my perspective, the SVR adjustment has a little more wiggle room (can be adjusted more incrementally) in fine tuning the max setting one can get away with especially when Smoothing is on.


#348

Yes, same problem. Looks like a few of us are getting this. Never saw it before in previous PiTool versions. I am using same SS settings as before and also I am using i7-6700K and 2080ti, so it is not like I don’t have enough performance.


#349

Looks like pitool got scared when i wrote now it seem to save so its off :slight_smile:


#350

Looks like we have the same setup. Are you an IL-2 player?


#351

I am saying that for best clarity with PIMAX - don’t use SteamVR SS sliders with their vague % scales but to set them at 100 and use PiTool Render instead.

Pimax knows what resolutions work with the headsets - Steam / Valve do not. Thus one would assume that for render settings it is best to use the Pimax supplied settings software - PiTool.

I have done extensive testing over the last 4 months and my conclusions are that altering Super Sampling in SteamVR is pointless and will result in an image with many artifacts of which then people try to use Anti Aliasing to try and rectify. This then smothers the image and blurs the image result.

By using PiTool Render settings and leaving SteamVR alone and not using Anti Aliasing you will end up with a good quality image which will be relatively sharp and in Il2 that means you can spot and identify aircraft and targets at distance.

It mostly makes sense to change your render setting in PiTool even at the needing to restart SteamVR because most apps don’t have their own built in VR Render System and can not change resolution on the fly. Heck - Il2 can’t change 2D resolution on the fly and requires you to have to restart the sim anyway.

I am an avid Il2 flyer and spend a couple hours at least per day flying it and for the last 4 months in Pimax VR. Pitool 1.129 FFR gives very good performance gains in Il2 and the new Nvidia 430.64 drivers again add to that performance. At least for me in Windows 10 64 with a RTX 2080.

Smart Smoothing though for me was a step backwards in Il2 re introducing image tearing which makes shooting things difficult.:grinning:


#352

But even at 100% SteamVR adjusts the resolution correct?


#353

I’m running 8700k on 2080ti, I’m wondering if this is a 2080ti issue??

I saw another person’s post about the same issue, also running 2080ti


#354

Just tested that theory and instead of PT 1.0 and SVR SS 300% used PT 2.0 and SVR SS 100%. Although the resolution is roughly the same, the image quality isn’t for the app I’m using.

But I hope this is just the exception and in most cases your rule of thumb is correct.

During the development Pimax changed PT RQ and corresponding SVR resolution often.


#355

I have IL2 but haven’t had time to play it much yet. Currently learning F18 in DCS already take up all my VR time.


#356

yeah i got that after short play periods of play with ED, narrowed down to FFR being my culprit. I end up reverting prev beta as image quality def not as uber on ED as prev


#357

As I said it’s not related to PP and even with SS at 1 I get this problem in Lone echo and DCS.


#358

@Sean.Huang

Any idea what’s causing this? Never happened with previous versions of PiTool.

It’s related to head movements, with some kind of overlapping ghosting of previous frames.


#359

post withdrawn…


#360

Finally able to achieve constant 90fps with ss and ffr turned off and .5 render, with ffr on image looks horrible, very stretched and extremly washed out and with ss only on fps dropped to constant 45, without ss and ffr image is sharp but i am getting lot packet loss, players in the lobby suddenly freeze for couple of seconds and start moving again and it happens often and it has happened in the past as well, links to videos.

  1. With ss and ffr on in conservative, normal size and and.5 render - look at last 1/3 video.
    http ://www.twitch.tv/play_n_joyy/v/422968344?sr=a&t=108s.
  2. With ss and ffr turned off and everything else same -http://www.twitch.tv/play_n_joyy/v/422969295?sr=a&t=3s.

#361

I saw something like this, when my framerate was really slow. When I fixed my supersampling factor, the problem went away. I’ve not seen this stuttering/ghosting behavior before. One other thing differed: I had Smart Smoothing enabled, when I saw the double images. That may or may not be related. (I did no investigation.)


#362

Things don’t look good to me below 1.25 with the 8K, at 1 it’s too blurry.
With previous versions even if I was playing at a low frame rate I didn’t get that overlapped mess.


#364

This version of PiTool introduces a lot of visual stuttering in some games (VRChat and Audica while the menu is visible were especially bad while testing) with and without Smart Smoothing enabled. Going back to PiTool 121 fixed the issue.

Tested with Large FOV, Render Scale at 1, Refresh Rate 80Hz, Fixed Foveated Rendering disabled, Parallel Projections disabled, NVIDIA driver 430.39.


#365

I was just playing Fallout 4 VR using the below setup. One thing I noticed was that there seemed to be slightly more issues with textures loading but that could just be due to the fact that I was in a different area of the map than usual. Other than that, it ran about the same as the previous Pitool version. I tried Smart Smoothing ON but that didn’t really work very well for Fallout so I turned it back off. 72 Hz is significantly better than 90 Hz in all versions of the Pitool. Mostly just have to deal with the judder of the weapon where it seems to be correcting the weapon position as opposed to dealing with rendering issues.

Graphics: GTX 2080 Ti
Pitool: 1.0.1.129
FOV: Normal
Render Quality: 1.0
Refresh Rage: 72 hz
Smart Smoothing: Off
FFR: Off
PP: On
Nvidia Driver: 430.64