Pitool 1.0.1.129 Beta Test Release for Brainwarp 1.0


#366

Happens to me as well actually.


#367

Be interesting to see what is causing it.


#368

Mine reverted to ON, once. It’s stayed OFF for a while now.


#369

Thanks for the tips. Indeed a bit less screen arctifacts in IL 2.
Anyway I found that in any popular MP server when we starting our plane from the ground game with FFR and 72 hz mode imediatly „hang” (hearing only sound) or crash.
FFR is working great in single player or scenario missions but sometimes during longer flying works instable and also hang rendering and I have to reboot hmd and services.
@Sean.Huang can you check FFR again


#370

Yeah - I get even in single play il2 FFR hanging SteamVR Render on regular occasion. This coupled with Smart Smoothing not being as good as the previous version (image tearing now like early versions where last version didn’t have any image tearing for the first time I had tested it) I am wondering if it is better to revert back, use That version of Smart Smoothing and leave FFR for a later PiTool version.

The frame benefits of The current Smart Smoothing are good but it just isn’t stable enough for me.


#371

@Sean.Huang IL 2 like games with FFR still need some love :slight_smile:
Also Project Cars 2 ( SteamVR ver.) is not working with FFR in my system.


#372

I haven’t been able to look through the thread in detail but I’m having problems with smart-smoothing. It always shows as inactive. Any solution to this?


#373

I am still experiencing a sort of stuttering where the objects on the screen do not move smoothly when turning my head. This stuttering has occurred on every release after .95 Has anyone else experienced and solved this problem?


#374

Alright after testing for a bit, the “vive compatible” mode really does fix Skyfront VR, which had an issue where the controllers were not working, making the game unusable, due to the headset not being an expected value.

@Sean.Huang @Dallas.Hao
Two games I would like to bring to the attention of the pimax dev team is Neos VR and Project Sansar, the first game runs generally okay but if you attempt to wear an avatar in game (opening menu from underside of left hand, clicking inventory, neos essentials, avatars, double clicking on one of them to spawn, them using trigger to jump into them) the model’s hands vibrate a ton which makes it impossible to move any objects around with precision. I believe I was told the dev gave up on finding a fix, so maybe if you contact them or attempt to give him the api/interface on how to deal with the pimax, I hope it could help a lot.

Notably, Neos VR also has some strange cpu lag issues when running at too high of a resolution beyond the 5k’s native resolution, but that may have just been my pushing my computer so I suppose no worries.
However the pimax does in general have a state where if there is too much cpu lag it will act like the old “steam VR compositor lag” bug at some times and show some very aggressive per-frame/shaking interpolation between where you are looking and where you were just looking. (@proto this may be your problem?)

Lastly, Project Sansar still does not work properly when identifying as a vive under this new settings update, and it did work in a previous update, so I’m not sure if you need to contact them or fix the compatibility a bit more.

Thank you for your time


#375

This could be my problem however I don’t think the issue is with taxing my hardware. This happens in every environment including the stock steam (non home) environment featuring a couple of lines and the base stations. Versions .95 and earlier have no problem running most games at standard setting, although there are other issues present in the old versions that the updates have fixed. Such as the vertical screen tearing. But it’s atleast a usable product on .95 unlike any release after that.


#376

SmartSmoothing definitely needs to be turned off for games like Beat Saber. When the speed is on the high, there are a lot blurring and reprojection causing the hits not properly registered by the game.

On mine, the Vive only menu always reverts to off everytime PiTools is launched. Is there a workaround?


#377

Vivecraft on Minecraft v1.12.2 appears to be working again for me with version 129.

Unfortunately the ray tracing mod by SonicEther does not work in VR. :frowning:


#378

Vivecraft Seems to be the only one working so far with the new update(1.0.1.129), without Visual Stuttering.

I tried Vrchat & Elite dangerous and i keep getting a double image like effect after 5 minutes or so.
like one is still, and then an after image. i know others had said the same(Visual stuttering).

I mean, i can now play Vivecraft 1.13.2 just fine on my own server.
But, i can’t play other games i would like too.

Though, I have not tested Recroom, OrbusVR, Skyrim VR or Subnautica long enough to notice it.
(or can’t remember).

I just said screw it, And went back to 1.0.1.121 And it’s fixed.
Gotta wait for a new update to fix this issue, and i can play MC again. :man_shrugging:


#379

Even the 2080ti can´t run it.


#380

It’s not about if your GPU can run it.

Just not compatible with VR, Has issues with Looks and effects.
(Makes UI completely unreadable, and blacks out the UI in most parts)

Most Shaders that you want to use in VR, you NEED to turn off Motion Blur.
(Or there will be Huge blur effects in your headset, best go to desktop first and turn it off).

Ones that work the best for VR, Is Sildurs Vibrant Shader and Chocapic13 V6.
(Sildurs is the best, specially for FPS and looks for VR)

Should Help @Nifter @Douglaster


#381

Rolled back to PiTool_121_R211_beta.

Performance is the same as 1.0.1.129 but Smart Smoothing works for me in the rolled back PiTool Driver compared to 129.

Not sure with performance as to whether is is Windows Update, Latest Nvidia Drivers or even the recent Pimax 8K firmware update which flashed with the 129 PiTool that has led to performance increase over previous versions.

Of course there have been a few SteamVR Beta updates as well recently. Hard to pin point but even though FFR is not working for me in Il2, Smart Smoothing in PiTool_121_R211_beta works so I take that for the win.:+1:


#382

I was having bad stuttering and double vision (even with parallel on) so I uninstalled Pitools. Restarted the computer. Reinstalled it. I saw that Steam was going crazy and 100% was over 5000 per eye so I dropped it down to 60% (over 2000 per eye). In pitools I left render quality at 1.00 and checked smart smoothing but not parallel projections or compatible with Vive. Normal View and 90Hz every game I tried ran smoother than ever. Even Creed which used to get a little wonky. Everything was clear and sharp too so didn’t feel the need to bump it up. I am only running a 1080 (NOT Ti). Fallout 4 was running smooth too but one eye had objects darker than the other (tried doing the eye brightness and it didn’t help).


#383

if you rollback to an older version, does it flash the device again?


#384

No - keeps the latest firmware flash on the headset.


#385

Do we need to turn off and/or disconnect the headset when installing a new version of PiTool?