Pitool 1.0.1.129 Beta Test Release for Brainwarp 1.0


#406

Well it did not work for me, I booted up the ~PC one evening and steam did an update I then started to play elite dangerous and the image was very low res to what it was the night before, and no matter what I set steamVR to it would not give me the hi res I was use to, I then when and changed default.vrsettings back to what I had it set to originally and I got back the Hi res in the HMD.


#407

then at least try to write the setting to a config file that does not get overwritten on steam updates like
C:\Program Files (x86)\Steam\config\steamvr.vrsettings


#408

As of the latest update which I received yesterday, there doesn’t seem to be a setting for changing the max resolution in steamvr.vrsettings config file. It’s gone.

"{
“DesktopUI” : {
“pairing” : “2373,591,800,600,0”
},
“DismissedWarnings” : {
“DismissableWarning_RunTutorialAgain” : true
},
“GpuSpeed” : {
“gpuSpeed0” : 1369,
“gpuSpeed1” : 1369,
“gpuSpeed2” : 1367,
“gpuSpeed3” : 1363,
“gpuSpeed4” : 1365,
“gpuSpeed5” : 1375,
“gpuSpeed6” : 1370,
“gpuSpeed7” : 1365,
“gpuSpeed8” : 1369,
“gpuSpeed9” : 1361,
“gpuSpeedCount” : 10,
“gpuSpeedDriver” : “26.21.14.3039”,
“gpuSpeedHorsepower” : 1367,
“gpuSpeedRenderTargetScale” : 0.87999999523162842,
“gpuSpeedVendor” : “NVIDIA GeForce RTX 2080 Ti”,
“gpuSpeedVersion” : 2
},
“LastKnown” : {
“HMDManufacturer” : “Pimax VR, Inc.”,
“HMDModel” : “Pimax 5K Plus”
},
“audio” : {
“onPlaybackDevice” : “{0.0.0.00000000}.{d87f93ce-3fed-435f-868a-1f9cc7f2d512}”,
“onRecordDevice” : “{0.0.1.00000000}.{7b4af28f-858f-4793-a343-2cef458645df}”
},
“steam.app.244210” : {
“appName” : “Assetto Corsa”,
“resolutionScale” : 200
},
“steam.app.719950” : {
“appName” : "Windows Mixed Reality for SteamVR “,
“resolutionScale” : 200
},
“steamvr” : {
“background” : “#FF000000”,
“haveStartedTutorialForNativeChaperoneDriver” : true,
“installID” : “16852359998106846861”,
“lastVersionNotice” : “1.4.14”,
“lastVersionNoticeDate” : “1558107610”,
“mirrorViewGeometry” : “0 0 720 400”,
“supersampleScale” : 0.87999999523162842
}
}”


#409

that the file where pimax sets it and it should be active
C:\Program Files\Pimax\SteamVRSupport\drivers\aapvr\resources\settings\default.vrsettings
that file shloud gets active wehn the pitool installer installs the hmd (dll) into steam

if you want it set manually then it should be set in
C:\Program Files (x86)\Steam\config\steamvr.vrsettings
this file is used for user specific extensions and will override the defaults from valve, if you set values that are already default the they will be removed by steam

the file you should not modify is
C:\Program Files (x86)\Steam\steamapps\common\SteamVR\resources\settings\default.vrsettings
the header of the file states clearly

""!!__WARNING__": {
		"000": "DO NOT EDIT THIS FILE TO CHANGE YOUR PERSONAL SETTINGS.",
		"001": "THIS FILE WILL BE REPLACED WHEN STEAMVR UPDATES.",

#410

Pretty sure I just raised the limit today with it actually taking effect. I was under the impression that changing it just allowed you to choose a higher SS value in the slider, but in fact, I’d been using a high number with it limiting the res to what the SteamVR limit was. I changed it and went back with the same % I was using prior and noticed a definite improvement in image quality accompanied with the expected performance impact.

Assetto Corsa looked glorious at 20M+ pixels per eye.


#411

I don’t have a file with that name in that location.

I do have the Pimax config file, which is indeed set to 8192. I’m not convinced that Pimax’s setting was actually being honored, but I’m not going to spend any time investigating it.


#412

The file you edit is in xx/SteamVR/resources/settings.

I’ve just done some exhaustive testing between PiTool .111 and .129, with the conclusion that they are identical performance wise, yet the .111 driver seems to handle smoothing better than the .129 driver. The latest driver is miles better than smoothing in .121, which I don’t think anybody should be using, but I always get the nagging feeling that .111 is just that bit better.

On a side note to smoothing, I drove a tonne of laps with the hz at 90, smoothing off, but only getting 50-55fps due to 300% SteamVR SS slider in Assetto Corsa. I can’t believe how well the 5K+ handles lower, non locked and non native hz. I wouldn’t have lasted 2 minutes in the Rift. yet I banged out 10 or 11 laps with it going that way and only stopped to change sims for more testing. It was amazing. All while being sharp as hell. Pretty sure that was on the .129 driver, but I wouldn’t expect the .111 driver to be any different.

I did find that both PiTool’s were pretty much the same with Smoothing OFF. Just some thoughts if anyone else would like to share their experiences. For what it’s worth, rFactor 2 with the parallel projections enabled looked pretty much flawless on the .129 driver with Smoothing ON, so, who knows, it may be better in some situations. I just always get the feeling that I want to go back to .111 again, though.


#413

NO, thats not the file to edit, it a “resource” file and the header states clear not to edit it
valve has way’s how you can have your own values and the way to go is the file mentioned above
…\Steam\config\steamvr.vrsettings
if you want to know your config configuration then you can use the “vrpathreg.exe”
…\Steam\steamapps\common\SteamVR\bin\win64\vrpathreg.exe
…\Steam\steamapps\common\SteamVR\bin\win32\vrpathreg.exe
if you start this in a command line you will see where the config directory is

on my system its this

Runtime path = C:\Program Files (x86)\Steam\steamapps\common\SteamVR
Config path = C:\Program Files (x86)\Steam\config
Log path = C:\Program Files (x86)\Steam\logs
External Drivers:
C:\Program Files\Pimax\SteamVRSupport\drivers\aapvr


New HP 4K HMD $599
#414

Yes, that works, but the top of that file says:

  "000": "DO NOT EDIT THIS FILE TO CHANGE YOUR PERSONAL SETTINGS.",
  "001": "THIS FILE WILL BE REPLACED WHEN STEAMVR UPDATES.",

#415

I do have a steamvr.vrsettings file there, but it doesn’t have a maxRecommendedResolution entry. I could add a entry, but I’m hesitant, since I’ve had problems in the past when I tried something like that.


#416

persumable there is alredy a section in steamvr.vrsettings

“steamvr”: {

and you just insert your additional line

“maxRecommendedResolution” : 8192,

syntax is the same as in the default.vrsettings
(last entry in section wihtout “,” at the end of the line)
but my guess is thats not needed as its already in the settings file from pimax that comes with the hmd plugin


New HP 4K HMD $599
#417

Well it worked for me, so I have no idea what is going to blow up if I change a value in a file that says DO NOT TOUCH.

It changes back when SteamVR updates? Do it again after it does!

Going to try adding the line in the file mentioned above, see what happens.


#418

you will have to reset the value in the resource file to something different then 8192 (usually to the original) or steam will remove your value from the config file (because it would be redundant as it would be the same in the resource default and your config file)


#419

What ? why 300 % ???


#420

I hadn’t given the smoothing in the .129 beta any serious testing, until last night. I found I could boost a few in-game video settings (like texture size) and increase the SS resolution and still maintain a good framerate: 80Hz apparent, ~55 FPS according to rpsVR. I didn’t notice much in the way of artifacts.

I’m actually pretty impressed.

However, I reserve judgment unit after I’ve used it for a while and had a chance to try driving an SRV or landing in a station (which usually triggers low framerates).


#421

intelligent smoothing does not work for me, too much begging on pc2, rf2, raceroom, ets2.
impossible for me to spend 90hz via pitool on steam or in games I have a disorder rectangle from left to right center on my eyes and everything is deformer, suddenly only the 72hz walk for me.
An idea of ​​the problem ? I am using gtx 1080ti and i9 7900x


#422

Why not? I am still testing a whole heap of things to see what the best compromise is. The awesome thing about these headsets is once you unlock the resolution limit via the ini file in SteamVR, more pixels results in a very noticeable image improvement. If smoothing is working as good as was in .111 (for me anyway, I’m still analysing the .129 implementation which is very close) then I can afford to run that high supersampling because I’m still well withing the 45hz range for smoothing with my 1080Ti.

Unlike the Rift, going WAY higher in the pixel count continues to show improvement in image.

I should add that this is for Assetto Corsa, with Post Process disabled. It’s the easiest sim racing title for me to run by a mile. Disabling PP gives me around 30% more performance back. It’s crazy.


#423

If you like testing crazy high SS try with raceroom, you’ll be able to go even higher SS than with AC.

And to grab the most performance back you can disable (completely off) the car mirrors (nice boost in raceroom but works with AC too and most race sims that let you disable mirrors completely).


#424

I run into issues with Raceroom going over 13.5M pixels per eye in supersampling. The game doesn’t boot into the HMD and just hangs on the desktop. I’ve done some testing and worked out that anything over 13.5M pixels per eye does this. Also, the launch command for SteamVR (-vr 4.0) doesn’t seem to affect supersample values either. It’s very strange but a bug people seem to have heard of. Someone recommended me to put the slider at 100% and use the launch command to supersample but this doesn’t seem to take effect.


#425

Is it just me or since 1.0.1.121 which “solved” the shutdown issue from idle, the headset simply doesn’t go idle and turn off the screens? Sure this makes it easy to develop with since it doesnt get stuck in that infamous “cant turn back on” mode without rebooting, but it feels like the screens suffer from it.

If I turn it manually off, or Reboot the headset, it then gets stuck in the “red light mode” even if PiTool says it is connected. Only way How I fix that situation is turn off the headset, then reboot windows. So what ever was done in the firmware doesnt really solve the issue of the headset not turning off, just removes the entire Idle stuff out.