PiTool 1.0.1.132 (stable) released

pitool

#21

Version numbers can be tricky as they don’t follow a traditional decimal layout.

Each number after a “.” Can have different meaning.

Much like a car Vin number has different details embedded.

What has been the pattern is versions ending in an odd number are Betas & even number is considered a stable release.


#22

Going from 129 to 132. Do I just run the new setup or do I need to uninstall 129 first?


#23

I haven’t tested this version yet. But typically have just unstalled new version without uninstalling old.

Just reccommend discconnect headset & kill exit pitool processes before install.


#24

There wasn’t any firmware update going from .129 to .132 for me, so I guess this time we don’t need to disconect and kill PiTool. Just install and reboot (or restart the service(s) manually)… :wink:


#25

Not sure if it’s just me, but it seems BrainWarp/Smart Smoothing is a bit smoother than on .129 (tested in Project Cars 2 and Dirt Rally (DR using ReVive/SteamVR)) on 72Hz without FFR (1080Ti).


#26

Have to check but firmware version in 132 is 212. Think 129 also packaged with 212. I only reccommend killing service to ensure an in use element doesn’t prevent an overwirte. Just a precaution. :beers::sunglasses::+1::sparkles:


#27

I read the user manual of .132 and saw a picture of
“Horizontal calibration”

What’s that, it’s not explained in the manual.


#28

Is this --> :beers: a requirement when performing the update?


#29

Well I am sure Seb uses it as a precaution or reccommendation. :joy:


#30

Horizontal calibration I believe is for if the horizon is not level.


#31

Actually they build it with broken Chinese (the first string). Japanese is the last one, which displays correctly. I noticed that when I was looking at privacy policy (which looked to be Chinese) and then noticed the language setting was set to the garbled string.

Anyway, for the record: I installed the new version over the old 1.0.1.91. The only thing I did was restarting PiServiceLauncher manually after that. Did not see any problem apart from the wrong default language. The brightness and contrast were ok.

But, right after turning on the headset PiTool started FW update! This has been reported right from the beginning as very risky operation. I assume there is no FW update from .129 to .132, but if this behavior is not fixed I expect at the next update we will again have people stuck in DFU mode because they (involuntarily) executed FW update in a bad moment.

@PimaxUSA, @SweViver could you explain to the devs that this not safe and should be left to the user to decide when to apply FW update?


#32

Same firmware in .129 and .132, yes.

I agree, it should wait until the headset is ready and maybe just prompt the user to update the firmware (“A new version of the headset firmware is ready. Would You like to update it now?”).

The only reason I would prompt is that people would probably never update the firmware if they weren’t asked.

You could always add a “Don’t ask me again until next update” checkbox if needed.


#33

I’ve not installed yet, but does installer still choke if service is still running? That needs to be fixed.


#34

I haven’t experienced that, no.


#35

Everything works fine here. I know I am late to the party, but I quite like brightness/contrast controls. Thanks!
Did not notice any smart smoothing improvement, still produces way too many artifacts to be used in rFactor 2.

I am not sure if this is Pitool or SteamVR issue, but recently I began getting this annoying overlay while on track loading screen: https://steamcommunity.com/app/250820/discussions/3/1649919326319420263/
If Pitool controls that, please allow turning it off.


#36

There are 2 fixes needed or Pimax will get a lot of support requests … it shouldn’t be called ‘stable’ yet.

  1. It seems to default to Chinese? This I think lead to some weird errors when starting SteamVR.
  2. The Left and Right brightness settings get set to different values.

From testing, I can’t make the 9X% GPU usage trick work in DCS anymore. But is ok for me as it lead to a lot of flickering anyway.

Since the release of PiTool 129 I complained about crazy flickering in DCS … which actually seemed to be caused by my 2080ti somehow going into 9X% GPU usage mode by itself.

I hope a way is figured out to make high GPU usage mode work without flickering.


#37

Tested Smart Smoothing in Il2 and it has gone backwards. Image flickering and warping quite a bit even when not pointed at bright light sources. Wish we had Smart Smoothing of PiTool 121 version - that worked well.

Haven’t tested FFR but last I tested - it wasn’t giving much benefit and it was leading to software locks and crashes (Il2).


#38

Both are mentioned in first post though I got the language wrong… :wink:


#40

was hoping it was to solve the horizontal scan lines…


#41

Horizontal calibration I believe is for if the horizon is not level.

I believe enough :beers: ensures horizontal calibration