PiTool 1.0.1.132 (stable) released

pitool

#102

It’s strange because in some titles I’m hitting the mid 90’s in GPU usage and others, like rF2, are just getting bogged down with poor utilisation.


#103

I think that might be down to the CPU threads being quite limited in RF2. I am often maxxing out 2 cores without much happening on the others and my clock is at 4.9ghz with a 7700k.


#104

Doesn’t make sense though that you can force it to work with the trick. The capacity is clearly there it just is not reliable and needs to be fixed.


#105

As I mentioned before, the team is looking at the contrroller issue and will resolve this as soon as they can :slight_smile: That also includes the GPU utilization thing by the way! We NEED that performance :slight_smile:


#106

I’m not so sure about it… The less frame rate we got, the more we have time to appreciate each frame…
:joy:


#107

Please don’t give Pimax ideas for new excuses…!


#108

Does anyone know why I don’t have the refresh rate selector? I didn’t in the previous version, and I don’t in .132 either. My headset firmware is up to date. I have the latest NVidia drivers installed, and am using a 2080ti.


#109

FWIW. It seems that whenever I start PiTool, I get the random selection of “Smart Smoothing”, “Parallel projection” and “Compatible with Vive” selected. I did not find any pattern to it, nor a way how to preserve the configuration over to the next PiTool launch.


#110

I’ve seen the exact same thing + brightness value seems to be reset in one side only but only in GUI. In the profile.json file they’re still equal.


#111

Happens to me sometimes, i click on restart Pitool and it comes back.


#112

Yep something arsed up. Since last stable update the brightness slider is always a different value to what has been set when I first open pitool. Usually one eye set different to the other by a notch or two.


#113

There’s something weird I noticed with Smart Smoothing in Elite Dangerous.
When I’m parked in a hangar in a station, and I look up at the lights on the ceiling, and my CPU/GPU utilization is such that frame times are barely below the limit (13.8 ms at 72Hz), I can notice that when Smart Smoothing kicks in, the lights wobble. This is strange because there is no movement, other than the uncontrollable movements of my neck.

I wonder if the interpolation algorithm might be using unfiltered values from the accelerometer?

For reference, I’m using quality 1.0 in PiTools, 72Hz, Smart Smoothing and FFR on, GPU is a 2080, CPU is a an i5 4690K running at 4.2GHz, and I don’t have base stations.


#114

I’ve never seen that before.

PiTool somehow thinks You’re on a non RTX series card?

EDIT: Never mind. This makes absolutely no sense. I somehow confused myself into thinking You were missing FFR, but You can still give below instructions a go.

Maybe try uninstalling Nvidia driver using DDU and reinstall.

When I upgraded from a 1080 Ti to a 2080 Ti I used DDU.

I’m thinking if You didn’t, whatever PiTool uses to check which card You have might still “see” the earlier card?

EDIT: And also try an uninstall + install of PiTool.


#115

Have you rebooted your PC? I’ve seen this once (in ~3 months) and rebooting fixed it for me.


#116

I had variable refresh rates on a 1070 (and now on a 2080ti).


#117

Sorry… :grin:

I somehow confused myself to think that what he was missing was FFR… :exploding_head::crazy_face:


#118

I am hitting that too, so I try to not start PiTool often, it seems to reset/mess settings up on startup. Also do not get the logic/solid repro.


#119

使用132穩定版發生調製整左右眼亮度時
左眼不論如何調整都會自動跳回0的位置(129不會)重新安裝前是都強制跳到5 只有左眼
就算我在兩眼都調整成0兩眼亮度明顯不同

@Doman.Chen @Dallas.Hao


#120

Just to translate the above:

When the 132 stable version is used to modulate the brightness of the left and right eyes
No matter how the left eye adjusts, it will automatically jump back to the 0 position (129 will not). Before reinstalling, it is forced to jump to 5 only the left eye.
Even if I adjust both eyes to 0, the brightness of the two eyes is significantly different.


Yes I can confirm I have had some random settings applied after reboot. I think we all better just stick with version 129 for now :slight_smile:


#121

I listed that in OP… :wink: