PiTool 1.0.1.132 (stable) released

pitool

#122

@SweViver replied:

是的我可以确认我在重启后应用了一些随机设置。我认为我们现在更好地坚持使用129版


#123

@Heliosurge Did you use google translate or are you of Chinese descent?

@SweViver Any change getting another beta PiTool soon? And could you ask them to try and emulate PP without hoarding as much CPU/GPU power as it does now? Most of the games I play require PP on and I couldn’t get optimal performance with PP on. I’m currently at version 129. Thank you.


#124

Google translate. So I hope it wasn’t butchered. :beers::sunglasses::+1::sparkles:

I only speak English & gibberish. :blush::joy:


#125

Whatever happened to xunshu btw?


#126

I think Kevin said she is working on another project


#127

I speak with her often and work with her on some things but her primary now is working for Unity.


#128

Just click default on this return value to zero and then choose your setting :wink:


#129

0H h@i! l k@n sbeak gibberish T0O!!:clap:


#130

For those whose use VORPX (like me), here is a warning from its creator when use it with our Pimax Headset:

"The latest PiTool 1.0.1.132 has a new setting on the ‘Brainwarp’ page called ‘Compatible With Vive Only Game’. This setting makes it impossible for applications to detect a Pimax as Pimax, instead the headset pretends to be a Vive with this setting enabled.

Make sure to uncheck this for vorpX. vorpX does several things different when it detects a Pimax.

Whoever at Pimax got the exceptionally bad idea to enable this setting per default and on top of that re-enable it each time PiTool is started should be fired immediately…

If you happen to be active on the Pimax forums, please complain about this nonsense. A headset should not pretend to be another brand, especially not if it’s as different as Pimax 5K/8K are.

I’ll add an according warning for the next vorpX version if a Vive is detected but PiMax software is running. That’s far from ideal though as it will also affect users with both headsets that are currently using an actual Vive."

:face_with_monocle::face_with_monocle:


#131

I can understand his concern & yes it shouldn’t reset to be on by default.

But it was a workaround for games that specifically look for the headset to be a Vive headset.

I’m sure eventually these kind of workarounds won’t be needed with game profiles & Devs not putting limitations like want X brand headset only.

Now Vorpx could also add a setting to choose headset type as well to force appropiate brand & model. Much like some games also have choose soundcard output.


#132

Thanks for the info. This sort of identity hack is not unheard of, at least in the hardware community. Here are 2 examples…

In the early days of PCs, some programs checked the motherboard ROM for “IBM” from “© Copyright 1985, IBM Corporation”, so “compatible” motherboards had a string like: “Some programs check for the letters IBM here”.

Many years ago I wrote a mouse driver for a Taiwanese company. It lied about its ID, so that it was compatible with more programs.


#133

I believe it is reenabled randomly the same way the other options (on the same pane) are.


#134

It seems in the new version the left/right brightness bug is no longer a display issue only. And I got different brightness even after the two sliders showed the same value. I tried to find a config file that holds the values so I can edit that directly and then make it read-only, but I couldn’t. Is there such file somewhere or the only option is to downgrade?


#135

Found it:

%localappdata%\Pimax\runtime\profile.json

Added: I changed the values for the left and right brightness to match and they are now identical for left and right, hen made it read-only, but in the headset I still got visible difference. Very strange.


#136

Did you restart pi services?


#137

I used PiTool v132 since it came out. I had the left eye brightness changing every time I opened PiTool and a couple of other boxes checking themselves when they shouldn’t be. So each time I would make sure all settings were correct before using the HMD. I tried Smarting Smoothing and FFR in IL-2 but found having them off was better. Ran under Normal mode at 72. What happened consistently was after about 30 minutes of flying, the HMD would go black (loss of tracking). To get it back I would look behind me for a few seconds. The screen would come back and then a few seconds later I would get a CTD. The CTDs closed PiTool and SteamVR. As I said this happened consistently, rendering the headset unusable for on-line play. I then put PiTool back to v129. I have used it in IL-2 for a number of sorties, both off and on-line, and have not, as of yet, experienced the above issue.


#138

facepalm
Uhmm… it was early in the morning… didn’t think to do that. Will try tonight. Thanks!


#139

The Firmware Update killed my 8K again. Even Flasher doesn’t work now.
I request a new HMD now, oviously mine is a faulty production!
Firmware updates suck!


#140

whats the led of the 8k?
there are 2 or three threads about firmware flashing
depending on system you might need to install a newer driver for dfu (recovery) mode and you can try a different flash tool


#141

After some more Flash tries during the last hours, the LEDs currently are actually dead. Means none of the lights is glowing. But when I switch off and on power again (LEDs would still stay off), I can press the buttons to get into DFU mode again. So the HMD is not dead at all. Then I can install the Firmware again and right when the tool finishes, light keeps being red or green. When I restart PC as last step and Flasher Tool opens after restart, it says “Pimax not found”. As does PiTool.

“depending on system you might need to install a newer driver for dfu (recovery) mode”
–> I don’t understand what you mean :frowning:

“and you can try a different flash tool”
–> which one? I only know this one: Sjefdeklerk's Pimax Flasher (4k/5k/8k)