Pitool 1.0.1.197 Beta missing 120Hz option

So with the release of the latest Pitool beta the new 120Hz mode for the Pimax 5K+ model in a limited FOV mode was announced. This seems like an awesome feature and the community was very happy. However, many users started reporting not having the 120Hz option visible in the tool. Some people reportedly got this issue fixed using various different methods involving series of PC reboots, graphics card driver or Pitool reinstalls, piservice or HMD reboots and cable plugging/unplugging. Unfortunately there still isn’t a confirmed way to get the feature working for many, myself included.

At first I figured we’d get a fix or new beta version in due time and there’s no need to rush things as it’s just a beta version and issues can be expected. It’s been a week and as far as I could see no Pimax employee has given a response or any kind of statement regarding the issue, which is a shame but it’s still just a beta and not an official stable release so I’m inclined to ignore the silence and give the engineers time to figure things out.

But then I saw that Pimax is now advertising the 5K+ as a 120Hz headset on their own store. So according to them the headset is now fully 120Hz capable and it’s an official feature. By that logic my unit is defective as I can not use any kind of 120Hz mode and have no option for it.

Do we or could we get some kind of a statement or status update on this? I’d really like to test this feature that my unit apparently should but doesn’t have out. Thank you.

@PimaxVR
@PimaxUSA
@Matthew.Xu

7 Likes

I have no 120hz mode for my 5k+ too…
it’s seem like some Early version of 5k+ is missing support。。。
or missing compatibility。。。

2 Likes

that’s what I read… Unfortunatelly I’m in that pool. Dont know why Pimax is not answering that question which was asked in many threads. @Matthew.Xu

@zths @Yata_PL
Do you, by any chance, also have visible black dots on the panels?

4 Likes

You might be onto something… :wink:

I have 120Hz and no visible dots.

Yes, I see them but they dont bother me so munch in my games

2 Likes

No black dots here. The sticker on my headset says Pimax 5K Plus and model P2 (nothing more). My Kickstarter backer number is over 6800 so my headset should not be any first “test” batch either but still no 120Hz with the latest firmware (and small FOV in Pitool .197).

2 Likes

FYI - Serial number can tell Your when it’s made (which week/year):

They’re all called “P2” (8K and 5K+, maybe even 5K XR too?).

Mine is from week 2/2019 with no dots and 120Hz works, as mentioned.

3 Likes

Thanks @DrWilken My headset seemes to be manufactured on 2018 week 49.

2 Likes

My headset is a replacement for my cracked backer headset. I received it a few months ago and it has 120hz after the update and no dots.

It was produced in 2019 in the 17th week. This would be around April 22nd?

1 Like

Got my 5k+ back in mid February, its a P2, if i understand the SN correctly it was made in week 31 of 2018 and with the latest firmware i get the 120hz option.

Is it just me or is the 120hz mode smaller than the “regular small” mode?

2 Likes

Pretty sure all original “8K Series” (5K+/XR + 8K) are P2’s. I think P1 is the old series (4K)? @Heliosurge ?

Digit 7 = Year (8=2018,9=2019)
Digit 8+9 = Week

It is, yes… :wink: I use large when using 120Hz, but normal when using all other refresh rates.

1 Like

If digit 8+9 is week then i guess my HMD was made in week 53 of 2018 then, did we have a week 53 of last year? :stuck_out_tongue:

2 Likes

Haha. Maybe Pimax did? :grin::crazy_face:

1 Like

With their time keeping that wouldnt suprise me, a few extra weeks added here and there and they are “still on time” in their own universe.

Can larger FOV settings be used in 120hz mode?

3 Likes

Yes, see my previous post, but large in 120Hz mode means ~130° not ~160° like in 64/72/90Hz mode.

It’s close to “normal normal” mode though if You’re used to that (64/72/90Hz normal FoV = ~140°)… :grin:

2 Likes

yes,i can see black dots… clearly

4 Likes

Thanks, ive mostly been using normal mode anyways so this makes me happy, i wasnt able to read that mess of numbers in the quoted post but then again im pretty thick at times.

1 Like

So looks like “black dots” panels dont have 120 hz mode. Nice !@

2 Likes

I have visibile black dots and not 120hz

5 Likes