PiTool Disconnected: Diagnose(10600) error


#21

Sorry I realize that I might be coming off as ungrateful for the help but I really do appreciate everyone’s suggestions I’m just pretty frustrated at this point. Anyway thanks for all the help and keep the suggestions coming because who knows one of them might work!


#22

Something else worth trying is disabling selective USB suspend in advanced power settings for the power profile you are using.


#23

Does that work for you?


#24

I’m traveling this weekend so can’t do anymore troubleshooting till Sunday night but will give it a try then.


#25

I’m having the exact same issue with the headset I received today. Tried the uninstall, remove folders, reboot trick with no success.

I’m an engineering type so willing to do some digging in files and registry if I have some direction to go on. Any suggestions?


#26

@mol I disabled selective USB suspend and that didn’t seem to have any effect. I also successfully the Pimax firmware using the file you had sent and still get the 10600 DP disconnected error.


#27

Have you had any luck getting it to work?


#28

And the cable leading into the headset has a solid fit? I also used a powered usb 3 hub for the usb connection but that is probably overkill.

The piserver logs migt tell you more. I don’t know what more to suggest.
I used the dfu flash tool in the runtime directory to flash last tine but ought to be identical to commandline tool (save for not needing to kill processes)


#29

For me it mentions something about not being able to access piserver library


#30

I was able to fix mine.

In my case it was due to a wonky port configuration on my graphics card: https://www.gigabyte.com/us/Graphics-Card/GV-N1080XTREME-8GD-PP-rev-10#kf

Specifically the VR Link feature was the issue, which causes two of the DP ports on the back of the card not to recognize the Pimax headset at all. The Pimax can only be used on the DP port directly next to the HDMI port on this card.

There’s other weird behaviors when the system goes to standby and comes back as well, but usually a reboot fixes those


#31

Interesting!
I got a Gigabyte AORUS GTX 1080 Ti Waterforce WB Xtreme Edition 11G:

Pimax is connected to the middle of the 3 DP, and a 3-display DP hub connected to the one closest to the motherboard.
VR Link should be enabled as long as you dont use the dvi connector. But it is kinda funky since the manual doesn’t mention anything about how VR Link works. I guess the takeaway is: reboot everytime you change connector for it to work.


#32

I have been working with PiMax support but still no luck at all. Also I have an ASUS ROG Strix 1080GTX and am pretty sure trying both the DP ports was one of the first things I did but switched ports again just to check and with no luck.


#33

Does anyone know if an Nvidia GTX 970 will work with the PiMax 5K+? Obviously it wont play games well…but will it connect and otherwise work normally?


#34

Not sure if this is the correct thread to mention this but just wanted to share. I had no luck getting my headset to be recognized by either the pitool or windows. The green power light was on and the bar on the front of the HMD was blue but nothing was working. Tried all the things mentioned here here in the forum to no avail. In the end I tried pushing the HMD cable in a bit more… satisfying click and suddenly windows starts recognizing the device and pitool fires up room scale calibration.

Solution: Dodgy connector on the HMD.


#35

Hey there,
Did you solve your problem with error 10600? I have the same Graphic card (strix 1080) with the same problem you described.


#36

@ManiacCB

The headset I received was dead on arrival and the issue wasn’t the GPU. After Pimax support spent a couple hours on TeamViewer remoted into my computer they couldn’t solve the issue and sent me a new headset.

The good news is the replacement headset worked on the first try with no issues and is still working great.

Sorry I can’t be of more help other than giving generic suggestions like unplug/replug the cord from the headset, reinstall PiTool, flash the firmware, etc.


#37

I would like to check about your issue via teamviewer when you are available.


#38

@exterm24
good to hear that your Pimax is working :slight_smile:

@Doman.Chen
Hi Doman.Chen,
You already checked my computer on sunday and you said that this might be an hardware issue if the Pimax. (SUPEN-1295)
While i wait for after-sales dept (didn’t react yet) i can yet do some experiments because it always can be that the problem is somewhere else. :wink:

(for example: I’ve seen that some GTX graphic cards have problems with the DisplayPort and therefore NVIDIA released an Firmware update to solve this but the firmware update didn’t help me either)
Firmware Update for GTX

At the moment i suspect the problem is the quality of the Displayport-cable but that’s just a guess.


#39

I was trying out Creed today. When I put the HMD (5K+) down the screen went black. I picked it back up and it turned on again. So I thought nothing of it, maybe a bug/lost tracking.
After a little rest I played again. Every once in a while it went black again. I took the HMD off and it didn’t turn on. The light was red. Sound came through, blue light on front was on. Checked Pitool and it said 10600. I tried everything in this thread, top to bottom. Nothing worked. Un/reinstalled, power off, dis/reconnect, full deleted appdata files, tried all DispPort, shutdown the service/run service, shutdown unplug turn on replug, everything.
A couple seconds ago I tried one last thing before calling it quits. I pinched the wire at the HMD and pushed in like I was fishing the cables toward the HMD and the light turned green! I thought the wire at the HMD problem was dealt with no? At least for me it was my problem, and I am using the Vive Deluxe Audio Strap with support velcro on that wire. That’s apparently not good enough. So obviously this needs to be addressed as I’m pretty careful with my Pimax, guests won’t be.
For now I’m gonna make a loop between the velcro on the Audio Strap and the HMD so there will be less tension at that point.
Hope this helps.


#40

It’s just getting worse. I have to keep pushing it every time I turn my head. E-Mailed support. I’d really like to open it up because it’s probably just one of those little white connections working itself out, but I’ll leave that to them.