PiTool won't start on W10



I’ve had an issue with a specific game on Windows 7, which is why I did a clean re-install of Windows 10 yesterday. Thus I’m now running a stock Windows 10 system. I downloaded PiToolSetup_84.exe from pimaxvr.com and installed it. However, the PiTool just simply won’t start. I can see the blue pi logo on my screen briefly and then nothing more happens. I can’t get the PiTool program to show up.

  • The VR headset shows a green LED all the time and a black screen.
  • SteamVR can’t detect the headset.
  • I can’t see the headset in device mananger, though I might just be missing it.
  • The same problem occurs with the headset disconnected from the PC.

There might be one thing I screwed up: The PiMax was plugged in when I installed Windows. Hence it was recognized as a monitor and Windows actually made it the main monitor. Thus I went into the display settings and ‘disabled’ the display. However, the PiMax is not shown as a monitor anymore since I insalled PiTool, so I can’t undo that.

I tried reinstalling PiTool. I tried running it as Administrator. I tried restarting my PC countless times with and without the PiMax connected. I tried starting PiTool with the headset disconnected. I tried just starting SteamVR, which can’t seem to detect the headset.

Anything I can do? Any help is greatly appreciated! Thank!


Disabling it don’t fully removes it, if you haven’t tried already, go in device manager, and check if the Pimax driver is still there under Monitor tab, right click it and uninstall it completely so that the only remaining one is your monitor driver, uninstall Pitool completely, reboot and try reinstall Pitool.

Also, some more experienced users could tell you what best Pitool version to use in this case…


With it being a clean install. You also need DirectX & Vccredistrubute installed. A lot of games will install these.

Possibly one of these componets are missing.

I myself installed 76 & let it upgrade.


The PiMax is not shown as a monitor anymore, only my two regular screens are in the list.

I already installed all the packages for x64 on this list that I found: https://gist.github.com/mmozeiko/de5d9b756bd11b77db8bf4253bed8b3e
DirectX is apparently already installed with windows, it wouldn’t let me install it anyways.
I don’t have 76 unfortunately but I already installed a few games and ran them.

I finally found the log folder in %APPDATA%/Local so I’ll be sharing a few logs (I crossed out the serial number deliberately):


17:13:26 T:6528 LOGNOTICE: build time:Sep 19 2018 18:59:59
17:13:26 T:6528 LOGNOTICE: service version:2.1
17:13:26 T:6528 LOGRECORD: Microsoft Windows 10 Home|C:\Windows|\Device\Harddisk0\Partition4
17:13:26 T:6528 LOGRECORD: Radeon RX 580 Series
17:13:26 T:6528 LOGRECORD: Gpu version:25.20.14011.10001
17:13:26 T:6528 LOGNOTICE: start svr!
17:13:26 T:6528 LOGERROR: load config data failed!
17:13:26 T:6528 LOGRECORD: mode:1,Start Main Service: success !
17:13:27 T:6528 LOGNOTICE: init mode:pimaxvr
17:13:27 T:6528 LOGRECORD: match hmd:USB\VID_0483&PID_0002\xxxxxxxxxxxxxx
17:13:27 T:6952 LOGNOTICE: start monitor
17:13:27 T:6920 LOGNOTICE: start connect
17:13:27 T:2248 LOGNOTICE: start rpc
17:13:29 T:6920 LOGNOTICE: usb connected event!
17:13:29 T:6920 LOGNOTICE: (hmd info): pimax_serial: xxxxxxxxxxxxxx, software_version:, region_id: DF
17:13:29 T:6920 LOGNOTICE: (hmd info): LCD_type: 0, hd_mode: 0, display_mode: 0
17:13:29 T:6920 LOGNOTICE: (hmd info): work_mode: 0, display_card: 0, sys_state: 0
17:13:29 T:6920 LOGNOTICE: (hmd info): bright: 0, color: 0, blue_right_flag: 0
17:13:29 T:6920 LOGNOTICE: (hmd info): back_light_flag: 1,sensor_rpt_flag: 0, display_ipd: 63000
17:13:29 T:6920 LOGNOTICE: (hmd info): warning: 16711935
17:13:29 T:6920 LOGNOTICE: hdmi connected event!
17:13:29 T:6920 LOGWARNING: pvr service have started!


17:19:53 T:5928 LOGNOTICE: build time:Jul 27 2018 14:44:43
17:19:53 T:5928 LOGNOTICE: interface version:2.1
17:19:53 T:5928 LOGNOTICE: svc start success.


17:15:20 Critical: PiTool start
17:15:20 Debug: load translator success “C:\Program Files\Pimax\Runtime\language\pitool_en.qm”
17:15:21 Critical: Setting init
17:15:21 Critical: setAutoRun: true true
17:15:21 Critical: PiService
17:15:21 Info: PiService::start,success
17:15:21 Critical: hmdInfo “Pimax B1” “Pimax B1A” “xxxxxxxxxxxxxx” “” 1265
17:15:21 Critical: EnumDisplaySettings success 2560 1440 0
17:15:21 Critical: ChangeDisplaySettings result= -2 0 0 1
17:15:21 Critical: EnumDisplaySettings success 1920 1200
17:15:21 Warning: QString::arg: Argument missing: “60” , 1200
17:15:21 Critical: EnumDisplaySettings success 2560 1440
17:15:21 Warning: QString::arg: Argument missing: “60” , 1440
17:15:21 Info: SteamModel
17:15:21 Info: getInstallFolder, (“C:\Program Files (x86)\Steam”)
17:15:21 Info: ResourceModel
17:15:21 Info: initResource tool size 0
17:15:21 Info: initResource piplay size: 0
17:15:21 Info: steamvr app: “C:\Program Files (x86)\Steam\config\steamapps.vrmanifest” size: 1
17:15:21 Info: appendLocalResource 0
17:15:21 Info: append new Local resource “steam.app.234630” 0
17:15:21 Info: save file success “C:\Users\x5444\AppData\Roaming\PiTool\manifest\steam.app.234630.json” 0
17:15:21 Info: downloadFile: “https://steamcdn-a.akamaihd.net/steam/apps/234630/header.jpg” “C:\Users\x5444\AppData\Local\Pimax\PiTool\games\steam.app.234630.jpg”
17:15:21 Warning: QSslSocket: cannot resolve SSL_set_alpn_protos
17:15:21 Warning: QSslSocket: cannot resolve SSL_CTX_set_alpn_select_cb
17:15:21 Warning: QSslSocket: cannot resolve SSL_get0_alpn_selected


[18-12-09 17:13:27][PSRV] pi_server 64 Release
[18-12-09 17:13:27][PSRV] build time:Oct 13 2018 15:31:10
[18-12-09 17:13:27][PSRV] build version:38
[18-12-09 17:13:27][PSRV] ignore Pimax Debug hmd.
[18-12-09 17:13:27][PSRV] load profile file:C:\Users\x5444\AppData\Local\Pimax\runtime/profile.json failed, use default value.
[18-12-09 17:13:27][PSRV] main tid:6764
[18-12-09 17:13:27][PSRV] event tid:6380
[18-12-09 17:13:27][PSRV] cmgr tid:3788
[18-12-09 17:13:27][PSRV] Failed to init nvapi with error=0x-2
[18-12-09 17:13:27][PSRV] Amd Driver version:[]
[18-12-09 17:13:27][PSRV] system adapters:
[18-12-09 17:13:27][PSRV] adapter 0 :Radeon RX 580 Series(0-37469)
[18-12-09 17:13:27][PSRV] adapter 1 :Microsoft Basic Render Driver(0-40702)
[18-12-09 17:13:27][PSRV] redmgr tid:6540
[18-12-09 17:13:27][PSRV] start run render.
[18-12-09 17:13:27][PSRV] hpmgr tid:6352
[18-12-09 17:13:27][PSRV] vendor specific connector type:0
[18-12-09 17:13:27][PSRV] extend display:, use main adapter
[18-12-09 17:13:27][PSRV] extend display:, use main adapter
[18-12-09 17:13:27][PSRV] drmgr tid:5600
[18-12-09 17:13:27][PSRV] init internal drivers
[18-12-09 17:13:27][PSRV] add device:Pimax B1A
[18-12-09 17:13:27][PSRV] init external drivers
[18-12-09 17:13:27][PSRV] global error code:105
[18-12-09 17:13:27][PSRV] rpc tid:6520
[18-12-09 17:13:27][PSRV] start idle client.
[18-12-09 17:13:27][PSRV] client 0(0) connected.
[18-12-09 17:13:27][PSRV] client PiService(6620) connected.
[18-12-09 17:13:28][PSRV] HMD Firmware version:
[18-12-09 17:13:28][PSRV] driverMgr added device:Rift B1A:xxxxxxxxxxxxxxx
[18-12-09 17:13:28][PSRV] added hmd:Rift B1A
[18-12-09 17:13:28][PSRV] global error code:106
[18-12-09 17:13:28][PSRV] display name: PIMAX B1A
[18-12-09 17:13:28][PSRV] mode: direct
[18-12-09 17:13:28][PSRV] whs: 0014402560
[18-12-09 17:13:28][PSRV] pos_x: 0
[18-12-09 17:13:28][PSRV] pos_y: 0
[18-12-09 17:13:28][PSRV] check graphics driver version.
[18-12-09 17:13:28][PSRV] check graphics driver version failed.
[18-12-09 17:13:28][PSRV] global error code:110
[18-12-09 17:17:12][PSRV] standby mode enter.

EDIT: I forgot to mention that I also reinstalled my graphics driver. While it was reinstalling, for a brief moment, the PiMax LED turned blue and it showed my desktop wallpaper in the Headset. It went away shortly after, though.


Not sure if you check the Banner topic there is a link there for pitool downloads. 76 is there.

@Dallas.Hao @Pimax-Support @Sean.Huang

May need to setup a teamview session. Some have had a missing dll file as well.


Thanks for that. PiTool 76 fails, too. However, before it quits it gives a somewhat conclusive error message:

OPENSSL_Uplink{00007FF9E67B4000,08}: no OPENSSL_Applink

This is somewhat related to the SSL Errors in the log of 84. I’ll do some more research.


Did you install as admin?


Yes I did install it as an admin. The ssleay32.dll is there, too, in the Pimax/Runtime folder.


Finally I’ve made some progress. I got PiTool (84) to launch by deleting the ssleay32.dll from the Pimax/Runtime folder and installing OpenSSL (light) from https://slproweb.com/products/Win32OpenSSL.html (found through some stackexchange thread).

It still wouldn’t switch to green so I fiddled around with the DFU tool, until my headset wouldn’t work at all anymore. Just white flashing. Since none of the DFU tools posted for the PiMax seemed to work I got the official STM DFU Tool from https://www.st.com/en/development-tools/stsw-stm32080.html . Hold all three buttons on the HMD, plug it in, let go of power, right and left in that order with 8 seconds between each. This gets the HMD into DFU mode. The STM tool will find the HMD, even if all the other tools fail. Next, I flashed the dfu file from [Release]Pimax 4K firmware with the STM tool.

Now, when I connect the HMD I get a blue light. And PiTool runs. Finally. However, PiTool still says “Disconnected”, which is somewhat annoying as it still doesn’t work. Any idea?


What is yourr system config?


You mean my hardware setup? I’m running a i5-4670S, an RX580 and 8GB of RAM. Fairly standard mid-range system I’d say.


What I think may be the problem is that the firmware I used is super old. Like, 2016 old. Is there a newer firmware available anywhere?


Yeah may need support’s assistance depending on how close the rx580 is to the Vega Gpu. Tge Vega has a driver issue & Amd is working on it.

I generally connect dp then usb then power but shouldn’t matter.

Red Usb ports also usually work better.


It worked fine on Win7 on the same computer.


What’s the most recent Firmware for the Pimax 4K B1A? Any way to get the dfu file?


265 I believe is the most current.


Please contact our support team via servicedesk, they are handle this and will respond very quickly.

The servicedesk link : http://feedback.pimaxvr.com/


Thank you very much! I will do that tonight (approx. 8hrs from now).


I got it to work perfectly now. I’ll post the procedure here, just for reference. All these steps were necessary for me.

  1. Create a new Windows 10 Installer USB Stick. This is done with the Microsoft Media Creation Tool and pretty simple. I used to use a approx. 6 month old version, which didn’t work. Get the latest and greatest.

  2. Install Windows on a plain HDD. Do this with the HMD DISCONNECTED at all times. Connecting the Pimax while the setup is running will break things.

  3. Windows Installation also installed the Radeon Driver software for me. Install the Pimax PiTool 1.0.84.

  4. If the PiTool doesnt start (just closes itself after the blue Pi logo), go to C:/Program Files/Pimax/Runtime/ and delete the file ssleay32.dll. Reboot your PC.

  5. Now you can finally plug in the HMD. PiTool should already be autostarted with Windows and the LED should turn blue. The Pimax works at this point.

Thanks for the support everyone! Finally, even XPlane works in VR, which is what gave me trouble in Windows 7 originally. I hope I can afford an 8K one day :smile: The Pimax is a great product after all and it would’ve been pretty sad for me to not get it back to work. I’ll keep in contact with the support team to ensure they can provide a workaround to other users if necessary.


That’s awesome! Glad your finallt enjoying your pimax! :beers::sunglasses::+1::sparkles: