Project Cars 2 - Pimax 5k/8k setup guide

fix-guide

#1

Hello guys ,

As my RTX gfx card need RMA I found couple hours to prepare one more sim setup guide.
Setup should work for ppl with RTX 2080/ 2080 TI & GTX 1080Ti cards and modern i7 processor.
As usually my goal was to get stable fps ( 72 this time as 90 is not possible with current gfx cards ) and very sharp picture with high/medium visual settings with postprocesing on and MSAA set at medium
This game on default settings is very blurry and demanding even for RTX card so we have to do a lots of modifications.

My sugestion for 1080ti OC/RTX 2080 OC
PiTool: 1.25
Steam VR Render: 30 %
72 hz mode ,
no smoothness - I see disturbing ghosting when is on
Parallel projection set on
Brightness: high
Fixed Fovated Rendering - dosn’t work at the moment
area mask set on

RTX 2080 Ti OC players
PiTool: 1.25
Steam VR Render: 40 %
other settings like for 1080ti

Next please copy my pastebin to graphicsconfigopenvrdx11.xml and replace all line there for my config.
https://pastebin.com/QYJi4fub
You will find this file in c://users/yourname/documents/Project CARS 2

3 last lines gives you distance sharpness, game looks a way better with sharpening xml code

To give you an idea how sharpening works I pasted 2 screenshots from small area of the game mirror
As you can see, it sharpens the whole picture also the in car dash, sharpening between 0.8 ~ 1.2 seems works good for pimax. Offset bias and clamp work like a filter on pixels shimmering done by “sharpening”

next part, set your post-processing effects as you like, my suggestion here:

sorry for polish lang. don’t know how to change that in this game - wl = on , wyl = off, tak = yes, nie= no

Enjoy your Pimax ride :slight_smile:

Edit: In game Supersampling 1.0 ( default)


How to play project cars2 on pimax 8k, 5k without parallel projections and steamvr
#2

Thanks man! I’ll be sure to use this when I get my Pimax :smiley:


#3

No wonder I had performances issues. I never considered such a big downsampling value.
Is there a difference between achieving 37.5% downsampling using both PiTool and SteamVR instead of just SteamVR (since PiTool doesn’t let you set under 50% if I remember correctly).

I will give it a try tonight.
Thanks


#4

Pitool 1.25 its not downsampling. Try first before judgment :slight_smile: With steamvr SS 40 % you have res 3045x2602
Copy my pastebin for “distance sharpness”


#5

Of course everything > 1 is supersampling, while everything < 1 is downsampling.

Well, I tried these (SteamVR SS at 30% since I’m using a non Ti card) but I still can’t maintain stable 64 fps in my use case (Spa, light cloud, 9 opponents), even with everything set to low/off (except MSAA because the aliasing is unbearable otherwise), and using -skipcrowds and -vrnomirror command line launch option.
It’s possible that my CPU (intel 4690K OC@4.2GHz) is the bottleneck, but I see no usage > 90% on either CPU (75-85%) nor GPU (60-70%) in fpsVR.

Tomorrow, I will try to switch back to 90Hz (which should get me stable 45fps I suppose thanks to reprojection … which was what I was playing with using Vive), and see until where I can crank up the supersampling, because the image is still a little blurry.

EDIT : oh by the way, I don’t really see any difference in staying at 1.0 in PiTool and setting SS to 38% in SteamVR (same rez displayed in SteamVR settings / fpsVR). I’m still wondering what are the benefit from doing supersampling + down sampling, instead of only doing downsampling to the same resolution.


#6

low textures only consume less memory - dosnt impact for fps…


#7

IMHO - probably DDR3 slowdown more your system , I did my setting with DDR4 - 3200 and i7 8700k
However if you have CPU usage 90~70 % that might also impact your fps , this is how Win 10 works its never give you 100 % for gaming


#8

You are not doing upsampling and downsampling. You just set two different factors at two different places, which both combined give the final supersampling factor. The game then renders the scene using this final factor. Check the reported “recommended render target resolution (one eye)” in SteamVR. If it is bigger than 2560x1440 the chances are the game is supersampling the image (with factor > 1).


#9

Well, I didn’t really set everything to low/off (my bad), only really impacting features on GPU and/or CPU (hence the -skipcrowds command line launch option).
I did have Texture set to High + Anisotropic filtering to x16 (doesn’t consumes a lot and brings out a big step up in texture quality … especially for games where you looks far ahead), combined with MSAA (as I previously said) to cope with too distracting aliasing.

Did though of that this morning. Well, I did plan to upgrade sooner or later, so why not give it a try.

I badly expressed myself, but that’s what I meant in a way. Thank you for clarifying that.
That’s why I don’t really understand why 1.25 * 0.3 would be different than 0.38 set only at one place (ideally in SteamVR as a specific setting for PC2).
The reported “recommended” target resolution asked in SteamVR is 74% when using Normal FOV, which I think was around 2800p (don’t remember the exact value).
As we said earlier, the value displayed in SteamVR settings is the resolution used before warping the image to match the lenses.
For the Vive (Pro), that image is 1.4 larger than the native resolution of the headset (hence 1680p for Vive and 2240p for Pro).
Since the ratio of Pimax screens are different (full 16:9 per eye) and we 3 FOV settings , I don’t know if that coefficient is the same (and users have reported that the 100% settings gives different resolution depending on PiTool version).
But whatever it should be, you should have a target resolution larger than 1440p in the SteamVR settings.


#10

It is not 0,38 but 0,46 because PiTool and SteamVR are using different formulas for calculating the supersampling factor (8k Users you have to try this for Elite Dangerous!), but in general I agree, there should not be a difference.


#11

Interesting to know.
So PiTool coefficient is applied to both height and width, while Steam’s one is applied to the total number of pixel.

Anyway, I should be able to test PC2 my GPU (2080) on a 9700K + DDR4 3200MHz this week end, so I should be able to get my answer ^_~


#12

at 0:50 you can see my short PC 2 gameplay , stable 72 hz at least in training sessions


#13

Thanks
We should some how get a list/blog/threads/section for Game Configs for typical best practice settings.
Like PC2 for 1080 to 2080TI;
Often its “specific” things you need to adjust for a game to make it playable and the rest ist just finetuning to your card.

@Heliosurge - is there such a “Area?” - would be nice since currently we have many threads with lots of solutions (like the none Parallel Projection for PC2 and this one as an example).

Like “Game Configurations 5k/8k”
and Threads like:

  • Projects Cars 2
  • DCS

not sure how to reduce the off topic jabbering….

Edit: This is the one (Yata_PL also provided some Infos there)


#14

@Yata_PL Did you try the Parallel Projection off thing?


#15

I didn’t doubt you, especially since this is backed up by several other feedback.
I will provide some feedback once I tested the game with a stronger CPU + DDR4 this week end or sometimes next week.

Yes he did.


#16

Thanks @Schadows - “The one who can read is clearly on the side of advantage” or how ever you would translate that one :wink: -
I guess I just missed that line!


#17

I think it would be more relevant to directly show the resolution that appears in SteamVr settings…

I read a lot of topics around SteamVR and Pitools rendering methods, and it appears that final resolution is pitools render quality times SteamVR suppersampling cursor.

In my case (RTX 2080 OC), I found out that it’s running perfectly smooth (a good test is to quickly go from one side to another when you are pursuing a car from close behind) with :
3207x2742 (0,75/98%), msaa low, shadows high, car details low
I am testing on Le Mans Bugatti, LMP2, at dawn, with 31 cars, it makes around 60 fps.

Obviously, you can use higher settings with fewer cars, and slower cars…

Settings above are without manual overclocking. Now the strange thing is that overclocking doesn’t improve the frame rate…


#18

Indeed, I think the end result resolution is a better indicator.

By the way, as a reference, using PiTool 1.0.1.121 Beta, I got the following default resolution (Pitool = 1 / SteamVr = 100%) :
Large FOV : > 6950 x 3290
Normal FOV : 3852 x 3290
Small FOV : 2786 x 3290

Original HTC Vive with SS 100% gives 1512 Ă— 1680 (1.4 times native resolution)

Maybe you’re CPU bound ?


#19

I don’t think that the CPU is the problem. It’s an i7-8700… And with pcars, it uses around 50%…


#20

I have done all your settings but I cant get past 60 fps. My 2080 Ti will not work more than 61 %. Is there anything I ca do to make my “lazy” card work 100% ?