Random flashing pixel in Pimax 5K


#21

Thanks I am going to read and try the solution ! Did it solve the issue of the flashing pixels for whoever tried that ?


#22

@park said in his case I believe inthat thread it greatly reduced it to pretty much gone. But as they say results may vary.

It might be an idea if they have the filters available to have on near the hmd plug & the motherboard end on both DP & usb connector. I do recall (i think) some wall adapter psu for monitors & laptops have had this kind of filter on them as well.

Myself? So far so good things seem to have adequate sheilding. But in the end still possible dud as they say.


#23

You could try some thing like this…


#24

Is there any new cable that we can buy and that is optimized to solve this problem?


#25

The headsets use a proprietary cable. So probably not at this time; however if the add these filters in future it really won’t be different than the diy clip ons posted here, save pre installed.


#26

I have returned the two headsets on 22 January and since then nothing.
No reply to my ticket [SUPEN-659] please advise.

@PimaxUSA @Dallas.Hao @Sean.Huang @Matthew.Xu


#27

Was this solved? I have the same issue with the green random flashing pixels on my new 5K plus


#28

You might need a cable replacement. @Doman.Chen


#29

Again I need a Headset to be send back to me as I already returned all headsets and cables in my possession! I HAVE NOTHING AT ALL!

Here is the email extact:

|### Sean.huang|Tue, Jan 22, 1:21 AM||

to 张天遥(kayla), alan.sun, Doman.chen, Steve.zou, me

|

HI,

Received, i have transfered 401 HKD to your Paypal account, please check it.

@张天遥(kayla) please record this info.

黄海 Sean Huang

产品/技术支持/对外合作

Product/Tech Support/BD

sean.huang@pimaxvr.com

小派科技(上海)有限公司 | Pimax Technology (Shanghai) Co., Ltd.

上海市浦东新区龙东大道3000号1号楼A区605室 | +86 13801814612

605A the first buliding, 3000 Longdong Avenue, Pudong District, Shanghai, China.

The problem is both @Sean.Huang and @Kayla.Zhang are MIA and no reply from them since 22 January.

@Dallas.Hao @Alan.sun


#30

Hello, pimax 5k+ received but white pixels flickering , reseating cable, change ports…always there !
i had read that some backers sent their hmd to,pimax . how to open a ticket ?
many thanks for all !:slightly_smiling_face:


#31

It’s been 3 months or so since this issue first appeared.
A headset and a cable was sent to me but I returned it all including the original headset.

I was told Pimax would return me another headset or a least a tracking number…I still have nothing…
Backer 753 and no headset so far…what do I need to do?

SUPEN-659

@Dallas.Hao @Doman.Chen @Alan.sun


#32

Added pimax team members. When you shipped back you used a track service? (Just to make things easier)


#33

Yes they already confirmed returned the two units ok within few days. So I don’t understand why it is taking weeks to send it back to me. I am in Hong Kong should be pretty close.


#34

Okay Yeah remember your original post on this. Will do what I can to try & get this elevated.


#35

Sean has replied to you on your ticket,please kindly check,thanks.


#36

Another week without nothing happening this is ridiculous. I was promised a tracking number last week where it is?


#37

Well, my 3rd headset is here and same problem, even worse now with whole screen flashing black and denser snowing pixels. Really disappointed backer after 4 months of battle with RMA.

@mozi


#38

really sorry, we will send our engineer to on-site check what is the issue.


#39

Sure contact me via my ticket SUPEN-659 to arrange a time for your visit.


#40

sure, will contact with you tomorrow. Thanks again.