[Replied]5k+ Thousands of random sparkling pixels (different colors) all over the HMD, and black screen flickering (image going off/on)


#1

Just got my 5k+

I have a lot of randomized sparkling piksel (noise) all over the display. This issue is there all the time, but increases after more usage. It is subtle in the start…but after a couple of minutes the intensity and amount of sparkles increases.

The HDM also goes black (loss of image) for a split second, and then comes back again. This happes about 3-4 times a minute.

I am unable to register on the support (link at top), get a message that registration in “unavailable”.

Order: P1109
HMD serialnumber: 20360085000544

Please advice!


#2

Please take a video about this issue.


#3

Video? That is not nessesary. There are many many customers reporting the exact same issue.

The issue seems to be in 9.5/10 to be a faulty (badly shielded) cable. I have tried to reseat the cable going into the headset, that did not help.

Please just send me a new (tested) replacement cable. I have already waited a looooong time for the Pimax 5K+ (and it is not cheap) - so this is kinda disapointing to be honest.

I can understand that there are (early) issues with the HMD, but I don’t want to wait and wait and wait for a new cable… please just send me a replacement cable.

Here are some of the posts regarding this issue:













#4

Having the exact same issue here with my 5K+.


#5

Please just send him another cable and send another cable to the many other Pimax users with this same issue. :exploding_head:


#6

I will ask our after sales dept to contact asap.please be patient.


#7

I am the OP.

Folks, to temporary fix this (while we wait for a replacement cable) we can wrap some aluminium foil around the “hub/splitter” where we plug in the power to the Display Port hub/splitter/box something.

Just wrap aluminium foil around this “hub/splitter” and 10cm on each end of the DP cable cable going in/out from this “hub/splitter”. Other users have tried this with success, and I tried for about 30 minutes yesterday - and I saw no more random sparkling pixels! I need to test this in a much longer VR session, but I wanted to report my finding now if it can help others.

This strongly indicates that the DP cable/hub/splitter/power inlet is badly shielded. A new properly shielded cable is required. But by doing this, we can actually use the HMD while we wait for a replacement.

Pimax, this issue needs to be sorted asap before more “faulty cables” (HDM’s) are sent to customers. I am not 100% sure that it is the cable shielding, but it seems that this is the case.


#8

Yes,the new replacement cable will 100% fix this issue.


#9

Is it possible to upload a photo how exactly you shield it? Good for everyone, thanks!


#10

Yeah, I saw another thred where there was a photo, I am at work now… I will try to find it and post it here…

EDIT: Found two images…posted furter down in this thread…


#11

FYI this does not work for most people, e.g. me. I’m pretty sure the first person that tried it also reported that after a little while it was back just as bad.


#12

Okay thanks,looking forward!


#13

Could you offer the cable in shop? Maybe a good possibility for all backers to buy some with there vouchers to have some when it broke by trampling on it or driving over it with the chair?


#14

Here is an image as an example of “custom shielded cable/hub/splitter”
Image is from @Creep (I hope it is ok that i “borrow” your image to help others with this issue):
Creep

Here is another image as an example of “custom shielded cable/hub/splitter”
Image is from @CyrilJ (I hope it is ok that i “borrow” your image to help others with this issue):

Just a little warning: I am a little worried about heat, and heat buildup…so I would unplug the power when not using the HMD


#15

Have the same Problem. Aluminium foil doesn’t work form me…
baker no. 5621
Signing up in the support forum doesn’t work


#16

Doesn’t work for me too ! but we have the same issue :thinking:
baker 5464


#17

tin%20foil


#18

You cs3n just turn it off by holding the power button on the headset.


#19

Oh I fully expect my replacement cable to not fix it, nothing they have done so far has instilled confidence in me or their abilities. I had the sparkling issue, but now it has started to black out. YAY!


#20

Doman,

I have the same issue… Red blue and green pixels sparkling with the screen flicker also.

I can’t raise a ticket as the service is unavailable, i am backer 5966. If the problem is the cable, why were they not checked?

Can you please send me a new cable please so that i can use my pimax 5k+.

Thanks

Ben