[Replied]Dead pixels and black dots in the Display - 5k+

issue

#1

Hello together,

I just found in the middle of the display are 2-5 dead black pixels. ? What can we do ? SUPEN-1556

@Matthew.Xu , @Dallas.Hao , @Heliosurge @Pimax-Support @Sean.Huang


#2

Here are some pictures. There are really not many dead pixels, but unfortunately right in the middle and if you look it is immediately noticeable. And no, it is not dirt on the lenses, it comes from the display!


#3

My God is the horror that I fear the most. Months of waiting and such a thing can break a man. With such dots, you can not fly a flight simulator and search for targets in the sky, and I only use goggles for this, so when I read about bad pixels, I’m terrified. I feel very sorry for you, the only option is surely replacing the goggles: /


#4

I hope so ! thank you for your participation


#5

Oh my god that looks really bad.
I don’t understand that there are so much QA problems with the Pimax HMDs.

I remember that they told us, that each headset is manually quality approved and that leads to the slow shipping … but now each day new defects, broken ports, bleeding and dead pixels are reported.
In addition there are new problems with each new SW release.

I’m really afraid that my Pimax 5K+ is coming and has also defects after over one year waiting.


#6

What shall we do ?

@Sean.Huang , @Matthew.Xu @Dallas.Hao , @Doman.Chen , @Pimax-Support


#7

@Alan.sun @Doman.Chen @Sean.Huang
We will send you a replacement after Tech support confirm this issue in service desk(Please provide picture&videos in service desk)
Please follow these steps:

click the “Support” button on the banner for submit your issue
2.Give me your question number for teach support to contact with you via service desk
3.The issue will be solved soon


#8

The support has the link to the thread! Is that enough ?
Support No. is already in the start post - SUPEN-1556

@Dallas.Hao


#9

Just out of curiosity, how exactly your dead pixels look like? I am asking because what I imagine (and what I saw on the monitor panels) as a dead pixel is a pixel which simply does not light up, but it has the dimensions and the structure as the other pixels, it is just black.

However I observe something on my panel, but it does not look like a simply non lit pixel. Instead it looks like if the whole place was somehow mangled and broken. So I am more inclining to the theory that it is a dirt/dust on the panel (as it is clearly at the same focal plane).


#10

I check the record in service desk, @Doman.Chen is following this question


#11

looks like dirt behind the lens to me. if that was mine i would pop the lens out and clean it.


#12

You can’t recognize the dead pixels in the photos, because you can not photograph them unfortunately and 2. I will certainly not disassemble the Pimax and thereby risk voiding the warranty.


#13

@Dallas.Hao @PimaxUSA
Will removing a lense void the warranty?

Example: theres a factory installed dust and hair behind the lense, would Pimax rather replace the headset or let the user clean it himself?


#14

I have dead pixel on my replacement unit, and support just asked me if i “could just ignore it”

Hope you have better luck than me lol


#15

Can you PM me the actual response (verbatim) from support?


#16

@Doman.Chen has already confirmed to me that a new one will be sent to me.

Unfortunately, I can not access my support account. Something does not seem to be right!


#17

Should be on its way now.


#18

I have the feeling, from the pics I saw here and my “dead pixel” that those dead pixels are simply dust particles on the panels. I wonder if there is a way to disassemble the unit and clean it up? @PimaxUSA


#19

What you see here in the pictures are just the black dots! How should you please photograph 3-4 broken pixels? You only see that when you look through the glasses !!!


#20

Have you seen “dead pixel” on a normal panel (e.g. monitor or TV)? It is a black dot alright, but it still is a pixel of the exactly same shape and alignement as the other pixels around.

I understand that it is very difficult to capture on a camera, and the only way to do it is to get a clear and focused shot of the pixel matrix. Otherwise, since the pixels are pretty small, they will simply disappear in the smudge.

On your shot, I cannot identify individual pixels, but the “black dots” still stand out, therefore I believe they are dust particles and not the dead pixels (which will be smaller).

I have also something on one of my panels and even when I look at it through the lenses and I can see clearly the pixel matrix (SDE) it does not look like dead pixel at all. It is bigger, is spread ever more pixels and has deformed shape.