[Replied]Flicking white dots 5K

issue

#242

how did you record with phone?


#243

Yes I have record with my phone LG V30


#244

So… What’s happen???

It’s been 3 days since I received this answer:

"He will answer your question and give you solution asap"

I’m still waiting…

I made the video as alan asked me the first time before the mail is no longer available and I don’t have answer, no information if he received my email, nothing …

I’m sorry to say that but it’s not at all professional for a company.
12 DAYS your support platform doesn’t work…
12 DAYS I have no solution on your part and yet I do everything you asked me!
12 DAYS I have a Pimax that does not work properly

Stop joking now!
I think I was patient enough!

I don’t want to repair my Pimax 5k + because I have too many problems with that one !!! I demand that I be replaced !!!

@Doman.Chen @Heliosurge @Alan.sun @Dallas.Hao @Sean.Huang @Pimax-Support


#245

Sorry for the late reply.

My tech support colleague has checked the record,your issue has been confirmed.

We will send tracking number to you after your new cable has been delivered from oversea warehouse(My colleague will reply you via email soon)


#246

Your cable will fix my dead pixel…???
I don’t think so…
@Dallas.Hao


#247

I have the flickering dots all over my screen as well how do I start a support ticket. Every time I try to login to support it says my password is incorrect when i have tried to create 2 accounts nothing works

@Dallas.Hao @Doman.Chen


#248

Addedvpokes to your post. Team is working on a solution for Support site & hooefully will have fixed soon.

Which headset did you receive? Are you a backer or pre order?


#249

I was a kickstarter backer #6350 originally backed for the 8k but i switched to the 5k plus


#250

Awesome thanks! :beers::sunglasses::+1::sparkles:

@Dallas.Hao please add to earlybsckers


#251

I’m fed up!!!
I still have my faulty Pimax since 22 days

10 DAYS AGO

and NO address to send back the headset… are you kidding me???

@Doman.Chen @Heliosurge @Alan.sun @Dallas.Hao @Sean.Huang @Pimax-Support


#252

Im pretty sure i just need a new cable. I tried to re-seat it a few times but nothing works. Its pretty well unusable the way it is the dots are everywhere and very distracting


#253

I guess most know, but just in case, there is an official answer thread