[Replied]Headset Stopped Working


#1

I received my headset two days ago. Setup went well, but after about an hour of playtime the headset shut off abruptly and would not turn back on. There was no LED light at all. The power adapter is still functioning, and I tried using a different power supply as well, but no luck. PiTool cannot find the headset. Further, I noticed the top of the headset near where the cables plug in was extremely hot to the touch… I’m assuming the power supply in the headset must have shorted or blown somehow.

Interestingly, if I hook the headset up to my PC via USB-C, the headset will show a red/green LED and will be recognized by PiTool, but the display does not work.

I have opened a support ticket, but due to the Chinese New Year I don’t anticipate to hear anything back until next week. It also looks like the Pimax support page is down right now.


#2

If the headset connector plug was warm I suspect you are correct on a shorting condition.

Sorry to hear. Which headset did you receive?


#3

5k+. It’s also worth noting that the cable packaging was slightly ripped upon receipt, like the cable had been pulled hard through the box. I’m thinking that may have weakened the cable/connector potentially. I’ll update with a picture when I get home from work.


#4

Check the headset side as the cable might not be firmly connected. Though with being hot is likely damaged.

@Dallas.Hao please add to earlybackers.


#5

I’ve tried reconnecting the cable a few times with no luck.


#6

Once there back in the office will need to setup a support ticket to arrange a replacement by the sounds of it.


#7

I have a support ticket open for the issue already, but it looks like the system is down right now and I can’t access it.


#8

Here is a picture of the damaged cable box.


#9

Support site seems to be down. Yeah that package rip is horrible.


#10

@paulh

is the headset still not working?
please share the SUP number to us, tks.