[Replied]HMD not booting/waking up when starting computer

issue

#1

I got my headset in Februari and for the first month it worked almost perfectly. Then I started to get the occasional hickup where the HMD wouldnt boot when starting/restarting the computer. The screens would either turn on, but remain black, or remain off. Usually it would work to unplug and replug the power to the HMD and restart the computer (just turning the HMD off/on wouln’t work), but now even unplugging the power and restarting the computer it doesn’t anymore, and it’s become a rule rather than an exception that the HMD doesn’t boot when starting the computer. The only thing that seems to work now is to completely unplug the HMD - USB, power and DP. Shut off the computer completely. Start computer, plug all HMD cables in, and then restart computer again. This seems to reset everything (sometimes). I initially thought that it was a matter of a small software hickup that I could live with, but it has gotten so bad now to the point that I have to spend a long time just trying to turn on the HMD every time I want to use it. I’ve also tried upgrading to the latest Pitool beta and nvidia drivers, but the issue persists the same as before.

I wanted to create a support ticket, but the Pimax support website is bugged and not working (go figure), so here I am. As if this wasn’t enough I’ve also been waiting for more than a month for a refund on the base station+controllers that I pre-ordered and wanted to cancel too.

I was really happy with the headset initially, but the accumulating problems I’m having with it, along with the absolutely terrible customer support is making me incredibly frustrated and sad. A month ago I would’ve recommended the Pimax headset, but from this point on I definitely won’t.

As of now, I honestly wouldn’t be surprised if I end up not getting refunded my money for the canceled base-station+controller pre-order, nor a replacement for my obviously faulty headset. Sigh I should’ve waited with buying this f-ing headset from this f-ing company…


#2

Try the latest PiTool and use the restart service button whenever you see hardware issue like HMD not turning on or controller not tracking.


#3

Please try this latest pitool version,thanks.


#4

@bucky
Hi bucky, sounds like my problem therefore i have a questions for you.

  1. Are you running AMD CPU (ThreadRipper)

my question is out of curiosity because i am and the resolve is I find and hopefully works for you also is PiServices not managing and executing properly.

So the solution, next time you plug the HMD in light is red and black screen. launch windows task manager and manually kill all task associated with PiServices. Piservice launcher exe, PiServices.exe etc… you can leave pitool open

Right click your pitools icon and open file location. in that directory, find PiServices.exe and run that. Your HMD should be back on.

Let me know if that helped

Cheers

PS - I just thought of this and will try at home tonight I wonder if also setting all PiServices executables to run as admin will fix this issue long term


#5

Please read my post before replying


#6

Thanks for the thorough response. I’m not running an AMD cpu. And it seems I found a fix for the issue (so far) which is detailed in this post: How to solve "Disconnect" or "Not tracked" of headset, base station, controller randomly, image follow head although not use base station. (PiTool 91)

The issue for me seems to have been that my headset wasn’t far enough away from the base station when powering up, and I always kept at it the same place on my desk when not using it. When I put it down on my chair and pulled it away a bit further from the base station, it seems to boot properly. I don’t know if it also played a part but I deactivated all USB power management stuff - both in steam and in windows (also described in the post).

I will return to your post if the issue appears again, and report what I find. Thanks


#7

Please post your system setup.


#8

My system setup is:

z370f mother board
i7 8700K @ 5Ghz
2080ti (minimal OC)
32Gb ram @3200mhz

win10 latest update
pitool latest beta
nvidia latest drivers

(I had my issues with earlier updates of windows/pitool/nvidia drivers too)


#9

Just to confirm Bios & chipset drivers installed & updated from MB website?

Not a fix but may save you time. Kill & restart pi related services.

With headset unplugged (dp, usb & wall plug) press & hold power for 5s to discharge stored energy… & see if it connects without a computer reboot. Something though definitely seems off.


#10

Thanks for the suggestions. I seems to have found a solution for it though (fingers crossed) - read my reply to BigSerge if you’re intersted!