[Replied]Pimax 8K arrived and broke within 5 minutes

issue

#1

So, my Pimax 8K has arrived today, set it up all fine, but there was no sound and the device didn’t show up in the list of audio devices. Pressed Restart in PiTool, then the device restarted a couple times (looked like it was crashed), then finally flatlined. Since then, it doesn’t show up in SteamVR/PiTool and when I plug it in Windows tells me that the USB device is not recognized.

I’ve tried installing PiTool on my laptop and connecting it there, but same error. Bricked HMD or firmware? :frowning:

Device manager shows one of the following errors randomly:

This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

Windows has stopped this device because it has reported problems. (Code 43)

A request for the USB device descriptor failed.

For reference, I’ve tried re-connecting the device to everything, turning it off and on, reinstalling PiTool, restarting my PC and even reinstalling my PC from scratch in case I had corrupted drivers.

In case someone from the Pimax team sees this, made a ticket about this, SUPEN-2297 @Doman.Chen @Dallas.Hao


#2

Which version of PiTool are you running? That’s key for people to help, as the most recent is more unstable than others.

Also are there any LEDs blinking on the headset? What color are they?


#3

The headset LED is not blinking, it’s a flat red. PiTool is 1.0.1.95 but have tried with 1.0.1.76 too, same result.


#4

Solid red means: DisplayPort cable or power issue.

Is the cable fully connected at the headset?

Can You measure the power adapter?


#5

Huh. Wiggling the cable at the headset side seems to have worked, though I see no indication how the cable could even be released on this end. Will experiment and come back in a bit if it works.


#6

I doesn’t look like it but it does come loose… :wink:

It’s not the first headset with a loose cable.


#7

Well, it worked for around 5 minutes, then died again… I wonder, maybe a faulty cable? or it’s very loose inside the HMD, but there is really no way to move the cable without disassembly


#8

@dallas.hao the cable can be removed & replugged.

Are you a backer or pre order?


#9

Kickstarter backer. Also I think that ping didn’t quite work


#10

Ping?

@Dallas.Hao add to earlybackers


#11

Oh yeah had to push down the shroud to pull out the cable and push back in, though didn’t help. I’ll try pulling it out and checking the cable itself. Maybe some dust?


#12

Nope, that did not work.PiTool Diagnose says neither USB nor HDMI/DP is plugged in. Red LED on constantly. The power should be right, since it did work for 5 minutes again…


#13

Broken USB port ?

Can you try in another pc ? Use the back USB ports.


#14

You could also try a different USB port. That has also been the problem for some.

I actually think that someone also had some dust in the plug at the headset end.

EDIT: What @Douglaster said… :wink:


#15

Nope, different USB port didn’t work. Tried blowing into the headset end port and connector but didn’t work either. At this point it’s possibly maybe power or the cable itself, tho the latter is unlikely since that wouldn’t have worked for this long…


#16

I’ve also tried my other computer earlier but same result.


#17

If You have a universal power supply You can try using that?

All You need is a 12V/2A power supply with a plug that fits. It’s OK if the amperage is higher than 2A, but it must be 12V.

@Doman.Chen: Any ideas?


#18

I’ll get one tomorrow, they are handy to have either way (don’t have one at hand but I really should) and if it works it’s easier and faster than sending it back…


#19

I would do the same and then probably ask for a new one anyway.

Good luck! :wink:


#20

Sounds like USB problem.

One thing you have to understand is that, the USB driver is buggy. It may work this time and as soon as you turn the device off, and on again it could either continue to work or just show red light, or show green light but not rendering. Restarting piservice may work but not guaranteed to work everytime. A reboot may get it going but also may not guaranteed to fix it.

If you experience something like this, it’s probably not a faulty unit. It’s just the pimax driver still not great.

I had the USB device not recognized issue and moved the pimax to a 3.1 type c port solved it for me.