[Replied]Pimax Headsets Do Not Track After Upgrade


after PiTool upgrade to the latest version, both my 5k Plus and 8k do not track anymore. I have tried the suggested fixes (deleting lighthouse config files, restarting services) but that did not do anything.

I actually wanted to do some nice Pimax videos, but rightfully, I won’t do so now. How can it be that upgrading will BRICK the Pimaxes in such a manner? Have you still not heard about testing these updates yourself before putting them out into the public? I heard you will need to remote connect to my computer now? Or can you fix it via update of a pitool update…?


To what firmware version?

1 Like

indeed wich firmware upgrade?

Everything is the latest. HMD FW

Others stated that latest batches of 5k+ came with 183 version also with removed black dots.

pitool is 195?correct me if i am wrong

That is correct, latest pitool version as well.

After the update, if I shake the headset towards the lighthouse for three to five minutes, it wakes up.

1 Like

haha…so everytime I start the thing I should make a 5 minute awakening dance now? :slight_smile:


You should make it part of your next video if you do. :wink:


I do so if I boot or reboot the pc. :sweat_smile:

1 Like

I suggest the funky chicken Dance:


that would be funny at least. Like a tutorial.

"After you update to the latest pitool version, the Pimax engineers have included a little gimmick to get you moving: take the headset in your hands, facing towards the lighthouses and dance the Makarena for 5 minutes! Like this, your headset will start to track and you are directly warmed up for your first session of the day!

Official Pimax statement: We are more transparent than ever now! We got lots of feedback that the community enjoys this kind of physical activation. So that is why we directly built it into our update! As what our quality control is concerned, also that is much better now! Before we uploaded the new update, our new intern confirmed it worked A okay when he tried yesterday!"


You assume that they tested the software before uploading. I wish I could believe that. :stuck_out_tongue:

1 Like

I don’t have lighthouses & controllers but otherwise pitool 95 inatalled & upgraded no problem on my end. But can’t test LH tracking.

Your headsets don’t connect? Or is this just steam tracking?

1 Like

Paint can mixer anyone? :joy:

I do not like your recent attitude at all. :-1:

1 Like

The download link works. :smirk:

thanks man, I take this as a compliment! :slight_smile:


It is the lightouse tracking that does not work after the update.

1 Like