[Replied][SUPEN-1817]Headset Stopped Working


#1

I received my headset two days ago. Setup went well, but after about an hour of playtime the headset shut off abruptly and would not turn back on. There was no LED light at all. The power adapter is still functioning, and I tried using a different power supply as well, but no luck. PiTool cannot find the headset. Further, I noticed the top of the headset near where the cables plug in was extremely hot to the touch… I’m assuming the power supply in the headset must have shorted or blown somehow.

Interestingly, if I hook the headset up to my PC via USB-C, the headset will show a red/green LED and will be recognized by PiTool, but the display does not work.

I have opened a support ticket, but due to the Chinese New Year I don’t anticipate to hear anything back until next week. It also looks like the Pimax support page is down right now.


#2

If the headset connector plug was warm I suspect you are correct on a shorting condition.

Sorry to hear. Which headset did you receive?


#3

5k+. It’s also worth noting that the cable packaging was slightly ripped upon receipt, like the cable had been pulled hard through the box. I’m thinking that may have weakened the cable/connector potentially. I’ll update with a picture when I get home from work.


#4

Check the headset side as the cable might not be firmly connected. Though with being hot is likely damaged.

@Dallas.Hao please add to earlybackers.


#5

I’ve tried reconnecting the cable a few times with no luck.


#6

Once there back in the office will need to setup a support ticket to arrange a replacement by the sounds of it.


#7

I have a support ticket open for the issue already, but it looks like the system is down right now and I can’t access it.


#8

Here is a picture of the damaged cable box.


#9

Support site seems to be down. Yeah that package rip is horrible.


#10

@paulh

is the headset still not working?
please share the SUP number to us, tks.


#11

Still isn’t working.

SUPEN-1817. The ticket has been open for almost 2 weeks now with only one response asking me for information I had already provided.

@Dallas.Hao


#12

Team was away for a week.


#13

It’s now been a month since I opened my ticket and over a week since the last reply to it. I was really hoping this could be resolved by now.

@Dallas.Hao @Sean.Huang


#14

Still no response. My ticket category was changed to ‘discussing’ but I received no actual reply.


#15

in the same boat supen-1860, I am starting to lose my patience. How can I tell anyone to buy a pimax if by the chance it breaks like mine you wont receive any support unless your a big shot youtuber or cause enough drama.


#16

That’s really rough. Pimax really need to aquire some new staff members for the support asap. I got mine last week on Ebay and so far it runs well and does not get very hot. Nevertheless, after reading so many threads in this forum I’m really concerned for my HMDs durability.

I feel you folks, being an early adopter and been left with a broken device is just the worst.


#17

Please check your ticket again,thanks.