[Replied]Vive Controllers in Wrong Place. Help Please

issue

#1

I’m using my 5K+ and for some reason my Vive controllers are horribly misaligned.

My Vive Controllers are on the other side of the room when I am holding them and it makes everything totally impossible to play.

Anyone know how I can get my Vive controllers to be in the right spot and properly aligned?

Please Help me.

Thanks

EDIT:
While drawing out my play space in the SteamVR Room Setup that the controllers are in the proper location. HOWEVER, the location of the headset is tied to the base station.

No matter where I move the headset, SteamVR thinks the Headset is directly on top of the base station

Any idea why my headset location would be stuck on my base station ?


Question for .bat programmers (start & stop service and tasks)
#2

I don’t have any Vive controllers, but I’d suggest re-running the SteamVR “Room Setup”. Just run SteamVR and right-click the SteamVR main window (not the SteamVR Settings window).


#3

This did not work but I noticed while drawing out my play space in the SteamVR Room Setup that the controllers are in the proper location. HOWEVER, the location of the headset is tied to the base station.

No matter where I move the headset, SteamVR thinks the Headset is directly on top of the base station.


#4

Maybe try the Pimax room setup, then the SteamVR setup? That’s what I did and my headset is tracked properly, but I only have 1 base station and no Vive controllers. I only intend to play seated games, since my play area is just 2 x 2.5 m (in my office by my desk).


#5

Try going into steamvr and re-pairing them.


#6

Sorry mate, mine ( version 2’s ) setup correctly and worked as intended… I ran the Pitool setup first and paired the controllers then opened SteamVR from Pitool, then immediately re-ran the setup in SteamVR using the room scale option.


#7

A mí me pasó y solo tienes que desinstalar pitools y volverlo a instalar. :wink:


#8

I have a similar problem since installing latest pitool 1.0.1.109. for me, headset seems to be ok but the controllers are other side of the room and pointing in the wrong directions but they track my hand movements (just translated and rotated from the actual of the physical controllers).


#9

Hi, that happend when you power-on your pimax after starting you computer.
You just need to restart the pimax service on windows, and restart steamvr and your controleurs will on the good place.

I shut-down my 5k+ all days, and I need to do this alltime I want to start an vr session.


#10

this does not happen with mine, no matter where i leave the controllers of if headset was on or off when starting computer.
Only issue i had with controllers was when accessing steam vr setting when in game, could not click anything or exit.
Was using Steam Vr beta. now using normal version and no issues with controllers.


#11

Had the same issue (controller visible but sort of mirrored to opposite direction), deleting the LH folder and restart did the trick for me. It actually happend a couple of times and it always worked, quite an annoying process though.


#12

Deleting the lighthouse folder then restarting your PC or restarting PiTool ?


#13

Had the same issue but I thought version .111 solved it


#14

Only thing worthy restarting is PiServiceLauncher.exe service.


#15

Well, I restarted the PC but probably restarting piservice may would have been enough, worth a shot. But apart from the time-consuming aspect (my PC is rebooted in no time though) it’s pretty much the same cuz piservice is basically being restarted by restarting the PC as well. And restarting steam for deleting the LH folders seems advisable as well. Admit, I don’t know exactly why😅.
So depending on your Autostart options actually rebooting your whole system may be a time saver after all. And before taking people through the whole open TM->go to services… procedure, simply rebooting solves a lot of stuff after changes at times. I’m stoked that this is less necessary on win10 than on previous OS though.


#16

I’m not sure why, but there have been a couple of times where my 8K seems to have locked up (black screens) and stopping all the pi* processes and starting PiServiceLauncher did not fix the problem, but a reboot did.

I’m assuming that the USB connection needed to be rebooted (or something like that).


#17

Yeah issues are sometimes kinda chained. Of course it would be optimal to know “the why” of each and every step but sometimes a reboot does the job. Annoying though.


#18

@Doman.Chen

Here to help please


#19

Please try the latest pitool version,thanks.


#20

@Doman.Chen this issue occurred for me after i installed the latest version. Prior to that I hadn’t seen it before. v1.0.1.109.