[Resolved]Can't get into SteamVR on laptop please help!


#1

hi guys i just got my pimax today and i cant get it into direct mode, please take a look at the 2 scenarios i am encountering.

Specs: Dual graphics integrated and GTX 1070
Laptop Model: Acer VX 15

Scenario 1:
I don’t disable the integrated card but instead I enable the GTX for both 3D and physx. When I try to launch SteamVR, it says (unresponsive) SteamVR home. My headset icon below is green and working, its just steamvr home can’t launch on the headset.

Scenario 2:
I turn the integrated graphics driver off from device manager. At this point, I cant even get into my Nvidia controls, it will say your monitor is not connected to this GPU.
Piplay searches forever and can’t find the headset.

Conclusion:

Does this mean the problem is the HDMI output on my laptop is connected to the integrated graphics and there is no way I can switch it to the GPU? If so then it seems there is no way a Pimax will work on a laptop except in the that stupid extend mode.

Is there anyway to get this working? Please share your comments with me thanks!


#2

Can you post more details on your laptop model?

When i search Acer vx 15 i can only find this model comes with a 1050 or 1050ti.

Reviews on the 1050 gpus are not strong enough for vr.

There was in the past VR ready laptops that were not vr able as the hdmi port was attached to integrated gpu n not the nvidia one


#3

I believe its the gtx 1050. Processor is a i7-7700hq.

What I really want to do is run things like Big Screen or Virtual Desktop to watch movies and play non VR games like overwatch. Maybe i’ll try some VR games for fun. But yeah those are the main things I want to do so all I need is to get steamvr to work.

I mean, if I wanted VR gaming, I wouldn’t have bought the Pimax at all.


#4

your GTX card has only 1 output ?


#5

im on a laptop, yeah only 1 hdmi output


#6

Hmm I did some quick googling (as you probably have done already too) and it seems you can’t get Steam to select a specific GPU, quite a few others having this problem with Vive, Oculus etc.

Maybe @PIMAX-Support has an idea ?


#7

Hmmm… General reviews says the mobile 1050 not strong enough.

If you can get into the laptop bios see if you can disable the igpu. Its likely that of only disabled in device manager that steamvr can still see it due to low level acs.

Some of the alienware laptops don’t have the dual hybrid graphics enabled.


#8

I suppose running a vr headset , for a laptop, looking for one that has additional display port, confirming that GPU is processing VR graphic not the intel one. Then a DP to HDMI adaptor is required.


#9

I hope so too. All I want is to get steamer working!

I found out that u can’t turn the igpu off through bios for Acer because the monitor is plugged into it. That’s why this option is missing in the bios. So game over then I suppose :dizzy_face::dizzy_face::dizzy_face:


#10

Mentioned this before in another thread… Search Google for use desktop graphics card on laptop.

You can use a desktop graphics card with a laptop if you can get your hands on one.

Eno


#11

so basically external gpu? i wonder if its worth it just to use the pimax lol


#12

I have seen the adapters @Enopho is mentioning. They use one of the mini pci-x ports inside (same type the wifi/bluetooth module). Definitely neat


#13

it is neat, but after u add all the costs in, i could build a decent desktop for a little more lol


#14

I guess This tutorial may be helpful.


[Resolved]Extended mode only?
[Resolved]OVR_Laucher crash
#15

Thank you guys.

Just now, we fixed this issue for @Imperator 's laptop remotely through Teamviewer. After our analysis, it should be a known bug which has been solved in Piplay 2.X version. The issue may appear in parts of laptop without “VR Ready” mark.


#16

So 2.x out soon? :v::smirk::+1::sparkles:


#17

After installing PIPLAY, it found a low graphic card like my R9 290, i must go to piplay s settings and clic on a button “complete version” to enable PIMAX MODE.


#18

Good to read it, I have a laptop with GTX 880m (8 gig). :sweat_smile:


#19

I’m suffering the exact same issue and I have a similar configuration. I asked about a fix weeks ago and even posted my own logs in the new version topic. What did you guys figure out??


#20

Sorry friend @Vort3k , not sure whether you suffered the same issue as per the logs you sent. If you are available now, please send ID & Password of Teamviewer to support@pimaxvr.com :sweat_smile: