[RESOLVED] Oculus Games won't launch

fix-guide

#1

Just received my Pimax Friday and one of the considerations of purchasing it was to be able to play Oculus games on it. Unfortunately, so far I haven’t been able to get them to launch.

I have the latest GeForce and PiTools software installed. (could this be the issue?)
I installed Oculus Store/Library BEFORE installing PiTools
My Oculus games show up in PiTools.
I turn off SteamVR, launch Oculus Store and try to launch an Oculus title within PiTools and a message appears that says I need to start Oculus Service and nothing happens.

Sounds like this is happening to others as well I hope someone can help soon as it was a big part of why I bought the Pimax.


#2

I haven’t ran any Oculus titles since before my system upgrade & will need some others to weigh in.

I think @dogbite might have oculus. It sounds like Oculus store isn’t launching the service?

Which headset did you receive & are you a backer or pre order?


#3

Is the oculus service showing up in task mgr? @kknutson

You should see Oculus Service Launcher and OVRServer_x64.exe 215623-public


#4

I am a pre-order and as far as which headset it is the 5K+.


#5

Both of those things are running in background processes even before I click “Start” on oculus game. WHen you hover over the Oculus game icon it gives the message “need to launch Oculus service” even though its already running.


#6

Not sure I can help. I was already a Rift owner and my only issues were just wouldn’t run or “out of memory” errors because my Rift games were already set above 1.0 hmd settings in game. Once I backed them down to 1.0 and kept Pitool at 1 or 1.25 (depends on the game) I was good to go.
I am assuming you don’t own a Rift and if so perhaps someone in that same situation will weigh in.


#7

Here’s a thought. I just read a reddit post where the person solved the problem by reverting to Steam VR 1.1.3 said the latest version didn’t work. This suggest Pimax may be linking to SteamVR in the Steam library even though it doesn’t appear to be running. Steam VR is OpenVR.
Here is a link to SteamVR 1.1.3 https://drive.google.com/file/d/1QGS8v36mrh7COTDNgDv2fLW1H1LF4Eve/view?usp=sharing
All you need to do is rename your Steam VR folder and put this one in it’s place. This one won’t update so future updates won’t have you start all over again. I use this one because Dirt Rally wouldn’t load with the latest version. makes some sense as Dirt rally only has Oculus support (have to use Revive for DR).
Worth a shot. If you try this let us know how you made out.


#8

I do actually own a rift, I just have the Rift hardware hooked up to a different pc than my Pimax. My understanding was you don’t need the hardware (just the store/library) but I am starting to wonder.


#9

Rift games are working ‘out of the box’ for me. Latest steam, latest nvidia drivers, latest non-beta pitool.
Pimax turning on and tracking depends on whether it feels like it on the day but luckily rift games are working for me.


#10

Flinnt, just curious, do you have oculus hardware setup up on that same computer as well?


#11

I figured out what the problem was. Norton Antivirus was blocking a potential threat upon installation that had to do with the oculus launcher. I disable Norton and reinstalled Pitools and now it works! Hope Pimax figures this out and makes adjustments or instructions for others. Thanks for the help.


Table of Contents (Wiki)
#12

Norton has been known to be aggressive. As can other AV.

I had I tgink it is Jet Moto 2 update in steam. Fir a long time it would not run. Found out my AV was quarantining the launcher.


#13

Great news. The info will certainly be helpful to some others in similar circumstances as they get their Pimax’s. Glad you posted your resolution.


#14

Was Norton blocking A pimax file or Oculus? We can add solution to Table of Content Wiki & Getting Started Faq.


#15

It was blocking an oculus file upon installation of Pitools.


#16

Yes. None of the Oculus hardware is connected but it’s all still there and haven’t removed any software from Oculus.


#17

#18

Sorry guy. i have no idea what you did in that video. Even if I could guess what folders you were in (ln English) the text is too blurry in your vid for me to make it out.


#19

Create steam_appid.txt in the folder where dirt rally is installed and write 310560 in that file


#20

Thanks for the clarification. Unfortunately the overhead introduced is as bad as Revive. The sense of speed is terrible and the overhead causes a delay in steering.
Afraid the Rift is the only way to really appreciate DR as the simulator it is.
Thanks for the tip though. Was worth a shot.