(Resolved) PiTool opening then closing


#1

I’m expected to get my Pimax very soon so I figured I’d download the PiTool and get familiar with it , but no mater what I do it opens with its logo then closes right away , I’ve tried running and installing with administrator , all three versions that are out , all do the same thing , there’s been mention to reinstall windows , but that’s abit frustrating when this is the only app that does it , it must be on PiTools side that this is happening , any input would be great thanks


#2

Hi mike can you post some details on your setup?

If you know how to use Commandline; launch pitool there as it will provide additional info.

@sjefdeklerk is a great resource & uses techniques like this.


#3

Thanks for the reply , I have some common sense on command prompt, but it’s been awhile if you have some time maybe you could give me a step by step


#4

Truth why I poked @sjefdeklerk.

With linux I can get around easier. Windows though it’s been awhile.

But if you know how to get the command prompt to open in the pitool tool directory.

Simply type pitool & hit enter.

Dos days i had no difficulty changing directory.

You might be able with the long name be able (case sensitive check)at cmd prompt)
Cd programs x86\pitool

However the path structure looks.


#5

Haven’t really messed that much yet with the new pitools. Will (hopefully) be getting my HMD this friday, will be able to assist better after that.


#6

Pitool does work on the p4k. I figured more on the commandline assistance. With command prompt do you need to cd to the appropriate directory or can you open it in the directory or launch straight from C?


#7

i was able to try it in command prompt , but same thing as clicking the icon


#8

The command prompt window did it show any errors? As this might show something not on the desktop.


#9

so i been trying and reading there is a error in the event log in windows , but nt sure what it is , no I just cd to program files cd pimax ran the exe and it tried to start again but some thing no error report , one thing i noticed is its going in program file , shouldnt it be going to program files x86 , this is driving me nuts you pay so much for a unit but with these sttupid problems


#10

Where programs store themselves can vary. Usually the x86 directory is where 32bit programs are installed. But this will vary by software developer & user preference. Like many here I have Windows installed on an ssdd & have programs install to d drive.

The log file if you can post it may help.

@Enopho is a good resource. It sounds like something is missing and/or something is preventing it from launching.

Something to try as some AV programs may flag a file during install. Windows Defender works but many prefer other AV programs for security.

Disconnect from the Internet. (Very important)
Disable AV
Re Install Pitool as admin
Let Pitool launch (should hopefully work)
Enable AV (perform scan for peace of mind)
Reboot & connect Internet


#11

yeh i just tried all that unless im missing something i cant seem to get it to work , thanks for your help tho , i think im gonna have to try a fresh copy of windows if that dont work its gonna upsetting , no one else seems to have this issue


#12

Directx & vcc redistrubute(sp) often installed with games also needs to be installed. I see Eno is about to post.


#13

Hi Mike

I am on my way home from work right now and the train will have quite a few tunnels on route. So replies may be spuradic
When you installed piplay, did you choose the default install directory? Did the install complete with any errors or files blocked with Antivirus? Are you able to check windows event viewer for any application or system errors at the time of the error happening?
Are you able to export the PiPlay log files please?
Regarding the install going in program files, installers check whether you are running 64bit windows and if the installation is 64bit compliant it will install in the program files directory. If it is not compliant or the pc/laptop is 32bit it will install into the program files x86 directory.

Eno


#14

ok so thank all of you for the response of help , appreciate it alot but i ended up emailing pimax i just got a email from some on there team sean huang and thank sir for your response , he emailed me two files to replace in the pimax runtime folder *libeay32.dll and ssleay32.dll , so I put those two in and it started up , now im happy it works but just a little confused why it happend to what it seems to be my system only but so far it works thanks guys


#15

Great to hear! Thanks @PM_Sean
Will resolve this ticket for you!

Eno


#16