Rift P1 kills my internet connection


#1

From a few weeks ago, every time I connect my Pimax 4K headset to the pc (I plug in both HDMI and USB cables), the internet connection is lost.

I started doing some tests and the only way to solve the problem is by eliminating the “Rift P1” device in the windows connected devices. I eliminate it, even without unplugging the HDMI and/or USB cable, and the internet connection goes back to working normal again right away.

I tried everything else I could think of, but I’m out of ideas. Anyone can help me out here?

Thanks!!

@Community @Pimax-Support


#2

It sounds to me that some kind of conflict is having with your network device.

Can you post your system specs & headset info? Please include motherboard model.

Have you tried a different usb port?


#3

Can you also advise what network method your using as well as the device model and driver version as well?

I.e wireless, wired? Wireless Device model or ethernet card? Adsl or cable/fiber etc.

Or if your using a custom solution like USB to ethernet adapter?

Thanks

Eno