So far a sub-par experience, feels like beta testing


#4

Okay, I got your headset to halfway work, but only under a very specific set of configuration criteria. This is what I meant by saying that I feel like I am beta testing, even though I had to pay to do so instead of getting paid.

If my main display is on GPU0 and the Pimax HMD is on GPU2, I then install an older version of PiPlay in Direct mode only, then and only then does Steam VR detect the PiMax HMD, but it displays the compositor feed on the Pimax HMD instead of the main display. This means when I start a steamvr game, the game only shows on the main display while the headset displays the wire frame room compositor. I’ve tried switching the main display and headset HDMI cords between GPUS and switching SteamVR to direct mode. Nothing makes a difference.

The important part is that I have proven beyond any doubt that your software is to blame and not MSI, AMD, NVIDIA, SteamVR, etc.

If you guys cannot come up with a fix within a reasonable amount of time, I’m going to return this useless hunk of materials and bad software, and go buy myself a real Oculus Rift. It’s great that the PiMax 4k has a 4k screen, but with such bad software, lack of compatibility, and lots of excuses with no fixes I ask what good is a 4k screen if you cant even get it to work the way it is supposed to?

Fair warning, if I have to send this product back, it will reflect in my review as well as be made very known on the internet, if you want me to make you famous, I’ll be glad to. I’m not asking for anything impossible here, I’m actually being very understanding despite paying for a product that does not work.


#5

@Hvel_the_Log,
We totally understood your expection and what your’re feelling. We’re so sorry that we didn’t do well and let you encounter this compatible issue. but pls trust us we’re working hard to solve it.
We had internal test with GTX1060 desktop and MSI GTX1060 laptop, everything works fine on GTX1060 desktop while the direct mode doesn’t work on MSI GTX1060 laptop. three parties (Pimax,Nvidia,MSI) are involved in analyzing this compatible issue. currently we know that the Nvidia dirver on MSI GTX1060 laptop is different from GTX1060 desktop. and the new “HDCP” feature in GTX1060 laptop cuase the direct mode failure. we have verified one solution to solve this issue: set one bit in a EEPROM chip in our headset to match the HDCP feature in msi laptop. after doing so, the compatible issue was fixed. But the bad news is we have to use JTAG tools to set this bit since it is under low level firmware. it is a bit complicated and we’re trying to figure out a simple way. it might need one more week due to Chinese National Holiday(10.1- 10.7). In next batch manufacture, we will set this bit as default.

Thanks for you patient and tried Pimax on Desktop. AMD 290 is OK with Pimax. but all VR headset don’t support SLI now. To make the thing simple, you can just set Pimax into “compatible mode” and install Oculus 0.8 runtime instead of piplay. pimax is works well with OC driver. When OC0.8 recognize Pimax, then start the SteamVR and it will work too.


#6

How to set the device into compatible mode, pls refer to


Thanks!


#7

Thank you for the response, I’ll try to be patient on this issue, but please do not delay. Okay, for some reason, I rebooted my desktop and now Oculus detects the PiMax. SteamVR still doesnt work (something about the compositor is not available), but this is the first real progress I’ve had in a few days.


#8

Alright, I have been patient and it’s been a week. Where is the fix? I have the latest firmware, but the headset is still stuck in OC Extend Mode. Before my return period expires, please tell me if a fix is truly inbound or if this is a problem that you cannot fix. It’s simply not right that I wont be able to return this product because you took too long to respond and issue a fix. This is a good indication of what I can expect from PiMax?


#9

Already tried the OC_Plugin tool, as well as the native PiMax tools, and it neither works for my AMD desktop nor my Nvidia VR Ready Laptop.


#10

Nevermind, I’m about to return this expensive hunk of Chinese junk, and I will NEVER make the same mistake of investing in PiMax or any other unknown Chinese company. I will also be letting prominent reviewers know about this experience, lack of support, and lack of solutions. I’ll instead be buying a real Oculus Rift that doesnt have a 4k screen but will actually work for what it is advertised to do. Meanwhile I have still lost money in that return shipping is paid for by the customer. Your company has cost me time and money and I really don’t appreciate that. However, thank you PiMax, for teaching me a valuable lesson in taking chances.


#11

I know only one good chinese headset - deepoon e2. Its just copy Oculus Rift DK2 and work with oculus drivers directly. And there are no problems with them. And in the middle of the lens is very sharp. But of course Samsung OLED FullHD matrix has SDE and real Low Persistence and Asynchronous Timewarp (now spacewarp).


#12

I feel so sorry about it. But in fact, we are still creating the new version for laptop because it is a big engineering. We had a meeting the day before yesterday to talking for laptop.
But do you have Pimax mode? If you have Pimax mode, just use it because Pimax mode and direct mode is the same.


#13

No, unfortunately I was not able to achieve Pimax Mode or Direct Mode, or I would not be returning the headset. No matter what on my desktop with 3x R9 290X and on my laptop with GTX1060, it was stuck in OC_Extend, since day one. It’s not just a laptop problem because this also happens on my AMD desktop. Also, I was able to find an Oculus Rift CV1 used but resealed in perfect condition for $350, so there goes any reason I might have had to buy a Pimax. I’ll be nice since you aren’t a well known company and despite my loss of money and time, I’ll summarize the PiMax4k VR headset like this, a mostly satisfactory but dim 4k screen that only seems to be utilized for upscaling, buggy, unfinished software that is just not ready for a full consumer release. I still feel like PiPlay and the Pimax drivers are an early beta release, and I am not willing to waste my 45 day return window waiting for engineering to fix a problem that I feel no amount of engineering will fix. I get the feeling that if I put my trust in your company you’d just sweep my problem under the rug and release a new model with fixed hardware that is surely waiting in the wings with HDMI 2.0 and working HDCP capabilities, meanwhile I’d be stuck with what amounts to a prototype that wouldn’t even be worth selling.

I certainly hope that your company does improve and gains a fair foothold in the U.S.A. by way of good business and satisfied customers. I certainly welcome more competition forcing technology forward and price of adoption downward, but this is not the way to make a good impression. Your software needs alot of work, and as polite as your staff is, they definitely need to be more in tune with what your engineers are capable of, because this situation should never have happened. You charge a “finished product” price, I expect a finished product experience. So far I have had a much better, no a superior experience on my $50 GearVR and Samsung phone… a phone for crying out loud.


#14

Thank you for choosing our Pimax, and give us a lot of suggestions. You helped us a lot to improve our product. We are so sorry that we can’t give you a good experience.


#15

Most of the notebook integrated graphics cannot be disabled, this may be the reason why you can’t connect on direct mode .


#16

Thank you for the reply. I don’t think that is the issue, because the hdmi port automatically selects the DGPU and allows me to have full access to the control panel, it also disables Optimus. Another point is that on my desktop I have the igpu disabled at the ddiver level and am running the Pimax directly from my r9 295x2 and the same problem occurs.


#17

The notebook is different from desktop computer. About notebook, hdmi is connected to Integrated graphics and the Graphic signal will get into Integrated graphics first. The DGPU works only when there is too much
pressure.
I have both notebook and desktop pc. I could only select my pimax to direct mode when I disabled the Integrated graphics .


#18

Exactly what I am saying, i disabled the iGPU on my DESKTOP, and still could not select direct mode.

Also wanted to update everybody. I’ve been using an Oculus Rift CV1 for about a week now and I absolutely love it! I plug it in, installed the software and it worked out of the box. I can do VorpX, Oculus Home, and SteamVR without any bugs or compatibility issues at all. It worked on my laptop, my desktop, and the extra laptop that we have. No issues at all. It’s a real shame I couldnt do this with the Pimax. That being said, it really proves how the Pimax was a late alpha/early beta experience that never worked right for me. So not worth the money for those that it is incompatible with.


#19

Hvel, I’m curious, how does the display resolution and brightness compare between the two headsets?


#20

I wish i could tell you, as i could never get the Pimax working for anything other than Piplay, so I dont have any valid comparisons to make between the two of them. The Oculus has what seems around the same brightness as the pimax, maybe a little brighter, but not by much. Again, I cannot judge resolution because so far I’ve only used Direct Mode on the Oculus and never could get anything worth playing to work on the Pimax. I will say that there is some SDE despite the choice to use Fresnel lenses, but all in all it’s still a beautiful picture on the Oculus and best of all it works.


#21

Hi, please try to use the latest Piplay version:


This version solves a lot of problem.
Thank you so much!


#22

nothing your version will not solve, headset with the new patch not working with the software steamvr


#23

Like I said, I didnt want to wait for their engineers to fix what I don’t think they can fix, without breaking something else. I lost all my confidence in this company the minute their product could not be made to work via troubleshooting, no workarounds available, somehow incompatible with multiple vendors despite Oculus being compatible out of the box with multiple vendors. I really think they are misdiagnosing the problem because the headset didnt work on my desktop either.