SOLVED: Fake Controller for Oculus games? (Chronos)


#21

How do you start the server without launching PiPlay? Did you somehow configure it to launch on system start?


#22

Congrats.

Piserver starts automatically for me. I can’t remember configuring it, don’t think I did.

I run at 0.9 supersampling in steamvr to fix judder. I find vsync settings make a difference too, i have mine set to fast sync.


#23

With the steam update today, the PS Eye icon is now astive on my Steam panel!

Thanks again to jonnypanic for the help!


#24

No worries. I advise not playing Chronos on hard mode, it really is hard.


#25

Getting no joy trying to get Chronos to start.

  1. Install and test PSMove service with PSEye (test camera to make sure it works). Install latest version of Revive
  2. Reboot machine
  3. Launch Piplay (1.2.57) in Pimax mode
  4. Switch on Pimax and wait for Piplay to detect it
  5. Launch PSMove service as Administrator (check, in console, that PSEye is detected)
  6. Launch Steam as Administrator
  7. Launch SteamVR from Library > Tools. This opens up the mini SteamVR window (nothing but the gridded hemisphere in the headset, though). It also fires up Revive
  8. Launch (Play in VR) gunfire-games-IIc-chronos

Chronos runs through its publisher animation and then displays ‘Please check that your headset and sensor are connected’

Can’t get any further…Any ideas? Lucky’s tale and all the free (non-touch controller stuff) works fine.


#26

post an image of your steamvr console ( the one with the hmd, sensor, and controller icons and the settings dropdown.


#27


#28

your psmove service/ ps eye is not working. Look at my post of APR 25 to see what you should see on the Steamvr dialog. There should be a green icon of the ps eye.

go to this thread for more technical detail of what I went through to get the ps eye working https://groups.google.com/forum/#!topic/psmoveservice/pYYxjzB-n1o5


#29

Thanks for getting back to me. Appreciate that.

That URL is dead, mind. I did follow your https://groups.google.com/forum/#!topic/psmoveservice/pYYxjzB-n1o5 instruction to April 23 with the same experiences. I got to the point where you say 'I wish I could point to one thing and say “it was this” ’ - no ‘it was this’ for me though.

I know you didn’t install VRidge but what the heck, I’ll give that a whirl.


#30

I very much doubt you will need vridge…

just keep at it and don’t forget to run things as admin, especially if you use win 10.

I am playing Chronos these days and think it was worth the effort.


#31

Yay! Working now. Chronos was worth the effort, me thinks. Thoroughly enjoyable and just a wee bit different to anything else (in a good way).

My problem was that the batch file was falling over when trying to copy the PSMove drivers to the Steam/Steam VR directories (odd location, environment variables wack, dunno).

To fix this, I opened up the .BAT, copied the indicated files and ran the executable to add the driver manually. As soon as I’d done this, I fired up Steam VR and happily spotted the PS Eye icon. Chronos was fine after that


#32

Folks using Psmove & such. With Trinus psvr they have got head tracking working.

What i am curious about… What about re creating the blue lights on the Psvr headset on the PiMax? & see if you can get it to track this way?

If course as per limits with psvr you need a fairly darkened room.


#33

It is a bit old topic but for the interested I do advice to check out Driver4Vr or Kinect2Vr