[Solved] HDM/USB connected but not recognized as Display


#1

Hi,
ive got a Problem with my new Pimax 4k, PiPlay is telling me that USB and HDMI are connected, still i got no Video Output to the Headset.
The only Way i was ever able to receive a Video Signal was by unplugging my main Monitor and then plug in the Headset in that Port. The Pimax only showed a Blackscreen, but at least it started. Anyway, after replugin my Monitor into another Port the LED of the Pimax went from Blue to Red.

I wonder if the Drivers are corectly installed, i couldent find much Information about installing them manually.
Since the Pimax dosent show up as an Audio Device or Display the Drivers are properly not correctly installed.
The Pimax shows up in the system as “Rift P1”, here is a Picture with additional Information > https://i.imgur.com/jBMeLuy.png

-I tried unplugging the Speakers
-I Unplugged other USB Devices and tried different Ports
-The Pimax was checked before i received it
-I updated the Firmware manually to the latest Version
System: Win10 64, AMD R9 390X, Latest PiPlay Version and GPU Driver

Thanks for any help

@Community


#2

Male sure the pimax is plugged into a native hdmi port & your monitor is plugged into a display port if needed via hdmi2dp adapter.

If we could also have your cpu info. If your motherboard has onboard video be sure to disable in the bios


#3

-Tryed with and without iGPU (CPU Grafics), CPU is a i5-3570k.
-My GPU has only native Ports: 1 HDMI, 2 DL-DVI-D, 1 DP
-It also supports VR-Ready Premium but i have no Idea what is good for
-My monitor only supports HDMI/DVI, i dont have a DP/HDMI Converter, only a DVI/HDMI. Is it necessary to buy one for this Test?


#4

Dvi & hdmi share lanes in the graphics card. Dp is independent. So yes buy an adapter to use with your monitor.

The Igpu needs to be disabled as it interfers with the piplay trying to find the headset. You might also need to disable the igpu in device manager; but just disabling in bios should be fine.


#5

This guide may help


#6

Okay, this is actually getting kinda strange and ime seriously nervous that my Pimax is broken.
I borrowed a DP Monitor from a Friend for the Test, sadly it made no Change, the Headset wasent recognized again.
Just for a test i plugged in my Monitor and the borrowed DP Monitor, sadly my GPU instantly switched into dual Display Mode, this is leaving the open Question why the Pimax dosent do the same? :confused:

Or is your Idea of it that the DP/HDMI Converter gets recognized instead of the Pimax?


#7

The pimax headset unless in Video mode should not show up as a display in your video settings.

I would reccommend uninstalling piplay.

Try reinstalling piplay offline.
I just use windows defender & have no problems. But if your using a different Anti virus it might be causing an issue with installation.

Disconnect from the internet & run the installer as administrator; watch to be sure all programs install.

Launch piplay & connect the headset.

If this doesn’t work post headset led color.

We may need @PM_Sean or @Pimax-Support assistance.


#8

I did everything you posted without success.
Just to be sure i tried an older PiPlay Version (2.0.7.54) and thanks God it finally worked.
Still this Version isent really up-to-date, can you recommend me a stable 3.0 Release?


#9

Okay it seema there still some issues in v3.0.x. I would reccommend sticking with 2.0.7.54 for now until it gets sorted out.

I know @Enopho pretty much always tests new versions & makes recommendations on whether to upgrade or not. His last post reccommended the version that you have installed now due to better performance on his 1080ti setup & ghosting is worst in the 3.0.x so far.


#10

indeed i do… thing is i was testing the latest 3.x version a few weeks ago after someone said the ‘latest’ nvidia drivers helped with the fps drops but i accidentally broke the headset strap clip on the side of my 4k. I informed pimax and they have been kind enough to send me a replacement for free! I know the trafficking info says its in NZ and i am waiting for it to be delivered by a local courier service, so will post if there are issues with latest pimax and nvidia drivers once i’m back up and running.

Thanks

Eno


#11

Thanks for the assistance!

#Closed


#12

Your very welcome. :beers::sunglasses::+1::sparkles: even though you are the one that found the needed fix. :wink:


#13