[SOLVED] Worsening HMD detection issues



Yes. I opened a ticket but wanted to see what other things I can possibly try to fix it.


It’s the 5k plus. I regularly game (non VR) so I usually stay up to date on the latest Nvidia driver for the 2080 Ti. I would try the later PiTool with newer firmware but it seems like it has problems tracking the HMD and I never got it to track. It did recognize the HMD just not track so I went back to 181.


I need check with our engineer, tell me the sup ID, I’ll push internally.


SUPEN-2807 is the ticket.



Also in order to get it to detect the HMD I have to continually unplug and plug in the DP.


With using the old pitool wjth latest Nvidia driver is likely causing the hmd detection issue. @pimaxusa mentioned those wanting to use old pitool versions not to update gpu driver.

So support would need to see why LH tracking is giving you issues.


The LH is tracking but the HMD says it’s not tracking but detected. Once I disable the light house it tracks. However I need room scale tracking for Beat Saber and most games. When the problem happened again today I tried upgrading to the latest Pitool and FW but the HMD never got detected. Overall when it worked I’m quite happy with the unit. When it has these problems it kind of makes me dread turning on VR and kind of makes me want to go back to the Vive or Vive pro even though the specs aren’t as good as the pimax but it is very reliable.


This is why they need to evaluate why your system (& others) with latest drivers is having difficulties while other systems seem to work smoothly.

Something to try if you haven’t is try a clean Nvidia driver install. Some have found that had fixed similar issues.


I tried the clean driver install but no luck. What seemed to help was to completely uninstall Pitool, remove all the related appdata directories and reinstall. That was a few days ago and seemed to bring everything back to life. I also spent literally 2-3 hours trying all sorts of things to fix it. Then today (2 days) later I got the dreaded HMD not bring detected and I can’t imagine having to do a whole uninstall and reinstall. Spending an hour to get it working isn’t ideal. Again, I really love this headset… I just wish it wasn’t so finicky.


Being that I’m on the newer Nvidia drivers I gave it a shot to try to go to the latest Pitool and again everything is ready but my HMD is never tracked.

I even tried routing my USB through the Vive breakout box as well and no luck either.


Once I disable lighthouse the HMD works

But then my controllers and lighthouse is gone

And if I turn back on the lighthouse back to HMD not tracked again.


I have some great news. So I took the recommendation to update to the 111 along with the updated FW and got that issue I described above with the HMD not tracking even though the controllers and LH we’re ready.

I went to the tool and did the log export. I looked through each file and noticed an error writing the config to c:\ProgramData…lighthouse…

I never realized it wrote there since when I uninstalled I deleted c:\Program Files… And all the %AppData%

So… I removed the runtime config, rebooted and whala!! HMD is now detected, the LH and controllers detected too!!

I rebooted the PC and now it detects it right away as well. No more unplugging the DP plug!


you will need to cancel your ticket with support also…

glad you got it working!



Yep. I notified them already. I wanted to report that I turned it on again this morning and everything connected and was detected flawlessly. I find that usually the next day the problems start to creep in but it seems to be working good and as expected now. :slightly_smiling_face:


Congrats; computers can be so finicky. Glad you have it working now. :beers::sunglasses::+1::sparkles:


I agree. I’m in IT and it’s not easy dealing with so many different factors. I have left them some feedback so maybe their software can auto fix itself and save others the trouble or at least when uninstalling cleanly uninstall everything.



@Heliosurge usefull links like this These are common issues I have had (5K+) and ways to fix them should be more visible on this forum . Useful links, FAQs even game setups are not visible for new ppl and that give us a lot of new unnecessary tickets…



Did you add it to Table of conteny wiki?

We have spots for visibility but even pinned doesn’t seem to help with all.

It’s where as a community need to keep guiding folks to things like that. Though perhaps we can look into revamping initial welcome to forum letter.


Not sure where that is. The site is extremely hard to navigate. It looks cool but very confusing compared to other forum software.


indeed change is not easy. I found the same with the old days of DOS with BBS software; some needed a lot of customization.