Steam crashes with P4K and NOLO

issue

#1

Faced some problems.
I’m using p4k with nolo. If I put pitool 1.0.1.132_212 then in steam there is no button to start steamVR.
If I then install Piplay 3.0.0.85 then nolo is not tracked, but a button appears. The nolo firmware has been updated to the latest version and accordingly does not work only with piplay.
The only working option for me: install piplay, then pitool. Then everything works. There is a button, steamVR starts, nolo is tracked. But I have frequent freezes and steam crashes.
Is it possible to somehow activate the stemVR button without installing piplay? Maybe then there will be stability. Or any other working option.


#2

Do you mean only have piplay installed and remove pitool and still launch steamvr?

Well yes you can… If you launch steam. The top right of steam app is a VR button that will launch steamvr without needing to launch it from piplay.

Eno


#3

I am not sure but ut sounds like your having a similar issue to @pimax_fr.


#4

I have to install two programs at the same time.

I’m talking about this button.
P5YLrfM


#5

the Pimax 4k needs to have either Piplay or Pitool installed to work…

I would be looking at what the render slider is set to in Pitool and also what render scale you have is steamvr settings.

I do not know what your PC spec is so i cant tell you what settings to use in either, but if your machine is low end for VR, in Pitool set the resolution to 1920*1080 and slider to 1.0 and in steamvr, check the video option to see what Steamvr thinks your resolution should be set to?
In Steamvr if you are not using the VIDEO render slider, then check what the APPLICATIONS slider is set to for the game you are trying to run?

Eno


#6

Hello Guys,

i got the same issue, need many days to get an stabilisation to play VR with Pimax and NoloVR

What i do i install both Pitool and piplay, and i lunch them in same time.

i started upluoad video of my playing with pimax and nolovr :slightly_smiling_face:

on my youtube Channel : https://www.youtube.com/channel/UCXfuq-tqCApmsx9qEBsvzzg

i play SteamVr
SteamVr environnement : https://www.youtube.com/watch?v=4SB_BotD5HI&t=58s
Portal VR (upluoad in progress)
SteamVR environement in Stargate (My dream com true !) (upluoad in progress)
Little Draw in steamVr (upluoad in progress)

The issue i solved :
- Better tracking stabilization but not 100% OK i would says is 80 % OK
- Missing button home for steamVR i just up the steamVr menu button

The issue i got now :
Is the tracking when i turn to 180°, the signal is lost
The batterie of camera (We can’t charge and plya in the same time :’( )

I think for a bett:er understanding of u configuration u have to give this information :

My configuration :

CPU : Core i5 7300HQ
Memory : 16 go
Graphic cards : MSI GTX 1060 Mobile 3 GB
Headset : Pimax 4K series ?? (i don’t know where found this information)
tracker : NoloVR CV1
OS : Windows 10 Pro
Pitool installed : V1.0.1.132
Piplay installed : v3.0.0.85

if u dont ’ know how found CPU and GPU information in details u can get this free application (look Qwant recherche : CPU-Z & GPU-Z)

Hope u will see u happy here


#7

Got rid of piplay. The algorithm is as follows:

  1. I downloaded nolo home, updated the firmware of the equipment to the latest.
  2. disabled everything except the mouse and keyboard.
  3. Booted from the first restore point of windows. (same as reinstalling windows).
  4. Slowly but surely, I installed the drivers and the necessary programs.
  5. Installed steam and steamVR.
  6. I launched several games, including vr. (to install the necessary libraries, etc.). Pitool do not touch!
  7. Made a recovery point manually (so as not to repeat points 2 to 6, if failed).
  8. Install pitool 1.0.1.132_212. Steam is running.
  9. I connected the helmet to the PC. Miracle! The steamVR button appeared, and everything worked as it should.
  10. I connected nolo, set up the room.

Results: There are accidents, but rare. Nolo positioning at 180 degrees, clear.

P. S. On this weekend I want to try repeating on windows7. I do not like 10. And maybe stability will be added.

P. S. S. Ryzen 1500X, asus pime b350, palit gtx 1660 Ti OC, 8gb ram.