Subnautica release


#1

Hi,

Subnautica 1.0 was finally released last night. I played 37 hours a year ago, then decided to wait for release. I’ve tried it for 10 minutes this morning before going to work. The framerate was so low I almost threw up :). I am trying to figure out what changed, besides the obvious - one year of updates in the game.

I haven’t touched the game settings. I have the PiPlay sampling at x1,0, x1.0 in SteamVR, the “extra sampling” or whatever, the option right below the sampling gauge in SteamVR disabled.

I still have my GTX 970. Granted not the best one nowadays for VR, but I swam for 30 odd hours with it without issues. The Nvidia drivers changed and I moved from the 1.1.92 I had at the time to whatever is the one before latest. I am not sure when the GTX 2xxx will be released, but I wouldn’t like to pay 500€ for a 1080, if a 2xxx will come out within 2-3 months at a similar price.

Anyone noticed an fps reduction after release or it is 100% on my end?


#2

They say that lower the framerate load a game records previous, they say that it is necessary to begin a new game


#3

I am starting a new game. But even before that, just the waves behind the main menu already move at like 3 fps.


#4

I fixed it.

I noticed on my G19’s LCD screen that something was regularly consuming a whole CPU core. Taskmgr told me it was an Oculus service. Apparently the Oculus software was stuck in an update loop, and trying a manual update did not fix that, still looping. Since I didn’t really need the Oculus software, I uninstalled it and boom, good framerates at max in-game settings.

The game is still quite raw though. A hard crash back to desktop after about 5 minutes. Not only did I get the performance from one year ago, but stability as well :).

Interesting thing. Playing with the Image Quality Render in Piplay (2.0.5.46, not upgrading, tired of having to reinstall all my video software and codecs after every run of Pimax’ installer), from x1 to x3 gives no effect in-game. But if I move the SteamVR Supersampling slider from 1.0 to 1.5, my GTX 970 is on its knees :).


#5

I’m glad you solved it


#6

just a note… if you are using 2.x piplay and its render slider, DO NOT use the steamvr supersampling as piplay use their own… no point in changing steams above 1.0 as it will only have negative impact on performance and will have no effect at all on visual quality.

only the 1.x piplay uses steamvr compositor. when pimax moved to 2.x versions they moved away from steamvr compositor and created their own.

hope this helps.

Eno


#7

If I remember correctly what I have tried, I put SteamVR’s slider to 1.0 and UNchecked the “Supersampling” button right below the slider, and played with PiPlay’s slider. I saw no change when restarting the game. I then put PiPlay’s slider to x1.0 and started playing with the one in SteamVR, and that’s when I lost all the fps. Didn’t even notice any graphic improvements.

Maybe I needed to restart PiPlay and/or the headset after each change in Piplay for Subnautica, but I clearly remember not doing that when playing around with Elite Dangerous and seeing a difference on-screen.


#8

you nearly had it…

what GPU do you have can you run high visuals? honestly… dont use steamvr if you have piplay 2.x

try going into ED and then into display quality… set the game visuals to VR Medium as a starting point. … then use the piplay slider… you will see a difference go upto 3.0… if its too demanding, lower to 2.75 and try again.

if you can run ED on vr medium and piplay slider to 3.0 without jitter, change game to vr high and same thing as before.

hope that helps.

Eno