[Temporarily resolved] Can't get Pimax 4K to work with VEGA graphics


Have a similar issue with Vega 56 not working with pimax, it worked fine with my 480.

Can’t get pimax into direct mode, constantly connects in video.

It’s really bloody irritating.


same symptomes here since i bought an VEGA 64, my Pimax 4 k refuses to show any Picture. Glad iam not hthe only one…


@Pimax-Support I have now tried uninstalling the K-lite decoder and after that it was once again possible to complete the PiPlay installation. I then figured out (to my shame) that the GPU driver installer had a built-in uninstaller so I uninstalled the driver and re-installed it (naturally with a reboot after each step). The PiPlay software now recognizes that the P4K is connected by USB but it still considers the HDMI disconnected. I have tried unplugging one of my monitors to make sure there’s no limitation to the number of screens that can be connected but it did not make any difference. I also connected one of the screens through the HDMI port to make sure it works (my screens are normally both connected through DisplayPort) and there is nothing wrong with the HDMI port. The P4K is simply not recognized as connected through the HDMI port at all.

It is really strange because both the USB and the HDMI was recognized as connected when I connected it the first time. I just couldn’t get anything but a blank black screen. Now it’s not even possible to make it recognize that it’s connected.

Since this is a new computer there is always the possibility of starting all over again, to reformat the drives and install Win10 again. I would rather like to avoid that if possible though. It should not be necessary if the hardware and software for the P4K would actually work as it’s supposed to.


@MrOCM @pablosan @domrockt Hi guys, sorry for inconvenience. Last time, we submitted the same issue from VEGA 64 user to AMD side, but still no response yet.

Please go to Help page of Piplay interface to export logs to support@pimaxvr.com, it will be better for our further analysis, thanks.


Hi @MrOCM , can we use Teamviewer together for this issue?


Hi guys, @MrOCM @pablosan @domrockt

Sorry to keep you waiting.

Just now we got a response from AMD side and make a temporary solution as below:

  1. Download the firmware flash tool: [Release]Pimax 4K firmware
  2. Use the above tool to flash the special firmware into the headset, link at: https://mega.nz/#!NUoAFYpQ!L7Cq_hMIo_3IVkxwp_WsCQZZEFxzhb9XvXDCPxrKlXc

Please let me know if it is effective, thanks.

Pimax 4K USB HDMI Connected Red X Settings Device Disconnected
Problemas com Amd xfx 380x por favor ajudem desenvolvedores

Hi guys,

I’ve now got connectivity with both headset and nolo. tracking is working (i used mirror mode in steamvr to check) but pimax screen is just lighting up grey, no pimax logo, no steam vr.

Is it possible the device is stuck in extend mode somehow instead of direct?


What is the colour of the led on the top of the hmd?

Have you tried unplugging USB from HMD and plugging it back in… It fixes lots of those types of connection issues…

Make sure that steamvr and steam is closed then reset USB cable… Then start steam and steamvr again



@Pimax-Support Hi, same problem, upgraded to a Vega 64, LED gets either green or blue, but the screens stay dark(if i put my finger on the sensor, the backlight goes on) while piplay shows usb and hdmi connection, it never gets recogniced(in the device menu in the options). tried several usb-ports, un and reinstalling/plugging everything several times, now after 3 hours i tried the firmware update thing.
took me a while to find out that i had to put the files into the Runtime folder in the pimax folder to get it to start. started the upgrade program, got the hmd into dfu mode, but wether i click on upgrade or return from dfu mode a black window comes up and a error box that the application couldnt start correctly, error (0xc000007b)
i tried admin rights and all the compatibility settings, no luck… im at my witts end, i think i need help…
btw. i cant read the S/N on the headset, its totaly worn away, but the upgrade thing said 100 something, which i found weird, because judgeing by the stickers on the screenshots, i think it should be a 102 hmd?.. anyway can i turn the Pimax off while it is in DFU mode? or will that brick it?


Hi, regarding firmware upgrade, it seemed that your PC lacks DFU driver. Please try this solution as below:

  1. Just quit Piplay (Don’t stop “PiServiceLauncher” Service in Task Manager).
  2. Drag the tool (https://mega.nz/#!wB5GDTTR!NnZn8qZF--kpU3Zz3qQOSGj5348ELg7Jw-diSmZWujw) to Piplay installation (C:\Program Files\Pimax\PiPlay2), and then use it to flash the firmware.
    Firmware downloading: [Release]Pimax 4K firmware

If you unplug the USB cable of the headset when it’s in DFU mode, the LED light may be extinguished (brick). You may press all three buttons on the headset, and then plug the USB cable, release Power button after 8 seconds, meanwhile keep pressing other 2 buttons, release middle button after 8s and keep pressing the last button in 8s, finally you should see the light is flickering, it means the headset enters to DFU (Firmware update) mode. If not, please operate above again. (Video tutorial: https://mega.nz/#!wJ40yRaS!-FF4rigkCTWwH79IXL2lg5lAOcGl0TcrnU0E7C3-32o)

Pimax 4K,missing driver, and not visible in PIplay
Seeing permanent vertical lines on the lenses of my headset

@Pimax-Support Hi, i left the HMD running in DFU mode and the new firmwareflash tool worked fine. i installed the “spezial” firmware for Vega GPU from the post above.
sadly it doesnt seem to have changed anything… just a lot of endless flickering and not getting detected…
same with the firmware 248 and 251 for the S/N 100 series…
for fun i installed firmware for the S/N 102 series and it get detected instantly, backlight turns on without putting my finger on the sensor like it used to. but the screens stay black no matter what i do…
ist there a new “spezial” Vega firmware for the 102 series?
also let me mention that windows seems to allways detect the HMD as a 1280x720 monitor? that doesnt seem right…


Hi, thanks for your feedback. Our testing department is testing this issue in a new Vega card and will update the progress for you guys who met this issue soon.

Edit: The headset you use should be our BE version with 102xxx series number.

Edit 2: Now we get in touch with AMD side who basically locate the issue and we are doing together at present.


@Pimax-Support hope we can get this fixed in a timely manner, im not keen on the idea of going back to my rift until my 8k arrives.
im out of ideas otherwise, so here are some Log Files in case they help:


Hi guys, how is it going?

Recently we made a special firmware for Vega users after discussing with AMD side, downloading link: https://mega.nz/#!cMBzXSJC!m_3HgHjSeYJNDhUg3Qnz5zYVVl57zKhCxU19NIhJO3g

Please be noted that it’s just a temporary firmware and we will release a normal one after discussing with AMD side again soon. Any feedback will be much appreciated.

Pimax 4K USB HDMI Connected Red X Settings Device Disconnected
Pimax 4K USB HDMI Connected Red X Settings Device Disconnected


it works! this new firmware did the trick…kinda. for some reason i have to switch into video mode and back into pimax mode, but it works now! :slight_smile:
fyi: without the mode-switching, it gets detected, but the monitor keeps flickering and the HMD-screens stay blank.

im off catching up on my VR-experiences, do some races in dirt rally, fly a few missions in elite and watch one of my 5 new 3d movies. thnx for the early christmas present! :wink:

ps: ill check back tomorrow if you need any additional info.
edit: after pc reboot, no more modeswitching required, just works.


Thanks very much for your feedback, I will report it to our engineers. Merry Christmas & Happy new year.


firmware worked, thank you.

When will we have NOLO ceiling support in piplay?

  • Paul


@Pimax-Support any good news on permanent and reliable solution for amd Vega 64 users?


Hi @paveu27, please temporarily use the firmware that we provided before. We will let you know once we confirm it with AMD side.


Hey can you post that link in the pinned & closed Piplay release topic? (If you haven’t already)