[Temporarily resolved] Can't get Pimax 4K to work with VEGA graphics


#21

@Pimax-Support

it works! this new firmware did the trick…kinda. for some reason i have to switch into video mode and back into pimax mode, but it works now! :slight_smile:
fyi: without the mode-switching, it gets detected, but the monitor keeps flickering and the HMD-screens stay blank.

im off catching up on my VR-experiences, do some races in dirt rally, fly a few missions in elite and watch one of my 5 new 3d movies. thnx for the early christmas present! :wink:

ps: ill check back tomorrow if you need any additional info.
edit: after pc reboot, no more modeswitching required, just works.


#22

Thanks very much for your feedback, I will report it to our engineers. Merry Christmas & Happy new year.


#23

firmware worked, thank you.

When will we have NOLO ceiling support in piplay?

  • Paul

#24

@Pimax-Support any good news on permanent and reliable solution for amd Vega 64 users?


#25

Hi @paveu27, please temporarily use the firmware that we provided before. We will let you know once we confirm it with AMD side.


#26

Hey can you post that link in the pinned & closed Piplay release topic? (If you haven’t already)


#27

Hi @Heliosurge, do you mean to post the link that Vega 64 users may try the temporary firmware?


#28

@Pimax-Support is there any step-by-step instruction on how to update pimax 4K firmware ?


#29

@Pimax-Support

this is the error I get after stopping all pimax services and trying to launch the upgrade tool


#30

#31

Hi @paveu27, please update the firmware according to the process.Thank you.


#32

Finally, after many weeks of being busy with other things, I have now had some time to look into this. I did encounter the same problem with the hidapi.dll mentioned when using the firmware update tool first recommended. When trying the last link and last firmware I did get it to work after a while (I had to unplug and plug in the headset and restart the computer a couple of times before everything worked out). Now the headset is finally alive. However, it is completely unusable…

  1. For 2D/3D video I get a crash message saying Kodi couldn’t run.
  2. For 360 video I get an unsynchronized fisheye view with horribly low resolution. What I mean by unsynchronized is that the left and right eye images do not merge into a consistent 3D view.
  3. For games I get a crash saying X3DAudio1_7.dll is missing.

I did go through the IPD Adjustment process, though I found it very difficult to see any significant difference when changing the lens spacing. When starting SteamVR Home I do get a reasonably good view of the house in 360 though of course I can’t do anything since I don’t have any controllers.

So far I have only tried downloaded demo content. I don’t want to pay for any content until I have verified that it all works properly.


#33

X3d i think might have to do with directx. Try installing dx again.

For controller you csn use an Game controller like xbox, logitech. Just be sure to check programs for gamepad support.

With 360 video results will vary due to quality of recorded video (res & quality of 360 cam)

@Pimax-Support


#34

Well, I would expect that the demo content you offer through the PiPlay Software would have decent enought quality to at least be able to see it as video. If not, I think you are making a serious mistake. This is the first content any consumer will download and/or play to get a first impression of the product an my impression so far is that the product is completely useless. If you can’t provide video files that can play properly it can’t be used for video. If you can’t pr

I have not done an explicit installation of directx. I have a fully updated installation of Win10 (installed from scratch) and you installation software seems to install directx during installation of PiPlay. At least it says so during the installation. I have uninstalled your software and then re-installed it. It does say it is installing directx during installation of PiPlay. I still get the X3DAudio1_7.dll error.

Also…
I checked the Windows support and NO installation of directX should be necessary for Win10. It is supposed to be included in Windows and any updates to directx should come through windows update. Since my windows installation is fully updated I should already have the necessary stuff in place (unless your installation software has somehow crashed the directx installation by making its own installation). I don’t know enough about how these different software interacts with eachother. I’m just really disappointed that I can’t get this to work.

You do not mention anything about the problem to play 3D/2D content (which is also available in PiPlay). I do not have Kodi installed so it must be your software that is trying to use it and if so I would expect you to make sure it works.

So far my Pimax experience can more or less be summed up by saying “really expensive crap”. Currently, I can’t use it for ANY of the content available through PiPlay, either due to crappy content or due to crappy software. The hardware seems to work now (as far as I can tell without being able to see any VR/3D/3D content). I really hope you can help me get it to work properly because I do WANT to be happy with my Pimax purchase.


#35

One i am a volunteer who is at work.

  1. 360 videos will be at the quality the provider made them at.

  2. If you want. To see quality then download Unity Chan Demo. It looks more like a 360 manga video.

  3. If you have run Windows it is always a good idea to run the directx installer that comes with any program. So if your unwilling to try what is reccommended there is little anyone can do for you.
    Running a directx installer ensures that all the componets are there & configured properly & will not hurt your windows install.

I poked support who would able to assist you. However Support is likely to be awayy til sunday night or monday.

Your kodi may havr issues if klite wasn’t installed.

When i have more free time i will try & help you.

Also please post your system specs

Cpu/ram
Gpu/driver version.


#36

I did actually find some VR content to download but I had to run it through the SteamVR player. That means I have been able to verify that the hardware does indeed work and the quality of the source material is indeed a factor. I have still not been able to run any content in PiPlay which I think is embarrassing for Pimax - It’s own software does not allow me to use their product but I can download content from other sources and use other software to play it. I still have not been able to run any games.

The PiPlay installer itself seems to install directX but it does it during its own installation process so I can’t run the directx installation separately. I have run the PiPlay installation several times but no change. I don’t think I have any software that allows me to run a separate directx installation. Microsoft does not provide a directx installer for win10 because it is already included.

I will try the Unity Chan Demo you mention tomorrow. I will also check klite. I’m sure it was installed the last time I was trying to get this fixed (before there was a working firmware available) but perhaps it needs to be updated.

I will add info about my system tomorrow. I’m shut down for the night now.


#37

Cool. Directx will usually come with programs (typically games) & install.

Something to verify as well is your gpu driver. It is possible the gpu didn’t install all componets. Especially if windows installed its own.

I will do a search on the missing dll & see if i can find out what should have installed the missing componet.

Myself I haven’t run into too many issues with the install process. Though recently Amd driver did break Piplay & had to roll back driver. Though newest amd driver seems to be good. The issue it had caused myself & others was blank screen with audio in headset.


#38

https://answers.microsoft.com/en-us/windows/forum/windows_8-update/how-to-fix-a-x3daudio17dll-is-missing-error-for/36c43168-f557-4f02-a0ff-2dcce7de9fe3?auth=1

It looks like it is a directx issue. The above link from microsoft looks like it should fix the issue. Try that & retry piplay content & kodi.


#39

Hi… If you own Vega and Pimax 4k…DO NOT bother with windows 10. I have wasted HOURS for zero result. Install windows 7, a pain if you also have ryzen but doable…simple undocumented trick to that, make sure you have your raid drivers available or you will ghet no where when it asks for the device drivers, make sure you install from a usb stick and have your motherboard installation disk in your cd rom drive. Install normally.

If you need to upgrade your firmware, once again do it on a windows 7 computer, windows 10 will not work. Use Dfu drag to piplay installation.exe , found above. Piplay will need to be installed beforehand for this program to work as it needs the service started, Firmware working to begin, use 102xxx_1.0.0.248.dfu( I have the 102 prefix…no idea if the same method ( and appropriate firmware) works for the 100 prefix. Start piplay v 2.0.7.54 and use it do upgrade your hmd firmware to latest version. Enjoy using your Pimax once again…DO NOT TRY WITH WINDOWS 10 Simples


#40

By the way…This forum is amazingly difficult to find out any useful information in one place. I have also wasted countless hours reading forum entries to find out how to do anything with my pimax and stuff me, most go to we will contact you via skype, email, teamspeak …and then NOTHING further on how the issue was resolved…SERIOUSLY people…lift your game support lot and when you resolve a problem, document it properly so people can follow the dots…

I will be Horribly disappointed if the same DISMAL effort is put into the support for the 8k version which I assume will turn up eventually on my doorstep… :slight_smile: I am looking forward to it…