[Temporarily resolved] Can't get Pimax 4K to work with VEGA graphics


#41

I hear you there. The Amd Vega issue is appalling. Amd should have fixed their broken driver by now. There is a special firmware to work around tge vega issue but you still can’t as far as I know use Amd’s latest driver.

@Pimax-Support can you repost firmware fix.


#42

This link has the more up to date flashing tool


#43

I’m using 18.3.1, only because I had pimax working on another windows 7 computer using that driver, so not that old anyhow…but vega and pimax will not work at all with windows 10… I wouldn’t wholly blame AMD either, none of the firmware upgrade tools from pimax work with win 10 either…I Strongly suspect that is a major reason for so many problems…no-one before me worked this out?. I’ve had the pimax for nearly 12 months and barely used it…I will now for sure…now that I am now able to run windows 7 with my ryzen cpu based computer.

After hours of trying different firmware via windows 10 and finding missing dll files and generally mucking around it would have been nice for someone to come up with what I did…PIMAX support??? instead of wasting heaps of everyones time. Anyone wanting to use Pimax 4k…PLEASE do yourself a favour and use windows 7… you don’t need the headaches… :slight_smile:

I am using the 1.0.0.265 firmware with a ryzen based windows 7 computer with a vega64 graphics card, amd driver version is 18.3.1 This did NOT work on the same computer with windows 10. One may assume from this that the pimax firmware may not be compatable with windows 10, OR vice versa and its not the amd driver that is the real/sole or whole issue that needs to be addressed?..


#44

You don’t need to on windows 7…the later piplay v 2.0.7.54 was on my other computer, the firmware upgrade tool, the one that needs the service running, worked immediately and without any issue whatsoever, hmd stuck in dfu mode at the time, whereas it always crashed on windows 10. The other one that needed the service turned off, was also useless if the hmd had gone into dfu mode…

Like I said before…find a windows 7 computer to do any patching work for your hmd and then forget about using windows 10 unless you just want headaches, install windows 7 and don’t hang everything on AMD…its a cobination of windows 10 and poor product updates and information from pimax…

If it was just an AMD driver driver issue, why the hell does it work on a windows 7 vega system with nothing else changed except the operating system??? its still the adrenaline driver


#45

The link I posted has the upgraded firmware tool that works. There are several users on vega using the modified firmware.

So the firmware you need is a special firmware & yes it is on Amd. Mt old setup had an issue of blank screen due to Amd driver.


#46

I tried them all and none worked…including the one above…MANY times , many reboots, many driver changes, much much cursing. If other failed like I was and given up crowd will have a chance now…don’t ignore that a different method to your works and is instant and as it should be…just on an earlier and if I might add…far superior operating system that doesn’t try to be a phone app


#47

Then win10 has recently broken latest firmware tool

@Pimax-Support


#48

I did 2 things…number one I managed to get windows 7 working on my computer even though its not supported by microsoft and they make it hard. so fresh install there…next I did a fresh install of Windows 10 and completely updated it. My original windows 10 install didn’t work with pimax either and it was an older version with no updates. I had also had no success with everything I tried below.

So I spent 4 days trying all of your product and firmware to get my investment to work with windows 10 and Vega. That everything I tried failed in every combination and suggestion was rather frustrating. To then toddle off to my old windows 7 computer that shouldn’t run VR, EVERYTHING I TRIED worked immediately, and quickly and within 15 minutes I was having a very slow :slight_smile: look around google earth… Windows 10 may be broken, AMD drivers may be broken, SUPPORT is definitely broken and I hope it improves with the 8K


#49

Happy with that success I then moved back to my now windows 7 vega computer and whacco… it worked without any issues…perfect straight up. My point is, that’s how it should be…why it isn’t with win 10…who cares, I never wanted to use windows 10 in the first place…

Before you waste time you will never get back…try it with a win 7 computer is all I’m saying…


#50

The funny thing a few months ago someone couldn’t get piplay to work on win7. Lol


#51

With the severe lack of computer literacy about and even less than helpful documentation available…i am not really surprised about that…you were ahead of the game if you spoke or read chinese or knew someone who could…


#52

I have read also alot of tripe over time about how poor the pimax 4k is…gotta love the fanboys of the triple the price VR sets at the time… very disnmissive …I use rFactor2, a very graphics intensive car racing simulation…It is absolutely perfect for it. Well above 60 fps, not measured but smooth as silk, no ghosting, no stuttering, no lag…no screen door… You make a good product people of Pimax…The backup is what needs work :slight_smile:


#53

Well I have a long history with computers. But Don’t read or speak Chinese. Myself I am a community moderator that helps pimax team where I can.

The 4k is restricted to 60fps (60hz refresh). While Ghosting is pretty bad on it. For Sim games like Rfactor & the likeis definitely quite reasonable & like you said the price was decent.

Ethan Carter with the vr dlc is amazing looking. I have downloaded Hellblade & will hopefully get sometime this weekend to check it out.

Hopefully in coming months we can get the forum setup better.