The GPU utilization boost is not only working with DCS World, it works in SteamVR games too!

pimax-8k

#21

Another example. The Forest VR with SteamVR.

Note that I had to click Default 4 times before it kicked in.
Around 15-18fps boost. Almost 20fps boost when overclocking after Default was pressed.

GPU utilization went from 80% to 97%


#22

And then (I think) start the game, switch back to the desktop, and use a GPU settings app to switch from overclocked to default and back to overclocked.

To me, this sounds like a bug somewhere, but it’s not clear where.


#23

Could you try this trick with a common Vive or other headset and see if that makes a difference?
Otherwise this is a PiTool thing


#24

I have got reports from Oculus users having the same result. I may try it as well


#25

I have just installed both Hellblade VR and DCS World, and of course would like extra performance in Elite, so this is a very timely topic for me, thanks :wink:


#26

So it only works for cards that are being/able to be overclocked?


#27

When saying “turning vsync off in the Nvidia panel” you mean turning it off globally or in the individual Nvidia game settings ? (I usually add highest performance to games that need more fps and tinker with the pre-rendered frames)


#28

You can just set it in game specific options.

Also no this does not need a GPU that can overclock, as we are actually not overclocking anything here. Just putting it to defaul values…
You COULD overclock above this but its not necessary.

Also some games may flicker with this done unless u reach a full framerate of 80/90fps. In that case its better to apply motion smoothing after doing this tweak.


#29

Anyone tried this with AC, rF2, Raceroom, etc? I tried this trick last night but found that already the GPU was fairly saturated with high SS settings. Somewhere between 85 - 90 %. Still sounds like as long as you’re not hitting 90hz (for 5K+) your GPU usage should be 99%, in a perfect world of course.


#30

Is having Parallel Projections off a requirement?


#31

@SweViver - Sorry for asking before - seems my Video Playback is buggy (strange effects - YouTube videos - stutter after the pc went to sleep)
I was before not able to get a clear reading on the text - just noticed that I need to force the video to full resolution now, for what ever reason. I got the screenshot of that, so thanks again!
Hope its ok, i will post it here, if not let me know and I will delete it instantly:
Source and courtesy of @SweViver:
https://youtu.be/rSCCS7i-Ic4
DCS Settings

Edit:
I just tryed - but today I am getting really strange behaviour - I start DCS and get 15 FPS - I move the headset and it jumps to 90 in the menu. I then go to play and only get about 50 FPS and 70% GPU and 12% CPU usage…


damn…


#32

That’s not clear. I haven’t yet tried this, so I’m not entirely sure what conditions are required to see the effect.

That’s also not clear.


#33

I tried this with rF2 tonight. I got the boost in GPU usage but also a very strange bug that makes the screen ghost and stutter everywhere. Looks like PP might be causing issues. Going back to menu resets the image proper but also gives me that 80% usage again.

I need those frames in VR! Whoever is responsible for this. I can see the GPU wanting to give me more, as even when I keep turning down the SS, I get dropped frames with 45hz smoothing. It’s stupid.


#34

@SweViver can you just list in point form the steps you took? I find your video too long to watch through to find out exactly what needs to be done in order to get this boost.

Thanks!


#35

If i got it right:
a) PITool

HMD

  • Hidden Area Mask ON
  • Render Quality 1
  • the rest set to your preferences

Brainwarp

  • Import Game from Steam Lib (might be obsolete - is optional should work via Steam as well as Starting straight from the .EXE File)
  • Settings: Smart Smooth OFF; FFR OFF, Compatible with Parallel Projections OFF; FOV Normal; refresh target as possible with your hardware 72, 80 ,…

b) The Rest

  • Start MSI or Precision GPU Tools (or other)
  • Start Game in PiTool

In Game

  • Watch FPS
  • Switch Fokus to your GPU Tool Software - alter the Clock settings (Default or Load Profile - might be needed more then once)
  • On each switch check framerate in game

Result: GPU Usage goes up and also the FPS.


#36

I’ll try it with Elite tonight and see if it works. Luckily I am in a space station which will allow for the best testing


#37

Can CONFIRM that this works in rFactor 2 regardless of Parallel Projections enabled. I am not sure if this works WITH smoothing or not, but it definitely works WITHOUT smoothing. I cannot believe I am losing litereally HALF my performance when you consider PP already eats 30% and now we find out our GPU’s are running at 20% below full tilt most of the time, even when they can certainly render more frames. I was sitting at 55fps in the pits with 75-80% GPU usage, did the trick a few times, messed about trying to get it to work, and then all of a sudden, BAM, 64hz in exactly the same spot and 90+ GPU usage.

SOMEONE FIX THIS! Going to menu negates the effect. So basically when I am on the grid coming from the menu, I have 15 seconds to get my GPU to actually WORK before the lights go out.

Nice. :rofl:


#38

I bet it is some kind of “power consumption limitation” built in Windows 10.

I BET IT IS.


#39

Hmm in the driver i put it on Performance - the default is different (NVIDIA control ) but non Idea what it does. Unluckily I did not manage to get the boost for mine it sticks at 72 - 75% GPU. :frowning:


#40

Or maybe its something related to clock throttle of Nvidia cards.