The GPU utilization boost is not only working with DCS World, it works in SteamVR games too!

pimax-8k

#41

Mine @ least from what it shows on the Hardware Monitor stays on the clocks ( in X1 Precision, EVGA 2080TI FTW) but I have no idea if i actually get to see everything.
None the less it is damn strange and a damn good finding- should be forwarded to NVIDIA- with some luck it will be addressed.


#42

Was not able to reproduce this with rF2 and Afterburner :frowning: no difference in Utilization.


#43

No difference here with Pcars 2 (many settings tried) :confused:


#44

you should easily be able to tell if this is pimax software bug or nvidia/steamVR bug by plugging your HTC VIVE and try the same reset, if you get increased FPS, it is steamVR/nvidia’s bug, if you don’t get increase FPS and GPU is already running at 90%+, than it is pimax or pitool problem


#45

Nope it works with PP as well but u get better performance without of course, where its possible.

No problem mate :slight_smile:
If u get 15fps then your Pimax is not active and goes in some kind of standby mode. Just move it and framerate should be good. But then after that Im sure u need to press that Default button again…

Yes this seems to be a problem in some games as long as the framerate is not maxed. When maxed the flicker is gone. But its not happening always. Just sometimes. Very strange.

In case u mean DCS World with PiTool I guess @MReis already answered your question (thanks a lot).
If u just want to try it in a SteamVR game, just install Afterburner and press the Restore to Default icon while being in game.

I just posted a new video trying some games in SteamVR btw…

Thanks man, the sum up is much appreciated! :slight_smile:


#46

Haha thats sounds stressful lol. Yeah the biggest problem now is that its restoring in most cases as soon as u enter menus, change level in a game, change track etc… its frustrating but at least a beginning. Hopefully Nvidia will look into this!

I got around 10 more frames in PC2 (check my new video) but got lots of flicker unless i looked down and the framerate was up in 90fps. So its not really working in all cases… at least it improves Smart Smoothing as framerate is higher. When SS is on and active in 45fps the flicker is gone.


#47

I could not see any fps increase when I tried Odyssey in Hellblade VR as the CPU was already at 93%-95%. Haven’t tried anything else on Odyssey yet but Ive seen many users confirming it DOES work with Oculus Rift.


#48

Here’s the new video btw with some SteamVR games:


#49

If rift users are having the same thing then it’s gotta be nvidia with the issue.


#50

That seems likely, but it’s also possible that it is some sort of Windows issue, say based on thread priority (or something like that).


#51

I wonder why it kicks in in some cases and not for others - I cant get it to go up with GPU usage in my case - spes almost the same as @SweViver’s

Some other config playing a role? I’ll post my Nvidia Settings - maybe there is a hint in them (sorry they are in German but should be comparable :

Edit: Drivers Nvidia 430.64 and EVGA Precision 3.17.0 as Pitool in Beta 1.01.121 and the HMD 5k+ Firmware 2.1.255.211 are up to date, if i am not mistaken.


#52

In either case then nvidia should be able to work around it in their driver? I would say if AMD has similar issue then we know it’s windows.


#53

Is this an RTX trick only? I can’t get DCS to launch from Pitool on my 1080ti. Tried many times. kept getting 2 errors. Even after I stopped clicking start DCS kept trying and producing the same error screens over and over (and failing). I had to reboot to stop it from trying.


#54

You can start it simply by launching DCS.EXE, no need to go through Pitools. I have the standalone install of DCS, simply launching outside of Pitools still makes this hack working.

It only works when you’re GPU bottlenecked though.


#55

Sometimes you need to click 5, 6, even more times to get it to tick over. If you’re already at 95%+ usage obviously this will do nothing for you as everything is already being utilised properly. But anything under that and not hitting your target frame rate means something is holding it back. I know it works on 10 series cards (1080Ti) and I know it still works with Parallel Projections enabled, too. I’ve tried it with Smart Smoothing but got the flicker (see below) so I turned it off and tried without it.

Also, I think I realised what the flicker is. It seems when the GPU pings hard against the limit (98-99% usage) you get it. So key here is to make sure you’re getting all your GPU feeding the Pimax, but also not so much that it randomly is allowed to jump up to super high usage, almost like banging against the rev limiter (sorry, sim racer here :slight_smile: )


#56

Yeah, happens to me too, and the silly thing is, I don’t have a G-Sync compatible monitor at all…something is just not right with Nvidia drivers, probably.


#57

Ok it works ! I got the same observations : frame rate increase but stuttering…
But it means that performance can be really improved


#58

Great! How do you find it?


#59

Good find there, sounds like a driver bug in the GPU drivers.

Will try it on my fav Il2 - every frame counts with good image quality of course.:+1:


#60

This is what I was looking for, thanks. My issues is not all the other stuff (yet). It is getting DCS (standalone) to launch from Pitool on my 1080ti despite trying at least 30 times. I’ll perhaps try again later.
I have no issue running DCS from the launcher on my Pimax.