The GPU utilization boost is not only working with DCS World, it works in SteamVR games too!

pimax-8k

#61

I’m a bit confused by your statement but never mind. I don’t think you need to worry about running it through PiTool or standalone. I have been using SteamVR like always and the trick is working for me as shown by Sweviver. If there are performance improvements to be had by running DCS standalone, I’m not sure as I don’t play it. But my point is, for this to work I am pretty sure it’s not needed. Just run it normally with SteamVR. That’s how rFactor 2 was working for me anyway.


#62

Ya I can see why. I started trying this boost based on Sweviver’s first video and I see now that it should work without needing to import into Pitool. Didn’t catch that new info until now. :blush:


#63

I’m starting to wonder if this is mainly a VR thing or if this could also boost power when playing on a 2D screen


#64

Hello,
I reproduce the fps boost in DCS with nvidia inspector , it has also a “default” button. But after that, you’ll have to play with Smart Smoothing frequency and your settings to be at ~90% of use, if you go higher you will have doubled images.
No luck with IL2BoS, my GPU usage stays at 60-70% even if I’m not at 90 fps and not 100% CPU on one core.
I have a 1080Ti and last nvidia drivers.


#65

Il2 no joy for me either but then I was seeing low 80’s % GPU usage anyway and I know that my RTX 2080 is not the issue with frame rates, my system is.

Even though you will not see 100% on CPU utilisation, Il2 is single threaded so it will be crapping out a single thread whilst the others sit around twiddling their thumbs. Hopefully this will be changed down the track with different elements getting separate threads and CPU Core count scaling taken into account.


#66

Just tried this out with a GTX1070, here’s what I had to do to get the boost:
Render Quality in PiTool has to be low, application resolution in Steam VR has to be high.
For example, if PiTool Render quality is 1.5 and Steam VR resolution is 50%, I get perhaps 60% GPU utilization, and clicking the Reset button in Afterburner will not give me any increase in GPU utilization.
On the other hand, if PiTool Render quality is 0.75 and Steam VR resolution is 400%, I get around 80% GPU utilization, and clicking the Reset button in Afterburner will increase it to around 99%.
But the image in the headset starts flickering, perhaps I just have to find the right setting and lower the Steam VR resolution, but I haven’t had time to fine tune it yet.

I haven’t been able to make the ‘reset button boost’ work with Smart Smooting on either.


#67

It’s so frustrating that people still don’t understand how scaling works.

Pitool 1.5 x SteamVR 50% = 1.5 * 1.5 * 0.5 = 112.5%
Pitool 0.75 x SteamVR 400% = 0.75 * 0.75 * 4 = 225%

Of course your GPU will have to work harder to move twice as many pixels.


#68

probably its a Nvidia RTX feature-bug, to throttle the card. Otherwise people won’t buy the bulk of 10 series chips that are still lying around from crypto age.
And thats what Nvidia wanted with high prices and not so high performance, wasnt it? … just speculating


#69

Yes of course, but for some reason GPU utilization goes down when I increase the Render Quality in PiTool. I don’t know much about how this all works, it just seems strange to me that I get really low frame rates and only 60% GPU utilization when Render Quality in PiTool is high. Why doesn’t the software just increase the framerates and the GPU utilization?


#70

I have done the trick using msi afterburner and i confirm that gpu use rise to 9X% but it is useless because it appears a lot of stututering and double image.

You can see in fpsvr how the framerate goes up but whit those problems, there isn’t improve

I have a 2080ti, vsync of in control panel.

Test with 2 games_

-Project cars launched diretcly from pitool, PP off, normal, 90hz, 1.25, and without steamvr

-Fallout 4 launched from steamvr, PP on, normal, 90hz, 1.25


#71

Again, the double imaging and stutter / flicker seems to be caused by the GPU hitting maximum load. The key here is to get it to use ALMOST all of it while not pinging against 100% load.


#72

I will try another test with less supersampling


#73

Because there’s some other bottleneck, probably memory bandwidth, due to the increased resolution. (Your memory subsystem can’t keep up, so the GPU sits idle at times.)


#74

Question - are you actually experiencing the performance increase? I mean, could it be that pressing that button forces a refresh on the app that’s checking the framerate, without affecting the real framerate?


#75

I have not. I’ve seen some strange framerate fluctuations, but mostly I’m seeing somewhat reduced framerates that vary over time (and do on occasion improve again). I’m speaking of the “real” framerate reported by fpsVR, not the smoothed synthesized frames. When the framerate drops too low (below 40 FPS), I start seeing flashing double images, as others have mentioned.

I never noticed this before I started using Smart Smoothing. This is in Elite Dangerous. I’m out in unexplored space, so this isn’t the normal slowdown you see at stations or on a planetary surface.


#76

Yes the more I try this, the more I realize it seems like this “trick” more or less requires the framerate to hit maximum to be fully flicker free. In case the framerate goes below 80/8K or 90/5K+ the flicker occurs. In some games it does more apparent such as Project Cars 2, but in games like Hellblade 2 I dont get this flicker even when I have 5-10 frame rate loss.

One of my friends said there could be a reeason why the GPU utilizartion many times doesnt go to max. It may be that it needs some overhead for the frame sync, in the rendering pipeline, and once we go max the headroom is gone and flicker could occur as the frame sync cant keep up.


#77

I wonder with higher PiTool Render settings if the RTX refresh coming out soon with faster memory will handle it better…

For me to move beyond my 2080 - I will wait for substantial performance increase from any future GPU to make it worth while. Paying near 1K for a GPU is 1. madness and 2. keeps me from wanting to throw more money into computing in the short term.

I will try selling it off when I do update though.


#78

People have reported it to work with 10 series cards, too.


#79

Found just by playing with PiTool whilst in a VR app, my GPU boosts for a short while too. From 80% uitilisation 3D to 98 or so% but I get flickering in my Right Panel so not much fun to view.


#80

Here’s what I wrote in the video comments:
I tested the tweak with Rfactor 2 and it works but only temporarily. The GPU utilization drops back after a couple laps. :frowning:
Clicking the default button again restores the boost for a little while but this is not practical while racing.
It’s disappointing because this is a game changer for rFactor 2 (90fps instead of 65 with SS at 70%).
Also, note that it doesn’t work for me if my car is not moving. I have to be driving as I click the default button otherwise nothing happens to the fps.

Please let me know if you find a way to make the tweak stick for an entire race.