The GPU utilization boost is not only working with DCS World, it works in SteamVR games too!

pimax-8k

#81

Those are some fairly odd restrictions. I’m wondering if this might have something to do with Window’s task prioritization.


#82

You’re spot on their mate. I discovered this last night when I was practicing for the nights race. I tried it again later on, offline, and it actually stuck for a little longer than a couple of laps but eventually it did go back. During practice it just changed by itself, no going back to menu, although I wonder if the messages from the server in the message box had something to do in triggering it.

Either way, it is a massive game changer. I can run 140% SS @ 64hz as my maximum SS level and man the game looks SO different to even running at 100. I can get smart smoothing to work quite well in rF2 but the frame rate is not locked unless I use a pretty low SS value for the 45hz. Probably the same as the 64hz mode with the GPU trick enabled.

We need at least one of two things for rF2 to become much more attractive to use: Either remove the need for parallel projections, or give us back the entire GPU usage as it should have been from the start. I can boot up Assetto Corsa and immediately hit 95% with a very high SS value with no tricks at all. It still uses SteamVR so I wonder what the issue is.

Tonight I will be having a look at iRacing and Raceroom to see how they fare.


#83

Unfortunately this doesn’t work for me, I did get a temporary boost when ‘underclocking’ my card, but the majority of the time I get about 80% utilization and it seems like I’m more restricted by gpu temps as I max out at @60C. This is using a 1080 Hybrid/watercooled card, and I’ve tried setting the OC priority to the temperature limit(80C), and uninstalling/reinstalling.

@SweViver, any update on part 2 for this, I’m curious if that will help.


#84

I have a ticket open with Nvidia that is now being escalated to level 2. I had to send them msinfo and GPU-Z log files after 1 hour of gaming.

In my correspondence with them, I provided a link to SweViver’s video and asked them to have a look. Initially they were saying that it was due to overclocking but I reinforced that there is no custom overclocking necessary to get these results.

I would recommend that as many people as possible open tickets with them.


#85

Its strange that the temperature is affecting your performance, as my RTX 2080Ti can run at up to 97% utilization for (as it seems) unlimited time in 72-73 degrees C. The only thing that drops is the boost clock from lets say 2100Mhz to 2050 or so, which is probably temperature controlled.

Maybe you have some temp/fan profile active?


#86

I tried to find a way to apply the gpu OC trick without the need to alt-tab from the game and clicking in the OC tool window. Finally I’ve found an open source command line tool that can modify the gpu and memory clock through NVidia-s nvapi calls. Then I created a little AutoHotkey script that calls that program to reapply the overclock when I press a button.

https://1drv.ms/f/s!AuTI0c5L_7Kris1Hzkx2QABkxWy9NQ

Just download the files to a directory, install Autohotkey, edit the second line in the overclock.ahk script to your overclock values, the first number is the gpu clock overclock, the second the memory. If you don’t want to overclock, just use 0 0.

The program does not modify any other settings, like power limit, so I kept the factory overclock tool to apply these and use the same gpu and memory clock in the script to apply the gpu trick.

You can also modify the hotkey in the first line, mine is Win+z, that works for me in DCS.

Then doubleclick the overclock.ahk to run it with Autohotkey.

Whenever you want to reapply the overclock just press the hotkey from within the game.


#87

Woah thats freaking awesome! Thanks man, will try it later!!! :slight_smile:


#88

I guess you could also schedule a job for this to execute the command say, every 3 minutes? Not sure how fast the effect deteriorates.


#89

Flying 1+ hour missions in DCS the effect lasts a long time. Usually until there’s big spike in cpu usage, maybe from some background task or just DCS. My guess that by applying the overclock something syncs up in the rendering pipeline and then it falls out of sync because of the spike.

Unfortunately applying the fix not always take effect for the first try. And as I remember an unsuccessful application removes the effect even if it was on. If we could test somehow for the state of the effect then we could schedule it, but for now manual way is better I think.


#90

Thats a good idea, in case the tweak resets (as some of you have noticed). I havent done longer sessions than maybe 20-25 minutes but I havent really seen it go back to low GPU usage yet, not as long as Im on the same level/track.

Very interesting, thanks! I must test more :slight_smile:


#91

I can confirm same behavior on Fallout 4 VR. I had PiTool at 1.0 though. The usage eventually falls back to 80%. 2080Ti as well. It looked like the clock speed wasn’t any different between 80% and 97% usage though.


#92

why do you even have a monitor? lol


#93

I’ve tried adjusting the fan curve, and setting the priority to temp and power limit, but always top out at 60-62 with or without overclocking.


#94

@karajzk: May I give you a big virtual hug?

I installed your utility and Autohotkey without much hope but I wanted to try it.

I started a Rfactor 2 GT3 race at Watkins Glen (12 AI, SS 70%). During the first quarter of the formation lap, everything was normal; 68-72 fps ~50% GPU utilization. I then pressed Win+Z and BOOM; 90fps ~75% GPU. I was expecting to have to press it again… Nope, it lasted the entire 20 minute race!! The fps stayed between 86 and 90fps the entire race (GPU between 72% and 85%, Temp 63). These little fps drops created a few stutters each lap unfortunately. My plan was to later try 72Hz to avoid stutters…

After the race, I went back to Monitor (Pits) and restarted the race to see if it would work again. Pressed Win+Z at the beginning of formation lap but it didn’t work. I decided to give it a chance and continue pressing through the entire lap. It finally worked after maybe the 15th press. Green flag and it continued to work until I stopped the race to try my 72Hz plan.

To get rid of the stutters, I decided to try at 72Hz. Unfortunately, I was not able to make it work. I think the fps is already too close to 72fps without the tweak. Tomorrow I’ll try 72Hz with more SS to increase the load on the GPU to see if I can enable the tweak and get a steady 72fps.

Note that if you press several times, the game will eventually drop to about 10fps and you may even lockup the computer completely. Ask me how I know… :smile:

Again, many thanks to @SweViver and @karajzk for all your work!!


#95

This should definitely work with 72Hz as I tried it in a few titles such as PC2 and DCS World with a much more stable max framerate. Just give it a few more tries :slight_smile:

Thanks for the report by the way, much appreciated!


#96

For applying overclock hacks, obviously! :stuck_out_tongue:


#97

It works at 72Hz!!

I increased SuperSampling to 100% (PiTool at 1.0) to put more load on the GPU and now it works.

I can’t believe it! I ran a complete 20 minute race at Pitool 1.0, SS 100% and the fps stayed locked at 72fps and there wasn’t a single stutter. Not even a small one. This was my best rFactor 2 VR experience ever. Even with the Rift I was always getting a stutter here and there. I never thought it would ever be possible to get this performance with rFactor 2. Three weeks ago I was ready to sell the Pimax because I was discouraged by the rF2 low performance.

Does it show that I’m excited?
Thanks again for this discovery and utility app!

Note: I tried 3 races tonight. For the first one, I had to press Win+Z 8 times. The second race; 7. The third one took the entire formation lap and at least 20 presses. The message is to be patient…


#98

Hehe yep, quite incredible, isnt it?

Im getting the feeling there is some overhead left for the GPU in VR to manage the framesync, and by doing this tweak we simply remove the overhead. It has to be an Nvidia problem/cause in one way or another.


#99

If that’s the case it would be nice if they made it an option in Nvidia Control Panel.

That way You could control how “aggressive” the timing should be.


#100

did someone reported this to Nvidia?