The GPU utilization boost is not only working with DCS World, it works in SteamVR games too!

pimax-8k

#101

I hope :slight_smile: To be honest I have not reached out to Nvidia as Im not sure they really care about what Im saying lol


#102

Maybe as an employee of a hardware company which has nVidia’s endorsement, you could get an official reply. That would at least alert them to a potential issue, which might affect many situations besides VR on a Pimax.


#103

20-30% of my 1080Ti going into overhead for select games? Especially the ones that need it the most (rFactor 2, PCars 2) is completely unacceptable if the same thing doesn’t happen with AC and Raceroom. We already get gutted performance with the required PP on. rF2 runs flawlessly with the GPU trick enabled. How much overhead does it need!?


#104

Hi Martin,
Have you tried it with X-Plane11? I couldn’t get it to work.


#105

ok, i shared it there…we will see.


#106

Yes, thats true. I will try to reach them through the Pimax instead I think. They have contact with Nvidia of course.


#107

Could anyone confirm if the new version 132 of PiTool solves the flicker when using this trick with high GPU utilization ? I can’t test until later tonight :slight_smile:


#108

It could also be SteamVR bug or feature. Indeed, it seems like something causes GPU to idle, like vsync. However, the way both OpenVR and Oculus SDK work, they have functions for frame pacing, where they tell app to not render the frame, because it is considered pointless for one reason or another. I personally was not able to reproduce this “default” trick, but since you guys notice flickering, I guess what happens this trick messes up frame pacing. Rendering more frames will increase GPU load, but not smoothness.

All that said, what a mess! We really need someone to rewrite Steam VR in open source, so that we can have quality Open VR host. Just look how much better Open Composite is than Steam VR, I suspect Steam VR itself is not that greatly written + they keep breaking things.


#109

Yes, I have a ticket open with them that’s been escalated to level 2.
@Hammerschaedel, @SweViver

In the last message I received, the responder wrote:

Thank you for contacting Nvidia Customer Care. My name is xxxx and I will be assisting with your case. Looking at the video it does seem strange.

Did you have any of these overclocking software versions installed on your system prior to discovering this video? Or was this the first time you have any type of overclocking software installed?

Is this issue specific to VR games? Do you notice any GPU usage issues with Non VR games and this issue would fix that?

I responded just now and provided a link to this thread. We’ll see what the next step is…


#110

Thanks for doing this :slight_smile:


#111

No flickering at all for me. Yesterday was my smoothest rFactor 2 experience ever.


#112

Sounds like game dependent - also, stuff I am saying might be BS, it is shameless baseless speculation. Well, not entirely, because I know OpenVR and Oculus SDK and worked on Open Composite for rF2. I am also looking into rewriting Steam VR, but it is a lot of work and the only obvious benefit will be no forced upgrades, which might not be worth it.


#113

I know, I was using Open Composite with the Rift before acquiring the Pimax. Thanks for that work by the way.


#114

After updating to latest Nvidia driver and PiTool v132 I cannot trigger any more the GPU workload increase in DCS…


#115

Same here. But after reinstalling the v129 version it still works even with the latest nvidia driver. So I’m staying on v129, the performance increase is simply too good to give up.
@SweViver Can you ask the Pimax devs to look into this further? Maybe it’s the high GPU utilization fix that caused this. If it is then could they give us an advanced option to disable the fix from pitool and let us manage to stay below 95% threshold with game settings where there is no flickering yet.


#116

Yes. Latest Nvidia drivers Ok but Pitool 132 is a no go. Returning to 129 works. I’ll stay there for now.

It would mean, as you wrote, that the GPU utilization limitation is in Pitool.This is odd since Oculus Rift users reported being able to use the tweak in the video comments…

Please fix this as soon as possible @Pimax-Support to unleash our GPUs. Thank you in advance!


#117

Same for me. From my point of view, that means this is only Pitool not able to use 100% of your GPU. Not a driver or a game problem. @SweViver please report that to Pimax devs.Their current software is making the Pimax helmets far below their real capacities…


#118

If this is a PiTool problem, it’s our BEST chance at solving the issue. I would hate to rely on Microsoft or Nvidia for a solution. I’ve also tried the trick last night in rF2 and indeed it does not spike the usage anywhere near what .129 does. However, I did find that the GPU usage was sitting around 85-86% just sitting in pits, which means that already PiTool .132 seems to be making better use of the GPU capacity. So I guess it looks like we’re stuck in the middle of previous PiTools. Getting more than the 70% without the GPU trick, but less that then potential 95% possible with using it.


#119

Tried 132 with NVidia 430.86 drivers and Evga X1. After clicking on default a few time my PC became unresponsive. GPU utilization went to 0%. I had to hard power cycle the PC as my mouse would move just a little bit every minute or so.


#120

p.s. I think it is a combination of things: Nvidia drivers not correctly utilizing the GPU and PiMax render pipeline not able handle things correctly when the GPU is nearly at 100%.