The GPU utilization boost is not only working with DCS World, it works in SteamVR games too!



I am on .129 and the Index controllers work great. I used the old driver hack posted around here somewhere, then refreshed the firmware using the other trick (noHMD) and it works great.


Hey guys!

I got an update from Alex about the DEFAULT-tweak. They are still working to find a “fix” for this so we always get the full GPU utilization. But for now, he have discovered what was blocking this “tweak” to trigger in PiTool 132 and 144. They changed something in the LibPVRClient64.dll file upon version 132 that was supposed to fix some ghosting issue, but at the same time this blocked the “tweak”. So Alex have compiled a new dll file as a temporary fix.

So to get the high GPU utilization working again (with better FPS) in PiTool 132 and 144, do this:

  1. Download the file “LibPVRClient64.dll” (from my Google Drive):

  2. Stop or close down Piservicelauncher (or preferrably all Pi-services running)

  3. Replace the current LibPVRClient64.dll file in C:\Windows\System32
    with the new file.

  4. Reboot your PC.

  5. Now, you should be able to do the “Default button tweak” again, and get up to 40% more fps.

I just tested and confirmed this in Hellblade an hour ago, see how it changes the GPU utilzation and fps:

(yes I know the temps are really high in this test, but it doesnt matter if its 45 degrees or 70+ degrees in this case. I had the fans on minimum here)

So now, lets just hope they find a permanent solution for this, so we dont need to do this manuually…



Is this a rollback of the ghosting fix, or just a rollback on what was blocking the trick while maintaining the ghosting fix ?


I assume its a rollback including the new fix for ghosting, but I must double check… Gimme a moment!

Edit: Nope, unfortunately its the DLL before ghosting was fixed. Not that I have noticed the ghosting really when using SmartSmoothing on and off, but I understand this might be a deal breaker for some people.
At least they are working to add the “tweak” ability again including the new ghosting fix, for the next update…


Well, the ghosting is quite heavy on Project CARS 2 (looks almost like temporal anti-aliasing), but it’s not so unbearable that I would pass on the performance gain this tweak bring.

Thank you for the confirmation.


Interesting, I will test, thanks. I just tried DCS World with SS a moment ago at stable 45fps, and I was surprised the stutters/ghosting while rolling the aircraft were completely gone in 144, even when using the old DLL.


Sweviver Did Nvidia respond to you, or acknowledge the problem,


Ok I am experiencing strange results…
If I launched the Pcars 2 with Steam and PP, the trick doesn’t work.

If I launch Pcars 2 without Steam and no PP, GPU usage is aound 90%, without any trick (I just downloaded your dll file), while frame rate is around 25 fps, but the picture is better…


This is interesting and weird. If they’re able to add the ability to use the trick again, surely they know then what’s caused it to go away and also what’s causing it in the first place?

Hopefully we get a resolution to this soon. It’s so nice being able to use the whole GPU!


Check your reported target resolution in steamVR or fpsVR, PP mode has higher target resolutions which would explain the heavier GPU workload.

EDIT: found an old post of mine:

The actual numbers have probably changed since, but you can see that with normal FOV, the workload difference used to be 50% between PP OFF and PP ON.


No unfortunately nothing yet…

Thats strange. I see a difference regarding of using PP on or off, but the performance increase in PC2 is rather small compared to other titles and sims.

Btw, 25fps frame rate sounds very low. Are you using very high supersampling or an older GPU?


The interesting thing is that when having PP enabled, decreasing the render quality in PiTool from 1.0 to 0.75 gives basically no difference in image sharpness or clarity. This lowers the total target resolution to a more reasonable level. Give it a go and let me know what you think!


I got a 2080 ti but Pitools was at 1 or 1.25 with MSAA high and everything on ultra, that could be the reason :slight_smile:
Anyway, the game already shines with SmartSmoothing. I won’t say no to further optimisations but it’s already acceptable for me.

BTW, the picture is really different with and without PP. I don’t know why it is the case, and it’s hard to say which one is better too…


Yeah Smart Smoothing does wonders for PC2! For me I actually get better results running at PiTool 1.0 or even 0.75 and bumping up the in-game resolution scale to 1.5/1.6 or higher. Looks very similar to PiTool 1.0 or 1.25 on standard settings, but with better frame rates. Have you tried that?


I didn’t try that, I thought that it would be the same thing as increasing the pitool settings !

Ok I’ll try that as soon as possible !


Do you have a description on the software you use?


Thanks Martin, I just tried it, what a difference in performance! I can set in game ss at 2.0 and it’s buttersmooth with smartsmoothing, you just made my day :grinning:


Well, Pitool supersamping (coefficient applied to both height and width, so squared coefficient is applied to the number of pixel) doesn’t work the same way as SteamVR supersampling (coefficient directly applied to the number of pixel), so maybe the in-game supersampling is based on SteamVR method, which is lighter.


I tried your trick. I am not convinced that low Pitools//high in game SS is more efficient…(because it’s quite hard to note the visual differences between each settings).

Otherwise it is a good way to fine tune the visuals/framerate.


Currently Im using ther latest Nvidia drivers, latest PiTool + that DLL file I mentioned.
The monitoring software I use is NZXT CAM and latest MSI Afterburner.
Basically no settings needs to be set in the above software, to get the “trick” to work.