The Lab: Hands-on Update - is one hand glitching out for everyone?

issue

#1

Valve recently updated The Lab and added support for the new skeletal input system, among other things. With my 5K+ and the latest SteamvR beta, NVidia driver, and Pitool, the right hand model is rendered as what seems to be a combination of both the left and right hands, flickering between models. Is anyone else seeing this?

@PimaxUSA @SweViver


#2

Yes, I can confirm this. I’m on the same software versions, but using 8k.


#3

Can confirm as well.


#4

I hope Pimax looks after this quickly. The Lab is one of those essential first-experience VR applications, IMO.


#5

Well. Found the problem. And it’s not Pimax’s fault. I just wonder how there are not many more people crying, because currently it can only work for people with index.

In steamapps\common\The Lab\TheLab\win64 are bindings*.json files. Open the right one for your setup (vive?) and see…

"skeleton": [
        {
          "output": "/actions/default/in/skeletonlefthand",
          "path": "/user/hand/left/input/skeleton/left"
        },
        {
          "output": "/actions/default/in/skeletonrighthand",
          "path": "/user/hand/right/input/skeleton/right"
        },
        {
          "output": "/actions/default/in/skeletonrighthand",
          "path": "/user/hand/left/input/skeleton/right"
        }
      ],

See the 3rd entry? Its completely bogus. So it should be

"skeleton": [
        {
          "output": "/actions/default/in/skeletonlefthand",
          "path": "/user/hand/left/input/skeleton/left"
        },
        {
          "output": "/actions/default/in/skeletonrighthand",
          "path": "/user/hand/right/input/skeleton/right"
        }
      ],

And it works!

It’s weird how all bindings are screwed likes this JUST not the index one. It looks so…tinfoil hat on… ^^


#6

Yes, it really worked for my Vive wands :beers:
The third hand was really annoying.


#7

Thanks for looking into it!


#8

Sadly, the situation wrt The Lab is not resolved. Initially, even after changing the JSON bindings, I could still see doubled hand models for each hand! After restarting SteamVR a few times something changed and I saw the correct models in the opening scene with lots of valves, but when I transitioned to the screen with the pedestal where you can choose to start or play the intro, there were no controllers displayed and for the most part I couldn’t activate that UI. Somehow I fumbled around and managed to press the play intro (or possibly it just timed out waiting), but when I got to the Vesper peak orb in the intro and lifted the orb to my head, The Lab crashed. Tried a bunch of times to restart, but can’t get past this.

I’m not sure if it’s the latest version of SteamVR beta, 1.7.13, that broke things (I actually got to play with things when I originally posted), but it’s quite bad right now. I tried with and without Vive compatibility checked in Pitool.

@SBK_VR @Shrike @dga711 @Century - can any of you try the latest SteamVR and reply here with your experience?


#9

So. For me it is like that the hands are still flickering on the opening Scene (Valve) but then in game they are ok.

Not sure about the SteamVR version, will test it when I am at home.
But I’m pretty sure it should only happen because of the bindings and not other software.

@asampal Which controllers are you using? I think your problems go beyond that or the files are not edited correctly.


#10

Just tried The Lab again.
And now I have double arms both :japanese_goblin:

I am on the latest version of SteamVR Beta.


#11

I’m using the vice controllers.


#12

How far into the game can you get, @Century? What SS are you using with the Lab?


#13

I have in TheLAB SS 50, PiTool 1.0, 72hz, PP.

But I didn’t do the settings there.
At the moment, I decided to simplify the settings for Pimax for myself and set PP to constant. Therefore, SS is reduced.

By the way, this is how this bifurcation of my hands looks like:


#14

You’re on the latest SteamVR beta?


#15

Yes, on the latest Beta SteamVR. The icon bar when running SteamVR is blue. (Controllers, stations, etc.)


#16

It’s crazy. Yesterday changing the bindings worked 100%. It was an obvious mistake.

Now the problem is back, doesn’t matter which SteamVR version.

What the hell.


#17

Now I got it working again, even with the latest SteamVR Beta.

@asampal @Century Do Room Setup again from inside SteamVR and then see if it works.Make sure the JSON files are still correct. ex. bindings_vive.json


#18

No, my arms bifurcate again after doing Setup Room.
JSON files are correct…


#19

By the way, I tried a similar application, with very similar hands. There, only the thumbs on each hand are slightly bifurcated. The rest of the hand is fine.


I could not go further than a handshake there, because apparently this is done individually for Index controllers.
But the experience is very interesting.


#20

https://steamdb.info/depot/450391/manifests/

I think there have been updates to the game. Maybe it fixes stuff for you.