This is why I like my PSVR


#1

So last night I was “jonesing” to play another round of The Solus Project on my Pimax 4K, after the game loaded, I found that my Xbox controller would only allow scrolling up and down in the menu, and my headset laser pointer would not highlight the “LOAD GAME” icon, so after fiddiling with Steams controller setting I just gave up. This is when its just nice to be able to insert a disc into the PS4 console and put on the PSVR headset and not have to worry about ANYTHING, I can just play! With the PC style VR headsets its seems Im always at one time or another fooling with something to get it to work. Does anybody have any thoughts on what might be going on my my Xbox controller. The controller works with my Gizmo VR app which is not tied into Steam. I only have the one game The Solus Project to try it on. Thank for any help


#2

For me, controller issues are usually the fault of Steam Big Picture mode. Trying disabling all controller settings in big picture, try Solus in VR, if it doesn’t work enable your controller and set it up again.

That is, if you haven’t accidentally enabled motion controls in Solus. I did that once.


#3

I had the vive since launch… it is just like the PSV4 in steam. Start a game have the headset on and go.


#4

Not tried it, but SteamVR has its fair share of weird quirks and controller troubles.


#5

Yeah, they even messed up the WMR completely in the last SteamVR beta, I had to return to the non beta version, the screen was being rendered in a desktop window in the Mixed Reality Room, with no way to enable 3D at all…just a virtual desktop window with the games on, so lame…phew… :-/


#6

Thanks for the reply and help!! Ok so I went to Big Picture mode and went to SETTINGS, then CONTROLLER then CONTROLLER SETTINGS and noticed that the “Guide Button Focuses Steam” was the only one checked and also note that when my Xbox controller is on , this screen shows under “detected controllers” “Marc’s Xbox controller : Xbox 360”,Anyhow I unchecked “Guide Button Focuses Steam” , then went back to Solus with no luck, so I came back to controller settings and tried checking the Xbox Configuration Support", that didnt work so I came back to controller settings and set it back to where it was before and checked “Guide Button Focuses Steam” , this still didnt work. Just to clear up what my problem is… The white dot or curser that you guide with your head in the Solus Project menu will not light up the boxes, I can hover the curser/white dot over the menu boxes but they dont highlight for me to check. My up and down and A and B buttons work so it seems that the controller might be working ok, the problem is that I cannot get the white dot curser to highlight any of the boxes in the Solus Projects mune screens, like the autosave and save slots to load a game. Hmmmm


#7

Right.

So maybe it’s the game itself. If you haven’t, try running the Solus beta branch. Right click the game steam>properties>beta.
Maybe it is a bug that got fixed in the beta.

I do vaguely remember some kind of similar problem.

What version of Piplay are you using?
Are you on SteamVR or SteamVR beta?


#8

I was thinking the game was the issue too, Ok I right clicked the game, clicked properties and then clicked betas, there is a tab that says “Select the beta you would like to opt in to”. I have the choices: #1. NONE-Opt out of all beta programs(I think this is what is running now) and #2. 411finalbuild. I am running the PiPlay that was supposed to have less ghosting. If you need me to tell you exactly the version I might need some help finding out that, lol. Im not sure how to tell if Im on SteamVR or SteamVR beta. When I start a game, a small STEAM VR window opens… Thanks again for helping me!


#9

Just in case, have you made sure the game window is maximised? Click on it after loading the game up. And test it again.
I have thought my controllers were messed up a few times, but it was just that the game window wasn’t active, something else was in front of it.

I use Piplay 2.0.5.46, Solus Project beta final build, xbox controller, SteamVR (not beta). Working here, just tested it.


#10

I tried the 411finalbuild, loaded Solus Project and the pointer was working as it should(highlighting the menu boxes) GREAT!, HOWEVER:( For some reason on my PC I have to restart my PC to get my supersampling in PiPlay to take effect, so I was at 3.0 which is too much for games so I set PiPlay to 1.0, restarted my PC and after that I loaded Solus Project and found the headset pointer not highlighting the boxes again, Grrrr! Maybe a problem with my PC, it started to work but after I restarted my PC it stopped working. hmmm


#11

Also I did notice on games and video players I always have to click on the app window in order to get the controller to start working. I tried reinstalling SteamVR but no avail


#12

I am not sure what is causing it, but may be worth backing up and deleting your steamvr.settings file in steam>config.

That will reset steamvr to default settings.

So if changing Piplay settings messed it up, perhaps Piplay is the culprit.


#13

Ok so get this. I was about 2 minutes from uninstalling Steam. I had just backed up all my games, VR players, etc. Then I remembered what you said " have you made sure the game window is maximised". Well the problem was that my SteamVR window was located inside the Solus Project window and the curser was locked onto the SteamVR window instead of the Solus window, so I moved the SteamVR window off of the Solus window and clicked the solus menu, problem solved, man what a pain, lol. thanks for all your help, much appreciated.


#14

No problem. At least now you know.