Trigger doesn't work on Pirate Trainer, Space Junkies, and First Person Tennis

issue

#1

I’m using Pimax 5K XR and the Vive controllers and PiTool 132. The 3 games above load fine but when I must click the trigger to choose a menu item, the game doesn’t see the trigger click. Other games like Skyrim, Beatsaber, and AR-10 work fine.

I tried fiddling with the controller bindings in SteamVR (though I saw nothing that looked off), rebooting, changing Vive compatibility in PiTool, re-pairing the controllers, but nothing has worked.

Ideas? Do these games work for anyone else?


#2

Space Pirate Trainer and Space Junkies work as expected with vive wands for me.

Maybe try rebinding or binding the trigger action the the menu button or something just to see if it works.


#3

Sounds like a binding issue on the controllers you should be able to change those settings through steam.


#4

Hmm this is strange. I will report this to the team. Have you tried the latest version 144 btw?


#5

Do you have joystick or any other controller conected to usb port ? IF YES , DISCONNECT and try again.


#6

Ive got an xbox gampad, a hotas and pedals hooked up to my comp, ie lots of analog axis and digital buttons without any issues.


#7

Try disconeccting all other USB controllers. My HOTAS setup sometimes acts weird in SteamVR and prevents VR controllers to work at all.


#8

My gamepad is not plugged in. I also unplugged every device other than the usb vive transmitters, mouse, and keyboard and rebooted. That didn’t fix it. Before this, I also restored a backup from July 10th, which was before I installed pitool 144 (which was when my vive trackers stopped pairing and after that I noticed the trigger stopped working).


#9

Do you have the same issue when Parallel Projection is OFF? I remember X-Plane 11 had this issue only with PP enabled, but its fixed now as far as I know. I will report this anyway, somethings is definitely wrong!


#10

Sadly, turning off parallel projections makes no difference. I also tried restoring a backup from July 4th, which helped me to get my Vive trackers paired again after they got hosed up using PiTool 144. However, it did nothing for the trigger issue (though I don’t know how long this issue has existed as I didn’t notice it until I bought the First Person Tennis game). But, it’s not just my computer!

I have a second Pimax (a 5K Plus rather than an XR) and a second set of Vive controllers (but no Vive trackers here). I hooked the 5K Plus up to a second computer where I have a Vive Pro that works fine with the tennis game. When I installed PiTool 132 and the latest firmware, the Tennis game actually worked when I started it for a minute. But, I exited as I needed to plug in my earbuds and switch my audio from my TV, which I used Advanced Settings to do. During this process I dismissed a generic Steam error message on the desktop, then loaded Tennis again, but this time it ignored my button presses just like my first computer and Pimax! I rebooted the headset, and the computer, but the problem persists.

I thought maybe Steam downloaded some bad setting from my account from the cloud. If so, what might that be?

Anyway, I logged in under my wife’s account and shared the game to her with Family share. Unfortunately, even after uninstalling and reinstalling the game, the issue still exists under her login too on the second computer and Pimax.

For the Space Pirates game, sometimes it fails to display any controllers at all, and other times the controllers appear as guns, but all buttons are ignored.

I have noticed that when I’m in VR, select manage game and configure controllers, it pops up “No controller exists” no matter what game I select. Is that normal?? When I select devices and configure on the desktop from the SteamVR app, it launches the controller binding app, lists each game I have, and everything appears normal with the default bindings set for the trigger and other buttons on Tennis and other games. (again, many/most games work like Skyrim, Beatsaber, Lab, etc)

This is frustrating as trying to play tennis with the narrow field of view of the Vive Pro is especially difficult and not fun. I’d love to get it working for the Pimax so I can see where the ball is along with my racket.


#11

Interesting, thanks for the report. Have u tried the new PiTool 180 just being released? Seems like it has fixed issues with controllers, including Index controllers.


#12

I haven’t tried v180 yet. I’m a bit gun shy after having problems with v144, but I may try it on my secondary computer when I get a chance.

Oddly, I’ve had a couple of times where the system button stops working in Skyrim with v132. I thought it was weird, so I tried these 3 games again and they were all working! However, after I rebooted my computer, Skyrim worked and the buttons for the 3 games went back to not working.

This has happened twice in the last couple of days. Very, very strange. I can’t think of any setting I changed that would have caused it. As far as I can tell, it’s been random. It’s like something has been sabotaging the button bindings.


#13

I have this problem in superhot. Can’t pick up the gun during the intro.


#14

The good news in version 180 seems to have fixed my controller button issues. It also pairs trackers much better (I could not re-pair them again until upgrading to 180).

The bad news is that it stutters badly in Skyrim VR where it runs perfectly smooth for 10-15 seconds, then stutters for a split second when it worked fine in v132. Beatsaber stuttered briefly too, but less frequently.

I see other people reporting this issue too with various games. Any fix to it?


#15

Robo Recall : I cant grip my guns with the index controllers and still got the height bug . I am too high of the ground . With Robo Revive I dont have the height bug but I cant play any mission because the select button doesnt work.

In seeking dawn I get flickering screen due to too high gpu usage in this game.

The climb doesnt render the resoltion right . Pi tool render changes have no effect in this game.
Defector is broken , everything is too dark …


#16

Hmm… Do you have any MSI LED software running in the background? Try stopping the process running in the background and see if it helps! This is one of the most common cause for frequent stutters/judder every few seconds. Many users have eliminated this problem completely by just disabling the LED software.


#17

Same goes for Asus Aura software too (equivalent of the MSI stuff).


#18

I removed the LED light software and every background program that ate up much CPU time or was unnecessary when I tried v180 and even tried Process Lasso to CPU prioritize all VR tasks. It made no difference. My i7-8700K CPU uses only 25-30% while playing Skyrim. I also have an RTX 2080TI and 4000mhz DRAM and an SSD. You can’t really get much faster than the rig I have.

No, it’s PiTool 180 that has serious stuttering issues with whatever changes they made. Usually, I see both the GPU and CPU spike at the same time in fpsVR during a stutter, though not always. In Skyrim, it happens every 5-10 seconds no matter where you are in the game. It’s unplayable. For Beatsaber, it’s less often, a few times or so per song. If you check the forums, you’ll see various other people reporting this issue.

Please make sure Pimax knows about the v180 stuttering issue as it’s the biggest problem I’ve ever encountered with their software.


#19

Interesting. Are you sure this only happens with PiTool 180? If you revert back, is the problem gone?

The problem here is that I cant reproduce this isisue, not on my desktop PC nor my laptop. There must be something in your system that spikes every 5-10 seconds. The difficult part is to find it. It could be BIOS related, Windows related or simply some 3rd party software or wrong/outdated driver. It could also be a USB conflict.

Try disconnecting most/all of your USB devices and try again. If you have any PCI-E cards, try removing them (especially if they are on the same PCI-E lane as your GPU. Wich could decrease your PCI-e lane from x16 to x8 or even x4 which is too slow and could cause bandwidth issues).

Stutters every x seconds are also often RAM memory related. Wrong RAM timings maybe? Or a faulty stick?

By the way, is your GPU/CPU overclocked?

Another thing could be you need to update/reinstall your audio drivers, which can cause loads of weird issues… Or uninstall fpsVR and OpenVR Advanced Settings if you use these (they have caused many issues lately)

Lastly, I would suggest that you test your Pimax headset and latest PiTool 180 on a different PC to see if the problem remains. If not, then its definitely your PC that struggles.


#20

As I mentioned before, the stuttering appeared when I upgraded to v180 and went away after I reverted back to v132. I’ve also seen two or more similar reports on the forums of people experiencing the same thing (in the v180 thread). This update definitely has a bug that affects some people, rendering the upgrade useless.