Unable to connect Pimax4K with streamvr


#1

Hi, i’am glad to be an Pimax4K owner from two day now.
But despite a new windows 10 pro 64 bit installation, and a fresh install of streamvr and pimax4K drivers, i can’t succeed to configure streamvr with pimax4K : the icon of HMD is green but in the roomscale i can’t succed to calibrate (stand up calibration).

Could you give me some help ? i’am in pimax mode.
In the video mode, i can see 2D and 3D video. And in pimax mode i can see video and short game demo from pimax soft.

Best regards.
FredJ


#2

Hi Fred to get te headset off the floor you need to enter height manually. Ie change to your approximate height


#3

If for some reason you can not set the height, you can try this “fix” and then adjust the height again.
http://www.kegetys.fi/floorfix-tool-for-re-calibrating-the-floor-level-in-steamvr/

If I misunderstood, just ignore my post. :wink:

I think to set up the room, you need a NOLO.


#4

Hi Heliosurge.
Yes i known, in fact i can’t pass through the link step with the base station, as there is no base station and i think about a driver pb but wich one ? Pimax or streamvr.
I have already made a lot of install (steam, steamvr, pimax)on my pc, and the last concerning the OS to try to pass through…

Any idea ?


#5

And i get this message from steam : shared IPC compositor connect failed (306)…


#6

I remember seeing an error like that within thw laat month.

If mem serves believe needed to do re install.

Do so with inet disconnected & antivirus disabled. Run setup as admin.

Try this on piplay.

Other thing if you have on-board video disable it in bios.

Also ensure all instances of pi server & piplay killed in taskmanager


#7

thanks WalterDas Trevas, anyway your fix will be usefull for someone else.


#8

Heliosurge, i ve already disable the on board video by the bios and run setup as admin. When you told to kill all the instances of pi server end piplay in taskmanager, you think before reinstall piplay ?


#9

Yes if the pi server or piplay running will prevent files be overwritten with the new versions needed.

The other steps i always include in case any new user reads helps them out. :v::wink::+1:


#10

ok anyway i’ll tell you if i ll succeed or not. The last piplay in beta version could help me also ?


#11

Its possible. Haven’t checked it out yet. But always make sure no part of pi is running as files that need to be replaced some will reside in memory.

Usually 2 instances if pi server one the P is capitolized


#12

Ok despite a new install, (with the last beta drivers), with windows defender disconnected, it’s not a success until now… So i am looking for all your ability to help me. Waiting for new comments…

Best regards
FredJ


#13

This is a solution to the error code I wrote in the past, Try it~!

  1. Install latest version of graphics card
  2. Run SteamVR> SteamVR> Settings> Developers> Enable Direct Mode> Exit SteamVR
  3. Kill the VR Server.exe (Task Manager> Process)
  4. Usb connector unplug&plug-in
  5. Run SteamVR

#14

If Crony’s solution doesn’t work. May need @PIMAX-Support to setup a skype with teamview.


#15

Thank you guys.

@fredotaz Could you please use Debug_tool in Piplay setting to export logs to support@pimaxvr.com ? We will analyze it and find out a solution.

Edit: Maybe this post could help you for this case, link at: [Resolved]Should I return it?


#16

Hi guys ! Thanks to your helph. The Crony solution doesn’t work, so i will try to install a 381.xx drivers and if it doesn’t work also, i ll use the debug tool.


#17

Dear all !!!
You are the best !! With the old drivers (381.65) i succeed to pass through the streamvr room and i saw the virtual stream room ! I’m so happy, so now i have to face the ghosting effects… like the others.
See you soon for another questions.

Best regards,
FredJ
PS : do you think the last drivers will support the pimax4k one day ? what kind of version you use ?


#18

With the Graphic drivers usually one side or the other usually gets them working so to speak.

Namely either a new piplay release or nvidia driver release will support better.

For example when Star Trek Bridge crew was released PiMax & presume other headsets were not working. It was discussed here & dev team made note. Before PiMax released a new version; bridge crew released an update fixing the issue.

I am in the Red Camp (AMD) think i might be upto date though possible not. Linux imo still seems to be better at keeping the whole system upto date


#19

Dear All !!

After few month using successfully the pimax 4k HMD, i decided to made a new pc specifically for VR.
So i came from a ZBOX EN860 with a 860M “graphic card” to a new pc with Ryzen 5 1600, and GTX 1070 Ti.
And after new windows 10, piplay 2.0.7.54, and steam vr installation, i have to fight with the same issue i get before : error 306 and 400. The Helmet is green, but can’t be seen by the base !! CRAZY !! I have also tried graphic drivers from 388.13 to the last 388.71… but nothing seems to run until now.

Do you have any new idea ? the drivers i used before (381.xx) are not usable with gtx 1070 Ti…

Thanks for any help you could brings me.

Best regards
FredJ


#20

Try reinstalling steamvr. Without Nolo it shouldn’t be trying to see the helmet with a base station.

@lukeb & @Enopho have reported lastest nvidia drivers are good