Warthunder render issue?


#1

Warthunder has a very annoying issue (see a picture or video) and i guess it happens only to pimax headset.



Screenshots and the video are from web

Is here anyone who plays warthunder and has no such issue? Any solutions how to resolve the problem?


Warthunder Unplayable 1.1.92
#2

Yes, I have the exact same problem. Which version Piplay do you have?


#3

Same issue here posting to Gaijin bug forum you should too.

FW= 1.0.0.248 Piplay=1.2.53 Steam VR Beta


#4

Have bug report here if you have same issue still please add to thread at:


#5

I solve this problem. Just open exe file in Open Local.


#6

Did this issue happen in PC Screen or display of Pimax?


#7

And PC Screen and Display Pimax BUT Only in SteamVR mode, in Oculus Mode (Open Local) no issue.


#8

Yes it displays the same on desktop and hmd. Could you elaborate on “open local” procedure? Do you mean don’t use the War Thunder launcher? I have tried with and without steam VR / Piplay running and get same result.


#9

Also please note I am running 1.1.92 with FW 1.0.0.248


#10

Also please note I am running 1.2.53 with FW 1.0.0.248


#11

I have tried both 1.1.92 and 1.2.53 same issue. Pimax and Steam VR both on and one without the other no differnce. If VTS or someone that has Warthunder working properly could elaborate the process that would be great. I have tried opening “aces.exe” from explorer didn’t make a difference and see no option for “open local” in the Pimax software.


#12

PiPlay 1.2.53 has button “Open Local” near to button “SteamVR”. Just click “Open Local”, open aces.exe and choose “Oculus Game” (not Steam !). Then Warthunder open in OVRLauncher window.


#13

Got it thanks so it is not an option for 1.1.92 I am sticking with until the Image quality issues are confirmed fixed with 1.2.52. I will probably just wait for IL-2 2.009 next week but thanks for elaborating!


#14

Just tried as described above using new 1.2.57 open local. I am wondering if this is just how Warthunder does it’s VR. The cockpit view is a bit blurry and the sights are unusable? Is this just the case. I can see the cut off portions in the corner of my eye at the edge. Note I am getting this "binocular effect probably because the foam could be a bit thicker. I just want to confirm that the split screen on PC monitor does or does not look like the above screencaps.


#15

I got the same binocular effect, but since I play Elite I can at least pretend it’s part of the helmet


#16

“Open locale” haven’t helped me as well - game still lunches in steam VR mode with this weird separations in the middle and I believe they affect in headset image as well - I think thi is what makes “sights unusable”
In I do think that this is not “just how Warthunder does it’s VR” because other screenshots (made on vive or oculus) on the internet does not have this weird look.


#17

Agreed I am doubtful that this is how it is implemented but would need someone to post screens to confirm. I put in a bug report to war Thunder and pimax support is aware of it so we shall see if it ever gets fixed. To be honest I do not really care anymore since IL2 BOS/M has got VR support today. Haven’t tried it yet but sounds terrific hopefully us Pimax users will have no problems with that!


#18

Hi, I tried War Thunder (Steam) and it seemed to display correctly.
It was the first time I have accessed the game and so I was in the training screen, but all seemed to display ok.
I’m using the latest firmware and Piplay Fw 1.0.0.251 and Piplay 1.2.57.


#19

What is IL2 BOS/M? That’s a new one??


#20

IL2 Battle of Stalingrad, Moscow, next is Kuban than Pacific supposedly. Much more realistic sim (can still play arcade like) Been out a while, long legacy of IL2 games check it out. I havent been on in quite a while but the multiplayer numbers were very low before, but for VR single player missions etc are just fine for me.