Warthunder render issue?


#21

Also luke could you confirm that your mirror scren DOES NOT look the screen caps at the top of the page. In VR the image still looks ok, but the sights are weird and there is strong paralax, With my binocular effect from mushed foam I can see it is putting these weird cuts from the middle to the outside of the opposite screen.


#22

Hi Lonny,
On the pc screen I get the left and right eye images as you initially described, but in the HMD the display is correct with all menus visible and correctly usable.
In the HMD there is no binocular or parallax apparent.
Unfortunately I don’t know how to get a capture of the HMD image in the game, but pressing the keyboard Windows key allowed to get this pic of the SteamVR mirror screen showing left and right eye. Probably not very helpful.

Also, does War Thunder support a HOTAS joystick? Can’t see it in the control options.


#23

I believe steam vr has a hmd mirror option somewhere in the options, I will try to confirm this in the next few days. War Thunder does support joysticks/hotas just need to go into customize controls (I only set up “full real” I think it was)


#24

OK, thanks. I’ll check it out.


#25

I have the same issue, there is a kind of overlap between left view and right view. On the screen, it appears like on the screenshot below. In the Pimax headset, I can see the wron vertical band on the edge of field of view. It feels like using a headset for mobile where you didn’t put the mobile at the center and you see a bit of the other screen.

I tried to run War Thunder using “Play local”. No changes
I tried to edit the config.blk of war thunder and to add oculus:b=yes. No changes whatever parameter I put in the oculus section

I am using PiPlay 3.0.0.81
Firmware 1.0.0.265


#26

This bug is related to IPD. Try to set the IPD as low as possible in the Piplay/Pitool, then start up the WThunder, aaaand there it is: the WT somehow ignores the correct IPD setting from PiStuff, just displays the picture correctly only at the lowest value.
Few months ago it wasn’t present, but as far as i remember, it came with the latest big patch. Also, this issue reported a lot of users, but no response from the developers.
Russian style - they even don’t give a shit to the customers… :confused:


#27

Thanks a lot Tomz71!!!
It worked indeed!!
It seems that the problem appear when the IPD is greater than 60.5!

Thank you very much Tomz71!!!