Washed out display

issue

#1

New user, so very grateful for any advice. Anyway, in short my screen in ‘Pimax Mode’ looks extremely washed out. I can’t think of another way to describe it.

‘Video Mode’ is fine. It’s just when it’s in Pimax mode.

I’ve tried switching over to ‘Video mode’ and playing around with the settings in the Radeon tool - both contrast and brightness. Then switched back to ‘Pimax Mode’. It makes some difference but I can’t get it anywhere near ‘acceptable’.

Would love to hear any suggestions.


#2

I think this can be a personal taste thing. Some people like popping colour and others more natural. My understanding is the Pimax 5k+ and 8k LCD panels don’t provide the vivid colours of the 5k xr OLED model (however they have other advantages).

I have the 5k+ and for me Pitool 1.0.1.121 Beta Test Release with brightness - 2 and contrast 2 made a big improvement.

I’ve started to reply and then spotted this is in the 4k section so not sure if it’s compatabile :thinking:


#3

Hi… thanks for the reply. Yes, this is for a 4K. Sadly this level of over saturation would not be to anyone’s liking…

Again, that for the response.


#4

The display lacks good color overall but have you tried anything like Virtual Desktop or Bigscreen to gauge video quality?

PiTool 1.0.1.121 works on the 4K, it has some options that may be of interest.

If using Piplay 1.1.92, ensure 2K support has been enabled in the Settings options.
Also, run the Debug Tool & adjust the brightness options.


#5

Have you tried pitool 121 beta? P4k has support now from my understanding & may have some new options available.

Just be sure to kill piplay & pi services before launching pitool.

@TheDeaX have you tried new pitool on p4k?


#6

No i not tested… New update?


#7

There is pitool 121 beta. For 5k & 8k they added contrast & extra brightness control not sure if option is also for p4k.


#8

Yes it have contrast and more options



#9

Hey guys… thanks for all the replies. I was able to correct the issues with your help.

In short, I think I erred in installing the latest versions of PiPlay and PiTools. So, I uninstalled everything and started again with 1.2.93. Seemed to do the trick, so now I have a functioning headset again.

Thank you again for the help. Really appreciated.


#10

freeze issue catched https://youtu.be/hH2FRLxQDeQ