Where to find Virtual Desktop apps


Finding support for the pimax 4k is difficult. I can’t get any of the virtual desktop apps to work. I have read on the forum that they do work but It’s not happening here. Steam and pimax are incompatible as of Dec 6, 2017 from my experience.
I’m not a tech guy. It just seems like I have this 4k device with no support like hive, oculus, and windows mixed reality. I can watch videos on piplay but switching between trailers requires me to remove the headset, hit escape, find my video, and put the headset back on. If I had a virtual headset this would be so much easier. This and the vertical lines on my screen are making me regret this purchase. I’ll figure a way to make music videos on piplay I guess because I can’t use any other type of player.


Just install REVIVE. I ran Virtual Desktop right now, it’s working perfectly.


Have Oculus Software installed as well.


“Revive” is only a workaround for software that is exclusivly for Oculus Rift. You don’t need that and you don’t need Oculus software neither! “Virtual Desktop” and the great free alternative “Bigscreen Beta” should both work out of the box just like any other software that supports SteamVR/HTC-Vive.

Have you installed and launched SteamVR in Steam?


Since the PiMax headset is primarily using steamvr. Topics on the Vive will help.

I haven’t ran VD; but have used Bigscreen Beta.

Just look for vive & occulus users who are having the same trouble


Why do you think steam is not working. It was fine last night. I used both big screen and virtual desktop from steam with no issues


Never said steam wasn’t working. Just mentioned it as when a prog not working right don’t need PiMax specific help. Vive users who might have experienced similar problem.

Steam itself is just a launch point one can launch a steam program without inet.


Revive supports Pimax without Oculus Software with Piplay 1.1.92 driver?


i was going off the original post where it was mentioned

“Steam and pimax are incompatible as of Dec 6, 2017 from my experience.”

I am not sure what this means …


For what it’s worth, BigScreen seems to work a little better with a headless ghost, where you can select which “monitors” you want to appear on your virtual desktop.

My main monitor is a 3440x1440 21:9 which takes up a lot of virtual space if I want to be able to read text, but I also have a 1080 ‘headless ghost’ that is perfect to just pin a web browser into


Ah my bad. Looks like he’s having trouble playing or making videos?


Downloaded rift software and it doesn’t recognize my headset. Tried finding direct mode in steam settings but could not find it. Piplay does not have a direct mode either. Nothing works for a virtual desktop. Perhaps someone could point me to the step by step instruction of how to get my pimax 4k to work in steam. I don’t see how regular people without tech degrees are operating this with steam, rift software, etc,. Nothing recognizes this headset. I get the feeling this company is just winging it. It seems like they find quick fixes in the forum but nothing a consumer count on. I should be able to plug in, follow instructions, and enjoy the thing. I have spent all night researching this headset, trying fixes suggested on the forum, and getting nothing done. All I need is a clear path to 1. getting steam to recognize the pimax 4k headset. 2. getting the virtual desktop apps on steam to work.


Hi Jason, can we use “Teamviewer 12” now? I would like to assist you remotely.

Piplay 2.0.X actually integrated previous “Extend mode” and “Direct mode” into the “Pimax mode”.
Is there any SteamVR issue popup? Are you using laptop or desktop?

Edit: If you use Nvidia GPU card, I suggest that you may manually install its driver same as below:


Is the headset recognized in Piplay? If so PiMax mode is direct & extend mode. Ensure headset is in pimax mode.

Launch SteamVR. Headaet should be recognized in steam. If not re install steamvr.

If headset not recognised in Piplay; reinstall as Admin.

Try the driver support mentions. Also if you have igpu (usually intel) disable in bios.

The other common interference is how is your monitor hooked up? Headset should be on native hdmi & monitor on Display port with an adapter if needed. Hdmi & dvi sometimes causes interference even on rift & vive. There are also nvidia 1070 & 1080 cards that are not vr ready as advertised (generally ones that use the nvidia reference design) as mentioned in Nvidia forums & elsewhere.


Yes. Piplay works fine and the vertical lines are getting better it seems. It is in pimax mode. I have reinstalled steam vr three times with no success. I have reinstalled piplay twice. I have no idea what a “driver support mentions” is. I have no idea what igpu is either. Going into the bios is something I leave my computer experts to do. I don’t think this is a hardware issue. I simply think steam does not support this device. It shows rift, hive, and one other device on the apps. I don’t see any pimax icons on the apps. The Bigscreen app says that I need to plug in a headset into the hdmi, it doesn’t detect the pimax headset. The trouble shooter on steam said something about direct mode but on its software under settings…I could not find that under any of the tabs.


Igpu - internal Graphics. If you have an Intel Cpu you likely have onboard graphics.

PiMax is a steam compatible headset. The headset more or less is seen as a Vive headset for comparability.

The headset is fully compatible with steamvr. You must have a software and/or hardware conflict.

Have you tried installing tge Nvidia driver support mentioned?

Might be best to setup with support a Teamview session.

Di you have a vive or rift? If not then the problem you have would likely affect them.

Please post your system specs.
Windows Version
Graphics Card & driver version


You said you downloaded rift software ? You don’t need that (for now)

Create a steam account, download steam client and install then install SteamVR. Once piplay is running you can start SteamVR and the headset should be detected and you can run the setup

You can then add big screen from the steam store and run it via steam.


Steam suggested that I delete my asus al suite program in the trouble shooting section. It works now but is very unstable at higher resolutions. I have to restart the program a lot when running with the slider on 3 in 1080. The video player on steam requires lot more of gpu resources than running through piplay alone. My guess is because the virtual world in steam is using gpu on top of the video player inside it. At least it works at a lower resolution. I am using an i7, gtx 1050 ti, and 32 ram. Hopefully my new pc with the gtx 1080 ti will make the steam software run smoother when it arrives. VR in movies require a lot of resources, I am eager to get into gaming but if movies are a struggle I can only imagine how poor gaming in vr will be with my current setup.