X-plane Oculus home and Pimax5k+

issue

#1

I just got my 5k+ today. I’m trying to launch x-plane from its desktop shortcut. It’s a stand-alone application. When I launch it SteamVR closes and the main menu for x-plane opens. Loading a flight often results in a crash to desktop. I’m also noticing oculus is opening on the desktop when I launch the sim.

Anyone else have issues with apps or games which have native oculus and openVR implementation being confused during launch.

Should I kill all oculus processes in task manager or do I need to remove oculus home altogether?


#2

@yanfeng might know something as a simmer


#3

I can launch X-plane on 5K+ fine with or without Oculus process running.


#4

Steam version or stand-alone?

Something very weird is going on. SteamVR crashes every time I launch xplane and I get the pimax logo in the headset before x-plane opens. I can get to the main menu but x-plane then crashes when I start a new flight.


#5

Mine is stand-alone version.
What’s your GPU? I used to crash a lot when I was running 1080 and high graphic setting on Samsung Odyssey. It’s too demanding for CPU and GPU power and memory. Try lowering the setting and see if it helps.


#6

I’m using stand-alone latest version. 1080ti, 5.1ghz 7700k and 32gig of ram. I’ll try lower settings. It has worked a few times with the exact same settings and flight loaded. On those occasions steamVR did not close. Its when steamVR shuts down and oculus software opens automatically that I have the crash, which is weird. Nothing in my crash logs.


#7

When I run x plane on my Odyssey+ the Oculus software starts, but SteamVR keeps running too. I can then close the Oculus software and x plane and steamvr keep running fine.
I think your problem may be with whatever is causing steamvr to close.


#8

I solved the issue. The steamVR and x-plane crashes were caused by my cpu overclock. I dialed it back from 5ghz to 4.9ghz and all is fine. I guess it wasn’t as stable as I thought it was. I’m now running the same settings as I had with Rift at 1.6. Pitool at 1 and steam SS at 100%. Thanks for your input guys.


#9

Awesome news. Yeah overclocking can cause instabilities. Why I myself let my Ryzen & 1080ti look after themselves. :beers::sunglasses::+1::sparkles: